summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Arias2020-10-03 12:19:25 +0200
committerPablo Arias2020-10-03 12:19:25 +0200
commitcb9e568e9a984281eba2e0c1b55f9bb1b9fd26a5 (patch)
treef2025a5cc2c3edfbac11564779ccd02b45e9fff6
downloadaur-fontpreview-ueberzug-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f18b8c4d931
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fontpreview-ueberzug-git
+ pkgdesc = Preview system fonts in the terminal
+ pkgver = r19.63e6b4c
+ pkgrel = 1
+ url = https://github.com/OliverLew/fontpreview-ueberzug
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = fzf
+ depends = imagemagick
+ depends = ueberzug
+ source = git+https://github.com/OliverLew/fontpreview-ueberzug.git
+ md5sums = SKIP
+
+pkgname = fontpreview-ueberzug-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25c6f57c6d09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Pablo Arias <pabloariasal at gmail dot com>
+pkgname=fontpreview-ueberzug-git
+_pkgname=${pkgname%-git}
+pkgver=r19.63e6b4c
+pkgrel=1
+pkgdesc="Preview system fonts in the terminal"
+arch=('any')
+url="https://github.com/OliverLew/fontpreview-ueberzug"
+license=('MIT')
+groups=()
+depends=('fzf' 'imagemagick' 'ueberzug')
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("git+${url}.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ install -D -m755 ${_pkgname} "$pkgdir/usr/bin/${_pkgname}"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+}