summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Eklöf2020-11-12 08:18:11 +0100
committerDaniel Eklöf2020-11-12 08:18:11 +0100
commit41f22e2b81144f6abf347da7d85a5c2bf642f214 (patch)
tree2b9e293b1a15be06e6121a08d139dc4759c998e7
parent485627bd2737a14f4289ee74ace66c48fcff4352 (diff)
downloadaur-41f22e2b81144f6abf347da7d85a5c2bf642f214.tar.gz
Fix foot-terminfo dependency and add changelog
We can’t declare the foot-terminfo dependency in package base, as that causes a circular dependency: we can’t build neither foot nor foot-terminfo, because we need foot-terminfo for that... Appending foot-terminfo to ‘depends’ in package_foot() fixes the issue; dependencies in package() are only required to *run* the package, not *build*.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD5
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d4b5424263f..8e1220f64593 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = foot-git
pkgver = 1.5.3
- pkgrel = 1
+ pkgrel = 2
url = https://codeberg.org/dnkl/foot
arch = x86_64
arch = aarch64
@@ -17,7 +17,6 @@ pkgbase = foot-git
depends = pixman
depends = fontconfig
depends = freetype2
- depends = foot-terminfo
source = git+https://codeberg.org/dnkl/foot.git
source = git+https://codeberg.org/dnkl/tllist.git
source = git+https://codeberg.org/dnkl/fcft.git
@@ -27,6 +26,12 @@ pkgbase = foot-git
pkgname = foot-git
pkgdesc = Wayland terminal emulator - fast, lightweight and minimalistic
+ depends = libxkbcommon
+ depends = wayland
+ depends = pixman
+ depends = fontconfig
+ depends = freetype2
+ depends = foot-terminfo
provides = foot
conflicts = foot
diff --git a/PKGBUILD b/PKGBUILD
index c60b8adc3393..052270e65b78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Daniel Eklöf <daniel at ekloef dot se>
pkgname=('foot-git' 'foot-terminfo-git')
pkgver=1.5.3
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'aarch64')
url=https://codeberg.org/dnkl/foot
license=(mit)
makedepends=('meson' 'ninja' 'scdoc' 'python' 'ncurses' 'wayland-protocols')
checkdepends=('check')
-depends=('libxkbcommon' 'wayland' 'pixman' 'fontconfig' 'freetype2' 'foot-terminfo')
+depends=('libxkbcommon' 'wayland' 'pixman' 'fontconfig' 'freetype2')
source=(git+https://codeberg.org/dnkl/foot.git
git+https://codeberg.org/dnkl/tllist.git
git+https://codeberg.org/dnkl/fcft.git)
@@ -58,6 +58,7 @@ check() {
package_foot-git() {
pkgdesc="Wayland terminal emulator - fast, lightweight and minimalistic"
+ depends+=('foot-terminfo')
conflicts=('foot')
provides=('foot')