summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeorize2016-12-31 07:16:48 +0700
committerLeorize2016-12-31 07:16:48 +0700
commit0dc380d2e9e853d9c57e2d3d95fd693d79a02b27 (patch)
tree260b0c4dbd95f004e53ba93e692509a32644eca8
parente0430828109fb00d8dde736dee1b2e296e604abf (diff)
downloadaur-0dc380d2e9e853d9c57e2d3d95fd693d79a02b27.tar.gz
Switch to a more consistant quoting scheme
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD56
2 files changed, 30 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09c07367ccd8..698539bda43d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,12 +28,12 @@ pkgname = fpc-svn
backup = etc/fpc.cfg
pkgname = fpc-src-svn
- pkgdesc = Sources for the FreePascal compiler (required by the Lazarus IDE)
+ pkgdesc = Sources for the Free Pascal Compiler (required by the Lazarus IDE)
provides = fpc-src
conflicts = fpc-src
options = !strip
pkgname = fpc-docs-svn
- pkgdesc = Documentation for the Free Pascal compiler
+ pkgdesc = Documentation for the Free Pascal Compiler
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index c429a162f8f8..7adbffa00ea7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ pkgver=3.1.1.r35219
_pkgver=${pkgver%.r*}
pkgrel=1
arch=('i686' 'x86_64')
-url="http://www.freepascal.org/"
+url='http://www.freepascal.org/'
license=('GPL' 'LGPL' 'custom')
depends=('ncurses' 'zlib' 'expat')
# Trunk can only be built with stable version of FPC
@@ -29,69 +29,69 @@ sha1sums=('SKIP')
pkgver() {
cd "${srcdir}"/fpcbuild/fpcsrc
- printf "%s.r%s" \
- $(grep -m 1 'version' 'Makefile.fpc' | cut -d '=' -f 2) \
+ printf '%s.r%s' \
+ $(grep -m 1 'version' Makefile.fpc | cut -d '=' -f 2) \
$(svnversion | tr -d [A-z])
}
build() {
- cd "${srcdir}/fpcbuild"
+ cd "${srcdir}"/fpcbuild
pushd fpcsrc/compiler
fpcmake -Tall
popd
- make ${MAKEFLAGS} NOGDB=1 OPT=" -dRelease" build
+ make "${MAKEFLAGS}" NOGDB=1 OPT=' -dRelease' build
cd fpcdocs
- [[ $_build_docs ]] && make -j1 FPCSRCDIR="${srcdir}/fpcbuild/fpcsrc" html
+ [[ $_build_docs ]] && make -j1 FPCSRCDIR="${srcdir}"/fpcbuild/fpcsrc html
}
package_fpc-svn() {
pkgdesc="The Free Pascal Compiler is a Turbo Pascal 7.0 and Delphi compatible \
Pascal Compiler. It comes with fully TP 7.0 compatible run-time library."
- backup=("etc/fpc.cfg")
+ backup=('etc/fpc.cfg')
options=('zipman' 'staticlibs')
conflicts=('fpc')
provides=('fpc=9999')
- cd "${srcdir}/fpcbuild"
+ cd "${srcdir}"/fpcbuild
- export HOME="$srcdir"
+ export HOME="${srcdir}"
make -j1 PREFIX="${pkgdir}"/usr install NOGDB=1 OPT=" -dRelease"
- export PATH="$pkgdir/usr/bin:$PATH"
+ export PATH="${pkgdir}/usr/bin:${PATH}"
- install -Dm0644 fpcsrc/rtl/COPYING.FPC "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.FPC"
+ install -Dm0644 fpcsrc/rtl/COPYING.FPC "${pkgdir}"/usr/share/licenses/${pkgname}/COPYING.FPC
- [ "$CARCH" = "i686" ] && ln -s /usr/lib/fpc/${_pkgver}/ppc386 "${pkgdir}/usr/bin/"
- [ "$CARCH" = "x86_64" ] && ln -s /usr/lib/fpc/${_pkgver}/ppcx64 "${pkgdir}/usr/bin/"
+ [ "$CARCH" = 'i686' ] && ln -s /usr/lib/fpc/${_pkgver}/ppc386 "${pkgdir}"/usr/bin/
+ [ "$CARCH" = 'x86_64' ] && ln -s /usr/lib/fpc/${_pkgver}/ppcx64 "${pkgdir}"/usr/bin/
- mkdir -p "${pkgdir}/etc"
- "${pkgdir}/usr/lib/fpc/${_pkgver}/samplecfg" "$pkgdir/usr/lib/fpc/${_pkgver}" "${pkgdir}/etc"
+ mkdir -p "${pkgdir}"/etc
+ "${pkgdir}"/usr/lib/fpc/${_pkgver}/samplecfg "${pkgdir}"/usr/lib/fpc/${_pkgver} "${pkgdir}"/etc
# use -fPIC by default
- echo -e "#ifdef cpux86_64\n# for x86_64 use -fPIC by default\n-Cg\n#endif" >> "$pkgdir/etc/fpc.cfg"
+ echo -e '#ifdef cpux86_64\n# for x86_64 use -fPIC by default\n-Cg\n#endif' >> "${pkgdir}"/etc/fpc.cfg
- mv "$pkgdir/usr/man" "$pkgdir/usr/share/"
+ mv "${pkgdir}"/usr/man "${pkgdir}"/usr/share/
- find "$pkgdir/etc/" -type f -exec sed -i "s|$pkgdir||g" {} \;
+ find "${pkgdir}"/etc -type f -exec sed -i "s|${pkgdir}||g" {} \;
}
package_fpc-src-svn() {
- pkgdesc="Sources for the FreePascal compiler (required by the Lazarus IDE)"
- options=("!strip")
- conflicts=("fpc-src")
- provides=("fpc-src")
+ pkgdesc='Sources for the Free Pascal Compiler (required by the Lazarus IDE)'
+ options=('!strip')
+ conflicts=('fpc-src')
+ provides=('fpc-src')
- install -dm755 "$pkgdir"/usr/lib/fpc
+ install -dm755 "${pkgdir}"/usr/lib/fpc
- svn export -r HEAD "$srcdir"/fpcbuild/fpcsrc "$pkgdir/usr/lib/fpc/src"
+ svn export -r HEAD "${srcdir}"/fpcbuild/fpcsrc "${pkgdir}"/usr/lib/fpc/src
}
package_fpc-docs-svn() {
- pkgdesc="Documentation for the Free Pascal compiler"
- options=("!strip")
+ pkgdesc='Documentation for the Free Pascal Compiler'
+ options=('!strip')
- cd "$srcdir/fpcbuild/fpcdocs"
- make PREFIX="$pkgdir/usr" htmlinstall
+ cd "${srcdir}"/fpcbuild/fpcdocs
+ make PREFIX="${pkgdir}"/usr htmlinstall
}