summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeorize2016-12-23 19:28:19 +0700
committerLeorize2016-12-23 19:28:19 +0700
commit79418f9c306fd8a5e1224ff33369432df134347a (patch)
tree5bbeafb9d7a56725799cd677733121b10b52d47a
parent67eb5e5ce0cd564aa740089c63216c895e3fa66c (diff)
downloadaur-79418f9c306fd8a5e1224ff33369432df134347a.tar.gz
Remove makedeps on "rsync", replace ugly symlinks with FPCSRCDIR, restrict fpc-svn from building itself
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD35
2 files changed, 25 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ac00e7c851d..a6098febbf6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = fpc-svn
- pkgver = 3.1.1.r32385
+ pkgver = 3.1.1.r35178
pkgrel = 1
url = http://www.freepascal.org/
arch = i686
@@ -7,11 +7,12 @@ pkgbase = fpc-svn
license = GPL
license = LGPL
license = custom
- makedepends = fpc
- makedepends = rsync
+ makedepends = fpc<9999
+ makedepends = svn
makedepends = texlive-core
makedepends = texlive-htmlxml
makedepends = texlive-latexextra
+ makedepends = ghostscript
depends = ncurses
depends = zlib
depends = expat
@@ -19,8 +20,8 @@ pkgbase = fpc-svn
sha1sums = SKIP
pkgname = fpc-svn
- pkgdesc = The Free Pascal Compiler is a Turbo Pascal 7.0 and Delphi compatible 32bit Pascal Compiler. It comes with fully TP 7.0 compatible run-time library.
- provides = fpc
+ pkgdesc = The Free Pascal Compiler is a Turbo Pascal 7.0 and Delphi compatible Pascal Compiler. It comes with fully TP 7.0 compatible run-time library.
+ provides = fpc=9999
conflicts = fpc
options = zipman
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 23f31ee1927b..62c765ccee84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,20 +8,22 @@
# See http://bbs.archlinux.org/viewtopic.php?t=9318&highlight=fpc
# Build docs
-_docs=1
+_build_docs=true
pkgbase=fpc-svn
pkgname=(fpc-svn fpc-src-svn)
-[[ $_docs = 1 ]] && pkgname+=(fpc-docs-svn)
-pkgver=3.1.1.r32385
+[[ $_build_docs ]] && pkgname+=(fpc-docs-svn)
+pkgver=3.1.1.r35178
_pkgver=${pkgver/${pkgver:5}}
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.freepascal.org/"
license=('GPL' 'LGPL' 'custom')
-depends=(ncurses zlib expat)
-makedepends=(fpc rsync)
-[[ $_docs = 1 ]] && makedepends+=(texlive-core texlive-htmlxml texlive-latexextra)
+depends=('ncurses' 'zlib' 'expat')
+# Trunk can only be built with stable version of FPC
+makedepends=('fpc<9999' 'svn')
+[[ $_build_docs ]] && makedepends+=('texlive-core' 'texlive-htmlxml'
+ 'texlive-latexextra' 'ghostscript')
source=(fpcbuild::svn+http://svn.freepascal.org/svn/fpcbuild/trunk)
sha1sums=('SKIP')
@@ -34,11 +36,11 @@ pkgver() {
prepare() {
cd "${srcdir}/fpcbuild"
- rsync -aq --exclude='*/.svn*' fpcsrc ../fpcsrc
+ svn export fpcsrc ../fpcsrc
- # For documentation building
- ln -s fpcsrc/rtl
- ln -s fpcsrc/packages
+ # Needed to fix documentation building on my machine
+ # FIXME: check if it's required to build docs
+ ln -sf /usr/share/texmf-dist/tex/latex/mdwtools/syntax.sty fpcdocs/syntax.sty
}
build() {
@@ -46,18 +48,19 @@ build() {
pushd fpcsrc/compiler
fpcmake -Tall
popd
- make ${MAKEFLAGS} build NOGDB=1 OPT=" -CX -Xs -XX -dRelease"
+ make ${MAKEFLAGS} NOGDB=1 OPT=" -dRelease" build
cd fpcdocs
- [[ $_docs=1 ]] && make ${MAKEFLAGS} html
+ [[ $_build_docs ]] && make ${MAKEFLAGS} FPCSRCDIR="${srcdir}/fpcbuild/fpcsrc" html
}
package_fpc-svn() {
- pkgdesc="The Free Pascal Compiler is a Turbo Pascal 7.0 and Delphi compatible 32bit Pascal Compiler. It comes with fully TP 7.0 compatible run-time library."
+ pkgdesc="The Free Pascal Compiler is a Turbo Pascal 7.0 and Delphi compatible \
+ Pascal Compiler. It comes with fully TP 7.0 compatible run-time library."
backup=("etc/fpc.cfg")
- options=(zipman staticlibs)
- conflicts=(fpc)
- provides=(fpc)
+ options=('zipman' 'staticlibs')
+ conflicts=('fpc')
+ provides=('fpc=9999')
cd "${srcdir}/fpcbuild"