summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Gu2020-02-09 21:47:14 -0800
committerTimothy Gu2020-02-09 21:53:48 -0800
commit0b8e285c77558569eb2fd4d4880cde9c26155457 (patch)
tree9bc7e7cac0ef3f6d15077c62c720367fa6d440b6
parent30abd460061ad2fd5e58709cb9b954a61361a07c (diff)
downloadaur-0b8e285c77558569eb2fd4d4880cde9c26155457.tar.gz
Bump; add patches for meson
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD51
-rw-r--r--pam_dir.patch11
3 files changed, 44 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21fe86e3b8d9..48b6ba11285a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,33 @@
pkgbase = fprintd-libfprint2
- pkgdesc = D-Bus service to access fingerprint readers, modified for libfprint2
- pkgver = 0.9.0+70+gb97903f
+ pkgdesc = D-Bus service to access fingerprint readers
+ pkgver = 0.9.0+127+g6d583cb
pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/fprint/fprintd
arch = x86_64
groups = fprint
license = GPL
+ checkdepends = pam_wrapper
+ checkdepends = python-cairo
+ checkdepends = python-dbus
+ checkdepends = python-dbusmock
+ checkdepends = python-gobject
makedepends = intltool
+ makedepends = git
makedepends = gtk-doc
+ makedepends = meson
makedepends = pam
- makedepends = git
- checkdepends = python-dbusmock
- checkdepends = python-cairo
- checkdepends = python-gobject
- depends = libfprint-git
depends = dbus-glib
- depends = polkit
- depends = glib2
+ depends = libfprint-git>=1.90.0
+ depends = polkit>=0.91
+ optdepends = pam: to use the fprintd pam plugin
+ provides = fprintd
conflicts = fprintd
source = git+https://gitlab.freedesktop.org/libfprint/fprintd.git
source = disable-systemd-protection.patch
- source = disable_pam_tests.patch
- source = storage_fix.patch
+ source = pam_dir.patch
sha256sums = SKIP
sha256sums = 4854d32d6579de31fd59b4df02f6a29db2e266dedfe9edda13bedcda1b083be1
- sha256sums = 2c81b9f4c5e593ee3ebdca08584be4b42c7a1a33f240c0da6e2aab50f0ff4b5c
- sha256sums = e94a80acaccc0e4830595b575f3865ed86a9866c18f910a83b568f602c750e3d
+ sha256sums = deae323c3ae28558aabca84b26c2e3e0004714941ab39384e45deaf7ca578b39
pkgname = fprintd-libfprint2
diff --git a/PKGBUILD b/PKGBUILD
index f10efbfa02b8..5ac888d6e13d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,66 +4,51 @@
# Modified for libfprint2 by Stephen Bird <sebirdman@gmail.com>
pkgname=fprintd-libfprint2
-pkgname_=fprintd
-pkgver=0.9.0+70+gb97903f
+_pkgname=fprintd
+pkgver=0.9.0+127+g6d583cb
pkgrel=1
-pkgdesc="D-Bus service to access fingerprint readers, modified to use libfprint2"
+pkgdesc="D-Bus service to access fingerprint readers"
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/fprint/fprintd"
license=(GPL)
-depends=(dbus-glib 'glib2>=2.56' 'libfprint-git>=1.90.0' 'polkit>=0.91')
+depends=(dbus-glib 'libfprint-git>=1.90.0' 'polkit>=0.91')
+optdepends=('pam: to use the fprintd pam plugin')
provides=(fprintd)
conflicts=(fprintd)
-makedepends=(intltool gtk-doc git pam)
-checkdepends=(python-cairo python-dbusmock python-gobject)
+makedepends=(intltool git gtk-doc meson pam)
+checkdepends=(pam_wrapper python-cairo python-dbus python-dbusmock python-gobject)
groups=(fprint)
source=(
"git+https://gitlab.freedesktop.org/libfprint/fprintd.git"
'disable-systemd-protection.patch'
- 'storage_fix.patch'
- 'disable_pam_tests.patch'
+ 'pam_dir.patch'
)
sha256sums=(
'SKIP'
'4854d32d6579de31fd59b4df02f6a29db2e266dedfe9edda13bedcda1b083be1'
- '2c81b9f4c5e593ee3ebdca08584be4b42c7a1a33f240c0da6e2aab50f0ff4b5c'
- 'e94a80acaccc0e4830595b575f3865ed86a9866c18f910a83b568f602c750e3d'
+ 'deae323c3ae28558aabca84b26c2e3e0004714941ab39384e45deaf7ca578b39'
)
pkgver() {
- cd $pkgname_
+ cd $_pkgname
git describe --tags | sed 's/^V_//;s/_/./g;s/-/+/g'
}
prepare() {
- cd $pkgname_
+ cd $_pkgname
patch -p1 -i "${srcdir}/disable-systemd-protection.patch"
- patch -p1 -i "${srcdir}/storage_fix.patch"
- patch -p1 -i "${srcdir}/disable_pam_tests.patch"
- NOCONFIGURE=1 ./autogen.sh
+ patch -p1 -i "${srcdir}/pam_dir.patch"
}
-check() {
- cd $pkgname_
- make check
+build() {
+ arch-meson $_pkgname build -D gtk_doc=true
+ ninja -C build
}
-
-build() {
- cd $pkgname_
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --disable-static \
- --enable-gtk-doc
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+check() {
+ meson test -C build
}
package() {
- cd $pkgname_
- make DESTDIR="$pkgdir" dbus_confdir=/usr/share/dbus-1/system.d install
- install -d -m 755 "$pkgdir/var/lib/fprint"
+ DESTDIR="$pkgdir" meson install -C build
}
diff --git a/pam_dir.patch b/pam_dir.patch
new file mode 100644
index 000000000000..bef64726f130
--- /dev/null
+++ b/pam_dir.patch
@@ -0,0 +1,11 @@
+diff --git a/pam/meson.build b/pam/meson.build
+index 6a342b0..fafbc5a 100644
+--- a/pam/meson.build
++++ b/pam/meson.build
+@@ -1,5 +1,5 @@
+ mapfile = files('pam_fprintd.ver')
+-pam_modules_dir = '/' + get_option('libdir') / 'security'
++pam_modules_dir = get_option('prefix') / get_option('libdir') / 'security'
+
+ pam_fprintd = shared_module('pam_fprintd',
+ name_prefix: '',