summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Gu2020-10-15 02:36:50 -0400
committerTimothy Gu2020-10-15 02:36:50 -0400
commit5b3785f62949a46a99285490e283ea6ddb5d28e4 (patch)
tree604e6506814298faa964bf16f3f902ee66c02dec
parentec245a16aa043914df03ed8a9da20ed2f83925d9 (diff)
downloadaur-5b3785f62949a46a99285490e283ea6ddb5d28e4.tar.gz
Bump to 1.90.1+98+gceb7544
-rw-r--r--.SRCINFO6
-rw-r--r--0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch47
-rw-r--r--PKGBUILD11
3 files changed, 58 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd0171b5a3d4..780b1479baa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fprintd-libfprint2
pkgdesc = D-Bus service to access fingerprint readers
- pkgver = 1.90.1+91+g4e47222
- pkgrel = 2
+ pkgver = 1.90.1+98+gceb7544
+ pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/fprint/fprintd
arch = x86_64
groups = fprint
@@ -25,7 +25,9 @@ pkgbase = fprintd-libfprint2
provides = fprintd
conflicts = fprintd
source = git+https://gitlab.freedesktop.org/libfprint/fprintd.git
+ source = 0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch
sha256sums = SKIP
+ sha256sums = 3217fc8eac1aed68039a56380ce78b7efb16e9d0e9a99efccd78d88d57d1999b
pkgname = fprintd-libfprint2
depends = dbus
diff --git a/0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch b/0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch
new file mode 100644
index 000000000000..2d596c8bd346
--- /dev/null
+++ b/0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch
@@ -0,0 +1,47 @@
+From 657bfff2871b95ab979d624e2668d7d472d5344b Mon Sep 17 00:00:00 2001
+From: Timothy Gu <timothygu99@gmail.com>
+Date: Thu, 15 Oct 2020 02:29:49 -0400
+Subject: [PATCH] tests: Skip a test if virtual image driver is not enabled
+
+test_manager_get_devices_on_name_appeared requires the virtual image
+driver to be available.
+---
+ tests/fprintd.py | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/tests/fprintd.py b/tests/fprintd.py
+index 0bd9ac3..06c65bc 100755
+--- a/tests/fprintd.py
++++ b/tests/fprintd.py
+@@ -270,6 +270,9 @@ class FPrintdTest(dbusmock.DBusTestCase):
+ return pwd.getpwuid(os.getuid()).pw_name
+
+ def setUp(self):
++ self.daemon = None
++ self.manager = None
++ self.device = None
+ self.test_dir = tempfile.mkdtemp()
+ self.addCleanup(shutil.rmtree, self.test_dir)
+ self.state_dir = os.path.join(self.test_dir, 'state')
+@@ -325,8 +328,6 @@ class FPrintdVirtualDeviceBaseTest(FPrintdTest):
+ def setUp(self):
+ super().setUp()
+
+- self.manager = None
+- self.device = None
+ self.polkitd_start()
+ self.daemon_start()
+
+@@ -441,6 +442,9 @@ class FPrintdManagerPreStartTests(FPrintdTest):
+ on_name_appeared, None)
+
+ self.daemon_start()
++ if self.device is None:
++ self.skipTest("Need virtual_image device to run the test")
++
+ while not self._appeared_res:
+ ctx.iteration(True)
+
+--
+2.28.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 7977230e560c..6232243c210d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=fprintd-libfprint2
_pkgname=fprintd
-pkgver=1.90.1+91+g4e47222
-pkgrel=2
+pkgver=1.90.1+98+gceb7544
+pkgrel=1
pkgdesc="D-Bus service to access fingerprint readers"
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/fprint/fprintd"
@@ -19,8 +19,10 @@ conflicts=(fprintd)
makedepends=(git gtk-doc meson pam)
checkdepends=(pam_wrapper python-cairo python-dbus python-dbusmock python-gobject)
groups=(fprint)
-source=("git+https://gitlab.freedesktop.org/libfprint/$_pkgname.git")
-sha256sums=('SKIP')
+source=("git+https://gitlab.freedesktop.org/libfprint/$_pkgname.git"
+ '0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch')
+sha256sums=('SKIP'
+ '3217fc8eac1aed68039a56380ce78b7efb16e9d0e9a99efccd78d88d57d1999b')
pkgver() {
cd $_pkgname
@@ -29,6 +31,7 @@ pkgver() {
prepare() {
cd $_pkgname
+ git am < '../0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch'
}
build() {