summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Gu2020-04-05 22:13:35 -0400
committerTimothy Gu2020-04-05 22:13:35 -0400
commit5d70c13efe3357eeedc51b84e0f2a564a3042c82 (patch)
treedf0ed08d6680f046b4c1adb4622188eaf3a720f8
parent677fbc313eb4af22da61499c2dca36c9f7f1e2cb (diff)
downloadaur-5d70c13efe3357eeedc51b84e0f2a564a3042c82.tar.gz
Align more with upstream Arch
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b5c55950397..1065d381c30d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@
pkgname=fprintd-libfprint2
_pkgname=fprintd
pkgver=1.90.1+81+g6dd010f
-pkgrel=1
+pkgrel=2
pkgdesc="D-Bus service to access fingerprint readers"
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/fprint/fprintd"
license=(GPL)
-depends=(dbus-glib 'libfprint-git>=1.90.0' 'polkit>=0.91')
+depends=(dbus-glib 'libfprint-git>=1.90.0' libsystemd 'polkit>=0.91')
optdepends=('pam: to use the fprintd pam plugin')
provides=(fprintd)
conflicts=(fprintd)
-makedepends=(intltool git gtk-doc meson pam)
+makedepends=(git gtk-doc meson pam)
checkdepends=(pam_wrapper python-cairo python-dbus python-dbusmock python-gobject)
groups=(fprint)
source=("git+https://gitlab.freedesktop.org/libfprint/$_pkgname.git")
@@ -27,6 +27,10 @@ pkgver() {
git describe --tags | sed 's/^V_//;s/_/./g;s/-/+/g'
}
+prepare() {
+ cd $_pkgname
+}
+
build() {
arch-meson $_pkgname build \
-D pam_modules_dir=/usr/lib/security \
@@ -39,9 +43,12 @@ check() {
# directories, causing random failures the next time tests get run.
msg2 'Removing stale /tmp/pam.[0-9A-Za-z] directories before testing'
rm -rf /tmp/pam.[0-9A-Za-z]
- meson test -C build
+ meson test -C build --print-errorlogs
}
package() {
+ depends+=(libfprint-2.so)
+
DESTDIR="$pkgdir" meson install -C build
+ install -d -m 700 "$pkgdir/var/lib/fprint"
}