summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Gu2020-04-05 21:18:40 -0400
committerTimothy Gu2020-04-05 21:18:40 -0400
commitcd64240786cba28521ab27181d91039ed4dba710 (patch)
tree6519078cbe3dcf62f8e5458c1c7062046aae428c
parentd6770b2b8137cb799ca216ced9ca566a831993eb (diff)
downloadaur-cd64240786cba28521ab27181d91039ed4dba710.tar.gz
Stronger medicine against random check failures
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a31efec8a9f4..2aa1ac124323 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,11 +27,17 @@ pkgver() {
}
build() {
- arch-meson $_pkgname build -D pam_modules_dir=/usr/lib/security -D gtk_doc=true
+ arch-meson $_pkgname build \
+ -D pam_modules_dir=/usr/lib/security \
+ -D gtk_doc=true
ninja -C build
}
check() {
+ # Unfortunately, the PAM tests often end up cluttering /tmp with pam.*
+ # directories, causing random failures the next time tests get run.
+ msg2 'Removing stale /tmp/pam.[0-9A-Za-z] directories before testing'
+ rm -rf /tmp/pam.[0-9A-Za-z]
meson test -C build
}