summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManolis Kapernaros2020-06-28 20:38:45 +0300
committerManolis Kapernaros2020-06-28 20:38:45 +0300
commitb7305853d99c82e7dbbb99e3955b1342a9567ec3 (patch)
tree04ad52190d13a53258835d8f07fa677e02160bf8
parentd55a0abd363809f65f2e26ab7a443b3f6efbe1c6 (diff)
downloadaur-fprintd-vfs_proprietary.tar.gz
workaround for 'multiple definition' error with gcc10
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--gcc10-workaround.patch12
3 files changed, 21 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf50ba372dec..d2b383c4e2b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fprintd-vfs_proprietary
pkgdesc = D-Bus service to access fingerprint readers, modified for the vfs_proprietary plugin
pkgver = 0.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.freedesktop.org/wiki/Software/fprint/fprintd
arch = x86_64
groups = fprint
@@ -16,8 +16,10 @@ pkgbase = fprintd-vfs_proprietary
conflicts = fprintd
source = git+https://gitlab.freedesktop.org/libfprint/fprintd.git#commit=9e32cd525724f21eebf2336a06b13a39c6616ab0
source = disable-systemd-protection.patch
+ source = gcc10-workaround.patch
sha256sums = SKIP
sha256sums = 034ded26596473b418fdfcfeb0838fef131819025660d047d41cf343f8c35116
+ sha256sums = eef023908190da9bc53abf274a17cb2575d80f48a3a8b258b9cd7d5459de4247
pkgname = fprintd-vfs_proprietary
diff --git a/PKGBUILD b/PKGBUILD
index 18e1d62846f4..159b10d74201 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer: Manolis Kapernaros (kapcom01) <kapcom01@protonmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Nikolay Rysev <mad.f3ka@gmail.com>
# Modified for vfs_proprietary by Daniel Kamil Kozar <dkk089@gmail.com>
pkgname=fprintd-vfs_proprietary
pkgname_=fprintd
pkgver=0.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="D-Bus service to access fingerprint readers, modified for the vfs_proprietary plugin"
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/fprint/fprintd"
@@ -18,10 +19,12 @@ _commit=9e32cd525724f21eebf2336a06b13a39c6616ab0 # tags/V_0_8_1^0
source=(
"git+https://gitlab.freedesktop.org/libfprint/fprintd.git#commit=$_commit"
'disable-systemd-protection.patch'
+ 'gcc10-workaround.patch'
)
sha256sums=(
'SKIP'
'034ded26596473b418fdfcfeb0838fef131819025660d047d41cf343f8c35116'
+ 'eef023908190da9bc53abf274a17cb2575d80f48a3a8b258b9cd7d5459de4247'
)
pkgver() {
@@ -32,6 +35,7 @@ pkgver() {
prepare() {
cd $pkgname_
patch -p1 -i "${srcdir}/disable-systemd-protection.patch"
+ patch -p1 -i "${srcdir}/gcc10-workaround.patch"
NOCONFIGURE=1 ./autogen.sh
}
diff --git a/gcc10-workaround.patch b/gcc10-workaround.patch
new file mode 100644
index 000000000000..93b0681c1bf2
--- /dev/null
+++ b/gcc10-workaround.patch
@@ -0,0 +1,12 @@
+diff --git a/configure.ac b/configure.ac
+index 9c8d979..069b496 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -10,6 +10,7 @@ AC_PREREQ([2.50])
+ AC_PROG_LIBTOOL
+ AC_PROG_CC
+ AM_PROG_CC_C_O
++CFLAGS+=" -fcommon"
+
+ GETTEXT_PACKAGE=fprintd
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, ["$GETTEXT_PACKAGE"], [Define to the Gettext package name])