summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-07-25 17:10:25 +0200
committerPhilip Goto2018-07-25 17:10:25 +0200
commit0fe391814e16f88aa5aed059e156076bbd313229 (patch)
tree6bb761781b8ca946cb92cc412c46d3c3981f13d7
parent2253c3b35ea04116e115dc00bf7ef1bd7ec75c36 (diff)
downloadaur-0fe391814e16f88aa5aed059e156076bbd313229.tar.gz
Update dependencies and prepare to build libtransmission properly
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 6 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 674b611460da..b944863c4db6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,17 +8,10 @@ pkgbase = fragments-git
arch = armv6h
arch = armv7h
license = GPL3
- makedepends = dht
makedepends = git
makedepends = gobject-introspection
makedepends = libdazzle
- makedepends = libb64
- makedepends = libevent
- makedepends = libnatpmp
- makedepends = libtransmission
- makedepends = libutp
makedepends = meson
- makedepends = miniupnpc
makedepends = vala
depends = gtk3
provides = fragments
diff --git a/PKGBUILD b/PKGBUILD
index 54fe78113c7c..f6f745bc0767 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,23 +9,21 @@ arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://github.com/FragmentsApp/Fragments"
license=('GPL3')
depends=('gtk3')
-makedepends=('dht'
- 'git'
+makedepends=('git'
'gobject-introspection'
'libdazzle'
- 'libb64'
- 'libevent'
- 'libnatpmp'
- 'libtransmission'
- 'libutp'
'meson'
- 'miniupnpc'
'vala')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://github.com/FragmentsApp/Fragments.git")
md5sums=('SKIP')
+prepare() {
+ cd "$srcdir/Fragments"
+ git submodule update --init --recursive
+}
+
pkgver() {
cd "$srcdir/Fragments"
git describe --always | sed 's/^v//;s/-/./g;s/_/./g;'