summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-01-30 21:39:30 +0100
committerPhilip Goto2018-01-30 21:39:30 +0100
commitacd26195a959cd81ce691707c9086e507cee3616 (patch)
treea6fbf8d0c929561929a951352e1730e414272c4a
downloadaur-acd26195a959cd81ce691707c9086e507cee3616.tar.gz
Add inital version of fragments app
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a31cd9391d0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = fragments-git
+ pkgdesc = A GTK3 BitTorrent client following the GNOME Human Interface Guidelines
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/FragmentsApp/Fragments
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ makedepends = vala
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = libdazzle
+ depends = gtk3
+ provides = fragments
+ conflicts = fragments
+ source = git+https://github.com/FragmentsApp/Fragments.git
+ md5sums = SKIP
+
+pkgname = fragments-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..556c8d473b80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+_pkgname=fragments
+pkgname=$_pkgname-git
+pkgver=latest
+pkgrel=1
+pkgdesc="A GTK3 BitTorrent client following the GNOME Human Interface Guidelines"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/FragmentsApp/Fragments"
+license=('GPL3')
+depends=('gtk3')
+makedepends=('git' 'vala' 'gobject-introspection' 'meson' 'libdazzle')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/FragmentsApp/Fragments.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/Fragments"
+ git describe --always | sed 's/^v//;s/-/./g;s/_/./g;'
+}
+
+build() {
+ rm -rf build
+ arch-meson Fragments build
+ ninja -v -C build
+}
+
+package() {
+ DESTDIR="$pkgdir/" ninja -C build install
+}