summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2022-03-14 23:14:46 +0100
committerGiovanni Santini2022-03-14 23:14:46 +0100
commit8ad4be0a982283fc40b252979ab9998cd22a975d (patch)
tree59def4006ee34025d7ba63ac7f65b6f10781b8ac
parentede804f0db2e67b74f854447507ffc9af557ed13 (diff)
downloadaur-8ad4be0a982283fc40b252979ab9998cd22a975d.tar.gz
upgpkg: franz 5.8.0-1
- Version bump. - Improve lerna bootstrapping, allowing lerna 4 to be used. - Add check() so that tests can be executed. - Use Electron 14 as upstream.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
2 files changed, 29 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a6d09aa44c0..1502f0f5fefb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = franz
pkgdesc = Free messaging app for services like WhatsApp, Slack, Messenger and many more.
- pkgver = 5.7.0
- pkgrel = 9
+ pkgver = 5.8.0
+ pkgrel = 1
epoch = 1
url = https://meetfranz.com
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = franz
makedepends = nvm
makedepends = python
makedepends = python2
- depends = electron12
- source = git+https://github.com/meetfranz/franz#tag=v5.7.0
+ depends = electron14
+ source = git+https://github.com/meetfranz/franz#tag=v5.8.0
source = franz.desktop
source = franz.sh.in
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5feaf0a0ba17..024c8c2212e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=franz
#pkgver=${_pkgver//-/_} # Leaving it here for possible dev/beta package :)
-pkgver=5.7.0
-pkgrel=9
+pkgver=5.8.0
+pkgrel=1
# Due to the previous "_beta" naming
epoch=1
pkgdesc='Free messaging app for services like WhatsApp, Slack, Messenger and many more.'
@@ -13,10 +13,10 @@ arch=(x86_64 i686)
url='https://meetfranz.com'
license=(Apache)
# Allow to easily switch between Electron versions.
-# Expected one is 'electron12' (Electron 12). May change soon.
+# Expected one is 'electron14' (Electron 14). May change soon.
# This is automatically replaced in `franz.sh` with the package name, as
-# the executable matches the package name (as of 2020-11-15).
-_electron='electron12'
+# the executable matches the package name (as of 2022-03-14).
+_electron='electron14'
depends=($_electron)
makedepends=(expac git nvm python python2)
source=("git+https://github.com/meetfranz/$pkgname#tag=v$pkgver"
@@ -68,7 +68,12 @@ prepare() {
nvm install
echo "--> Install modules dependencies with lerna"
- npx --package="lerna@^3.8.0" lerna bootstrap
+ # The author still uses old dependencies resolution.
+ # Luckily it is "documented" in the Appveyor CI file.
+ # About the double double escape, that is because the first '--' is for
+ # npm exec, while the second is for lerna.
+ # See: https://github.com/lerna/lerna/issues/2921
+ npm exec --yes -- lerna bootstrap -- --legacy-peer-deps
}
build() {
@@ -79,8 +84,20 @@ build() {
# Actually build the package
echo "--> Building the package"
- npx gulp build
- npx electron-builder --linux dir
+ npm exec lerna run build
+ npm exec gulp build
+ npm exec -- electron-builder --linux dir
+}
+
+check() {
+ cd "$pkgname"
+
+ # Be sure we are correctly setup
+ _ensure_nvm_setup
+
+ # Run the tests
+ echo "--> Running the tests"
+ npm run test
}
package() {