summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2021-09-08 10:05:42 +0200
committerGiovanni Santini2021-09-08 10:05:42 +0200
commit8af070bee0aab1011046435320bfdb23747b6628 (patch)
treeeb46e5c11cdbf14760e2bf24ab791ab8c6f8adb0
parentfa8982783ed29504a48d64da93821549dcdec5aa (diff)
downloadaur-8af070bee0aab1011046435320bfdb23747b6628.tar.gz
upgpkg: franz 5.7.0-8
- Disable Electron package matching. This was needed back when `electron` was used but is not necessary with `electron12`. - Remove `expac` dependency as a consequence of the above. - Minor PKGBUILD adjustments.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 045e0219dafc..1fd7f46a5331 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = franz
pkgdesc = Free messaging app for services like WhatsApp, Slack, Messenger and many more.
pkgver = 5.7.0
- pkgrel = 7
+ pkgrel = 8
epoch = 1
url = https://meetfranz.com
arch = x86_64
arch = i686
license = Apache
- makedepends = expac
makedepends = git
makedepends = nvm
makedepends = python
@@ -21,4 +20,3 @@ pkgbase = franz
sha512sums = 7ccf058421b173830493f35417d204e3a735fc20f801283dad3f658abeb484f6244bc535634c2f02ab2cb8e35a0e1a92dd3d06be5943e121ddccbbee7ad74b48
pkgname = franz
- depends = electron12
diff --git a/PKGBUILD b/PKGBUILD
index c4339a0a2b01..0038b3153afc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=franz
#pkgver=${_pkgver//-/_} # Leaving it here for possible dev/beta package :)
pkgver=5.7.0
-pkgrel=7
+pkgrel=8
# Due to the previous "_beta" naming
epoch=1
pkgdesc='Free messaging app for services like WhatsApp, Slack, Messenger and many more.'
@@ -13,12 +13,12 @@ arch=(x86_64 i686)
url='https://meetfranz.com'
license=(Apache)
# Allow to easily switch between Electron versions.
-# Expected one is 'electron10' (Electron 10). May change soon.
+# Expected one is 'electron12' (Electron 12). May change soon.
# This is automatically replaced in `franz.sh` with the package name, as
# the executable matches the package name (as of 2020-11-15).
_electron='electron12'
depends=($_electron)
-makedepends=(expac git nvm python python2)
+makedepends=(git nvm python python2)
source=("git+https://github.com/meetfranz/$pkgname#tag=v$pkgver"
franz.desktop
franz.sh.in)
@@ -88,8 +88,9 @@ package() {
# Point the proper Electron package version, so that people can complain when it's updated.
# This is for extra safety & reminds me of upgrading the package.
- electron_version="`expac %v $_electron | cut -d'-' -f1`"
- depends=("${_electron}=${electron_version}")
+ # Keeping this here if I'll switch back to `electron`, which is more unstable.
+ #electron_version="`expac %v $_electron | cut -d'-' -f1`"
+ #depends=("${_electron}=${electron_version}")
# Install the .asar files
install -dm 755 "$pkgdir/usr/lib/$pkgname"