summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Souza Franco2018-06-16 16:14:52 +0200
committerGabriel Souza Franco2018-06-16 16:14:52 +0200
commit296d7516e2092d2ebeb3eb78a866f28ec18adb22 (patch)
tree2b675c667e103a16c1641382d41a13f542cb2afb
parentb3dc7f9f41541906c97f99a544a138b1b60fafe0 (diff)
downloadaur-296d7516e2092d2ebeb3eb78a866f28ec18adb22.tar.gz
Properly fix line endings for qt5.11.patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--qt5.11.patch144
3 files changed, 74 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83153ef6073b..0f1c0c5a62ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -52,7 +52,7 @@ pkgbase = freecad
sha256sums = 248918de7d3c2145b5cc4fbbc9e224d22f4a6ca7ead2680e8c3a32e91772482a
sha256sums = 618bb85c4f3a4eb0e329d1fc30391b777c9b0cffe97aa1e96d45f58b18424311
sha256sums = 170c90ee6ef64cf3c8e6a35ca94bb1187d346707f7e0779022e614563c6b74f6
- sha256sums = 5e1635e1fc8687b624935859b8734133ed48c38c59d54581bca9b56162d08401
+ sha256sums = a639c9d51f8443e4d2270fe60d5ac3ac62c7c64c532620108514840f8e8704bc
pkgname = freecad
diff --git a/PKGBUILD b/PKGBUILD
index af909a0669a0..70db9585f3ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,7 @@ sha256sums=('ae017393476b6dc7f1192bcaf91ceedc2f9b791f2495307ce7c45efadb5266fb'
'248918de7d3c2145b5cc4fbbc9e224d22f4a6ca7ead2680e8c3a32e91772482a'
'618bb85c4f3a4eb0e329d1fc30391b777c9b0cffe97aa1e96d45f58b18424311'
'170c90ee6ef64cf3c8e6a35ca94bb1187d346707f7e0779022e614563c6b74f6'
- '5e1635e1fc8687b624935859b8734133ed48c38c59d54581bca9b56162d08401')
+ 'a639c9d51f8443e4d2270fe60d5ac3ac62c7c64c532620108514840f8e8704bc')
prepare() {
cd "${srcdir}/FreeCAD-${pkgver}"
diff --git a/qt5.11.patch b/qt5.11.patch
index 2638ed19ff67..c5a755fce7f1 100644
--- a/qt5.11.patch
+++ b/qt5.11.patch
@@ -167,144 +167,144 @@ index e392d470b7e..7636ad2fbbc 100644
--- a/src/Mod/MeshPart/Gui/Tessellation.cpp
+++ b/src/Mod/MeshPart/Gui/Tessellation.cpp
@@ -25,6 +25,7 @@
- #ifndef _PreComp_
- # include <TopExp_Explorer.hxx>
- # include <QMessageBox>
+ #ifndef _PreComp_
+ # include <TopExp_Explorer.hxx>
+ # include <QMessageBox>
+# include <QButtonGroup>
- #endif
-
- #include "Tessellation.h"
+ #endif
+
+ #include "Tessellation.h"
diff --git a/src/Mod/Part/Gui/DlgSettingsGeneral.cpp b/src/Mod/Part/Gui/DlgSettingsGeneral.cpp
index d0cf0f94eee..b44eac6ff70 100644
--- a/src/Mod/Part/Gui/DlgSettingsGeneral.cpp
+++ b/src/Mod/Part/Gui/DlgSettingsGeneral.cpp
@@ -22,6 +22,9 @@
-
-
- #include "PreCompiled.h"
+
+
+ #include "PreCompiled.h"
+#ifndef _PreComp_
+# include <QButtonGroup>
+#endif
-
- #include <Interface_Static.hxx>
-
+
+ #include <Interface_Static.hxx>
+
diff --git a/src/Mod/PartDesign/Gui/TaskBooleanParameters.cpp b/src/Mod/PartDesign/Gui/TaskBooleanParameters.cpp
index 78570544845..7e3280065ca 100644
--- a/src/Mod/PartDesign/Gui/TaskBooleanParameters.cpp
+++ b/src/Mod/PartDesign/Gui/TaskBooleanParameters.cpp
@@ -25,6 +25,7 @@
-
- #ifndef _PreComp_
- # include <QMessageBox>
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
+# include <QAction>
- #endif
-
- #include "ui_TaskBooleanParameters.h"
+ #endif
+
+ #include "ui_TaskBooleanParameters.h"
diff --git a/src/Mod/PartDesign/Gui/TaskChamferParameters.cpp b/src/Mod/PartDesign/Gui/TaskChamferParameters.cpp
index 330d5853512..4600cc25b62 100644
--- a/src/Mod/PartDesign/Gui/TaskChamferParameters.cpp
+++ b/src/Mod/PartDesign/Gui/TaskChamferParameters.cpp
@@ -24,6 +24,7 @@
- #include "PreCompiled.h"
-
- #ifndef _PreComp_
+ #include "PreCompiled.h"
+
+ #ifndef _PreComp_
+# include <QAction>
- #endif
-
- #include "ui_TaskChamferParameters.h"
+ #endif
+
+ #include "ui_TaskChamferParameters.h"
diff --git a/src/Mod/PartDesign/Gui/TaskDraftParameters.cpp b/src/Mod/PartDesign/Gui/TaskDraftParameters.cpp
index 556fc92ae1f..020148001cd 100644
--- a/src/Mod/PartDesign/Gui/TaskDraftParameters.cpp
+++ b/src/Mod/PartDesign/Gui/TaskDraftParameters.cpp
@@ -25,6 +25,7 @@
-
- #ifndef _PreComp_
- # include <QMessageBox>
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
+# include <QAction>
- #endif
-
- #include "ui_TaskDraftParameters.h"
+ #endif
+
+ #include "ui_TaskDraftParameters.h"
diff --git a/src/Mod/PartDesign/Gui/TaskFilletParameters.cpp b/src/Mod/PartDesign/Gui/TaskFilletParameters.cpp
index 3c4025574ad..5e0c31ec64a 100644
--- a/src/Mod/PartDesign/Gui/TaskFilletParameters.cpp
+++ b/src/Mod/PartDesign/Gui/TaskFilletParameters.cpp
@@ -24,6 +24,7 @@
- #include "PreCompiled.h"
-
- #ifndef _PreComp_
+ #include "PreCompiled.h"
+
+ #ifndef _PreComp_
+# include <QAction>
- #endif
-
- #include "ui_TaskFilletParameters.h"
+ #endif
+
+ #include "ui_TaskFilletParameters.h"
diff --git a/src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp b/src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp
index 532936310be..1970db7ef08 100644
--- a/src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp
+++ b/src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp
@@ -25,6 +25,7 @@
-
- #ifndef _PreComp_
- # include <QMessageBox>
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
+# include <QAction>
- # include <QTimer>
- #endif
-
+ # include <QTimer>
+ #endif
+
diff --git a/src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp b/src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp
index 084ab353c35..f8e96fd6c52 100644
--- a/src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp
+++ b/src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp
@@ -25,6 +25,7 @@
-
- #ifndef _PreComp_
- # include <QMessageBox>
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
+# include <QAction>
- #endif
-
- #include <Base/Console.h>
+ #endif
+
+ #include <Base/Console.h>
diff --git a/src/Mod/PartDesign/Gui/TaskMultiTransformParameters.cpp b/src/Mod/PartDesign/Gui/TaskMultiTransformParameters.cpp
index 1fe452a593e..d5a5317ae80 100644
--- a/src/Mod/PartDesign/Gui/TaskMultiTransformParameters.cpp
+++ b/src/Mod/PartDesign/Gui/TaskMultiTransformParameters.cpp
@@ -25,6 +25,7 @@
-
- #ifndef _PreComp_
- # include <QMessageBox>
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
+# include <QAction>
- #endif
-
- #include "ui_TaskMultiTransformParameters.h"
+ #endif
+
+ #include "ui_TaskMultiTransformParameters.h"
diff --git a/src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp b/src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp
index 874273f63e6..79c564d0965 100644
--- a/src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp
+++ b/src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp
@@ -25,6 +25,7 @@
-
- #ifndef _PreComp_
- # include <QMessageBox>
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
+# include <QAction>
- # include <QTimer>
- #endif
-
+ # include <QTimer>
+ #endif
+
diff --git a/src/Mod/PartDesign/Gui/TaskScaledParameters.cpp b/src/Mod/PartDesign/Gui/TaskScaledParameters.cpp
index 593664c9bdb..acaacce6ee8 100644
--- a/src/Mod/PartDesign/Gui/TaskScaledParameters.cpp
+++ b/src/Mod/PartDesign/Gui/TaskScaledParameters.cpp
@@ -25,6 +25,7 @@
-
- #ifndef _PreComp_
- # include <QMessageBox>
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
+# include <QAction>
- #endif
-
- #include "ui_TaskScaledParameters.h"
+ #endif
+
+ #include "ui_TaskScaledParameters.h"
diff --git a/src/Mod/PartDesign/Gui/TaskThicknessParameters.cpp b/src/Mod/PartDesign/Gui/TaskThicknessParameters.cpp
index b3f17f299d4..5b907304fcc 100644
--- a/src/Mod/PartDesign/Gui/TaskThicknessParameters.cpp
+++ b/src/Mod/PartDesign/Gui/TaskThicknessParameters.cpp
@@ -24,6 +24,7 @@
- #include "PreCompiled.h"
-
- #ifndef _PreComp_
+ #include "PreCompiled.h"
+
+ #ifndef _PreComp_
+# include <QAction>
- #endif
-
- #include "ui_TaskThicknessParameters.h"
+ #endif
+
+ #include "ui_TaskThicknessParameters.h"