summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2019-06-17 20:26:04 +0200
committerSimon Brulhart2019-06-17 20:32:00 +0200
commit1620c1f81fb41f11cb4b165a0b21b1ed6d618246 (patch)
tree0ca0a569b0d341f1189e4302a4b39dc3c09acf09
parentbe0c6c2435537af99584b1be372420b1443bebd1 (diff)
downloadaur-1620c1f81fb41f11cb4b165a0b21b1ed6d618246.tar.gz
Update to v10.13
-rwxr-xr-x.SRCINFO10
-rw-r--r--PKGBUILD24
-rw-r--r--revert_resources_path.patch16
-rw-r--r--revert_xdg_config_path.patch25
4 files changed, 26 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c870b5f0e58..8605a24b328e 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = freefilesync
pkgdesc = Backup software to synchronize files and folders
- pkgver = 10.12
+ pkgver = 10.13
pkgrel = 1
url = https://www.freefilesync.org
arch = i686
@@ -11,14 +11,12 @@ pkgbase = freefilesync
depends = wxgtk
depends = webkit2gtk
depends = boost-libs
- source = FreeFileSync_10.12_Source.zip::https://www.freefilesync.org/download/FreeFileSync_10.12_Source.zip
- source = revert_resources_path.patch
+ source = FreeFileSync_10.13_Source.zip::https://www.freefilesync.org/download/FreeFileSync_10.13_Source.zip
source = revert_xdg_config_path.patch
source = FreeFileSync.desktop
source = RealTimeSync.desktop
- sha256sums = 55b915c47f2dff5c376ed7b6297bae449ab71179bab026a776dea123aaa65407
- sha256sums = 052ef5bf5eb11730499f4b81cd7e70f990fff3cfcc2f7059b84981e7ededc361
- sha256sums = fef8aa099a27c277b76f1229651ed2324355528482c8f115e09c39269bbf4bdd
+ sha256sums = 6460362e56e846535ffa07eb5e087fac1efa04c34dd8f5c323c570f7e960b72a
+ sha256sums = e74b4abdf04c58004e52f77afee762e4c3d72d4ca42de4cc42cbc930cbec0e32
sha256sums = 590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51
sha256sums = 82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830
diff --git a/PKGBUILD b/PKGBUILD
index 0cac48c0768e..66ab106eb939 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: jooch <jooch AT gmx DOT com>
pkgname=freefilesync
-pkgver=10.12
+pkgver=10.13
pkgrel=1
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
@@ -15,15 +15,13 @@ depends=(wxgtk webkit2gtk boost-libs)
makedepends=(boost unzip)
source=(
"FreeFileSync_${pkgver}_Source.zip::${url}/download/FreeFileSync_${pkgver}_Source.zip" #ffs
- revert_resources_path.patch
revert_xdg_config_path.patch
FreeFileSync.desktop
RealTimeSync.desktop
)
-sha256sums=('55b915c47f2dff5c376ed7b6297bae449ab71179bab026a776dea123aaa65407'
- '052ef5bf5eb11730499f4b81cd7e70f990fff3cfcc2f7059b84981e7ededc361'
- 'fef8aa099a27c277b76f1229651ed2324355528482c8f115e09c39269bbf4bdd'
+sha256sums=('6460362e56e846535ffa07eb5e087fac1efa04c34dd8f5c323c570f7e960b72a'
+ 'e74b4abdf04c58004e52f77afee762e4c3d72d4ca42de4cc42cbc930cbec0e32'
'590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51'
'82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830')
@@ -39,9 +37,6 @@ prepare() {
# Revert to classic config path
patch --binary -p1 -i revert_xdg_config_path.patch
-# Revert change to resources path of portable version
- patch --binary -p1 -i revert_resources_path.patch
-
# edit lines to remove functions that require wxgtk 3.1.x
sed -e 's:m_textCtrlOfflineActivationKey->ForceUpper:// &:g' -i 'FreeFileSync/Source/ui/small_dlgs.cpp'
sed -e 's:const double scrollSpeed =:& 6; //:g' -i 'wx+/grid.cpp'
@@ -78,14 +73,17 @@ build() {
package() {
bindir="${pkgdir}/usr/bin"
- appsharedir="${pkgdir}/usr/share/FreeFileSync"
+ appdir="${pkgdir}/opt/FreeFileSync"
appdocdir="${pkgdir}/usr/share/doc/FreeFileSync"
cd "${srcdir}/FreeFileSync/Build"
- install -t "${bindir}" -Dm755 Bin/FreeFileSync Bin/RealTimeSync
- install -t "${appsharedir}/Misc" -Dm644 Misc/*
- install -t "${appsharedir}/Languages" -Dm644 Languages/*.lng
- install -t "${pkgdir}/usr/share/pixmaps" -Dm644 Misc/FreeFileSync.png Misc/RealTimeSync.png
+ install -t "${appdir}/Bin" -Dm755 Bin/*
+ mkdir -p "${bindir}"
+ ln -s /opt/FreeFileSync/Bin/{FreeFileSync,RealTimeSync} "${bindir}"
+
+ cp -rT Resources "${appdir}/Resources"
+ find "${appdir}/Resources" -type f -print0 | xargs -0 chmod 644
+ install -t "${pkgdir}/usr/share/pixmaps" -Dm644 Resources/FreeFileSync.png Resources/RealTimeSync.png
cd "${srcdir}"
install -d "${appdocdir}"
diff --git a/revert_resources_path.patch b/revert_resources_path.patch
deleted file mode 100644
index 4a3975ef1698..000000000000
--- a/revert_resources_path.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ur a/FreeFileSync/Source/base/ffs_paths.cpp b/FreeFileSync/Source/base/ffs_paths.cpp
---- a/FreeFileSync/Source/base/ffs_paths.cpp 2019-01-02 23:57:37.768501228 +0100
-+++ b/FreeFileSync/Source/base/ffs_paths.cpp 2019-01-03 00:02:28.632322663 +0100
-@@ -65,10 +65,10 @@
- wxTheApp->SetAppName(L"FreeFileSync");
- ZEN_ON_SCOPE_EXIT(wxTheApp->SetAppName(appName));
-
-- //if (isPortableVersion())
-- return appendSeparator(getExeFolderParentPath());
-- //else //use OS' standard paths
-- // return appendSeparator(utfTo<Zstring>(wxStandardPathsBase::Get().GetResourcesDir()));
-+ if (isPortableVersion())
-+ return appendSeparator(getExeFolderParentPath());
-+ else // use OS' standard paths
-+ return appendSeparator(utfTo<Zstring>(wxStandardPathsBase::Get().GetResourcesDir()));
- }
diff --git a/revert_xdg_config_path.patch b/revert_xdg_config_path.patch
index 8be48f790d67..570faffef418 100644
--- a/revert_xdg_config_path.patch
+++ b/revert_xdg_config_path.patch
@@ -1,15 +1,12 @@
-diff -r -u2 a/FreeFileSync/Source/base/ffs_paths.cpp b/FreeFileSync/Source/base/ffs_paths.cpp
---- a/FreeFileSync/Source/base/ffs_paths.cpp 2018-12-12 15:02:09.000000000 +0100
-+++ b/FreeFileSync/Source/base/ffs_paths.cpp 2019-01-03 00:56:19.364918282 +0100
-@@ -83,9 +83,7 @@
- if (isPortableVersion())
- cfgFolderPath = getExeFolderParentPath();
-- else //OS standard path (XDG layout): ~/.config/FreeFileSync
-+ else //OS standard path (classic layout): ~/.FreeFileSync
- {
-- //wxBug: wxStandardPaths::GetUserDataDir() does not honor FileLayout_XDG flag
-- wxStandardPaths::Get().SetFileLayout(wxStandardPaths::FileLayout_XDG);
-- cfgFolderPath = appendSeparator(utfTo<Zstring>(wxStandardPaths::Get().GetUserConfigDir())) + "FreeFileSync";
-+ cfgFolderPath = utfTo<Zstring>(wxStandardPaths::Get().GetUserDataDir());
- }
+--- a/FreeFileSync/Source/base/ffs_paths.cpp 2019-06-13 20:39:40.000000000 +0200
++++ b/FreeFileSync/Source/base/ffs_paths.cpp 2019-06-17 08:28:10.960031518 +0200
+@@ -73,9 +73,6 @@
+ ZEN_ON_SCOPE_EXIT(wxTheApp->SetAppName(appName));
+- Zstring cfgFolderPath;
+- //OS standard path (XDG layout): ~/.config/FreeFileSync
+- //wxBug: wxStandardPaths::GetUserDataDir() does not honor FileLayout_XDG flag
+- wxStandardPaths::Get().SetFileLayout(wxStandardPaths::FileLayout_XDG);
+- cfgFolderPath = appendSeparator(utfTo<Zstring>(wxStandardPaths::Get().GetUserConfigDir())) + "FreeFileSync";
++ //OS standard path (classic layout): ~/.FreeFileSync
++ Zstring cfgFolderPath = utfTo<Zstring>(wxStandardPaths::Get().GetUserDataDir());