summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2019-04-11 21:11:10 +0200
committerSimon Brulhart2019-04-13 14:46:32 +0200
commit4c3588298484537529ae4999942c175322ca04d5 (patch)
tree71092882048ffb273da40c8d8b46940a55bf4deb
parent3e8625444dece9faaa0ff21be5d1a86f6bc62014 (diff)
downloadaur-4c3588298484537529ae4999942c175322ca04d5.tar.gz
Update to v10.11
* Refactor desktop files based on upstream examples
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xFreeFileSync.desktop17
-rw-r--r--PKGBUILD26
-rw-r--r--RealTimeSync.desktop19
4 files changed, 25 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b9336023fa2..d592437c1fb3 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = freefilesync
pkgdesc = Backup software to synchronize files and folders
pkgver = 10.11
- pkgrel = 2
+ pkgrel = 3
url = https://www.freefilesync.org
arch = i686
arch = x86_64
diff --git a/FreeFileSync.desktop b/FreeFileSync.desktop
index 37680ecb3722..b94e4799d123 100755
--- a/FreeFileSync.desktop
+++ b/FreeFileSync.desktop
@@ -1,14 +1,11 @@
[Desktop Entry]
-Name=FreeFileSync
-GenericName=File synchronization
-Comment=Backup software to synchronize files and folders
-Exec=FreeFileSync
-NoDisplay=false
-Terminal=0
-TerminalOptions=
Type=Application
+Name=FreeFileSync
+GenericName=Folder Comparison and Synchronization
+GenericName[de_DE]=Ordnervergleich und Synchronisation
+Exec=FreeFileSync %F
Icon=/usr/share/pixmaps/FreeFileSync.png
-Categories=GTK;Application;Utility;
+NoDisplay=false
+Terminal=false
+Categories=Utility;FileTools;
StartupNotify=true
-X-KDE-SubstituteUID=false
-X-KDE-Username=
diff --git a/PKGBUILD b/PKGBUILD
index 5f9c7ee77e11..25d00927bf52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=freefilesync
pkgver=10.11
-pkgrel=2
+pkgrel=3
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
url="https://www.freefilesync.org"
@@ -21,12 +21,11 @@ source=(
RealTimeSync.desktop
)
-sha256sums=('ed322ef285d85b1cfaa7d4e6fd4dbcb00c4aaf57003a3cbd35126eaef95a1d37' #ffs source
- '052ef5bf5eb11730499f4b81cd7e70f990fff3cfcc2f7059b84981e7ededc361' #revert_resources_path.patch
- 'fef8aa099a27c277b76f1229651ed2324355528482c8f115e09c39269bbf4bdd' #revert_xdg_config_path.patch
- 'd492d71c722340a1e6ee8dbbbf1ea24e052b473c38ef2d64d7338131bf417adc' #FreeFileSync.desktop
- '1321f3af06f0bc9c37dac369ca5960cba00961af7e2ceb76f18d16ca607ffa73' #RealTimeSync.desktop
-)
+sha256sums=('ed322ef285d85b1cfaa7d4e6fd4dbcb00c4aaf57003a3cbd35126eaef95a1d37'
+ '052ef5bf5eb11730499f4b81cd7e70f990fff3cfcc2f7059b84981e7ededc361'
+ 'fef8aa099a27c277b76f1229651ed2324355528482c8f115e09c39269bbf4bdd'
+ '590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51'
+ '82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830')
DLAGENTS=("https::/usr/bin/curl -fLC - --retry 5 --retry-delay 3 -A Mozilla -o %o %u")
@@ -47,7 +46,7 @@ prepare() {
sed -e 's:m_textCtrlOfflineActivationKey->ForceUpper:// &:g' -i 'FreeFileSync/Source/ui/small_dlgs.cpp'
sed -e 's:const double scrollSpeed =:& 6; //:g' -i 'wx+/grid.cpp'
-# libssh2 v1.8.0 does not yet implement LIBSSH2_SFTP_DEFAULT_MODE, revert to previous impl.
+# libssh2 v1.8.2 does not yet implement LIBSSH2_SFTP_DEFAULT_MODE, revert to previous impl.
sed -e 's/LIBSSH2_SFTP_DEFAULT_MODE/LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO/g' -i 'FreeFileSync/Source/fs/sftp.cpp'
# add '-lz' back into LINKFLAGS
@@ -84,18 +83,13 @@ package() {
cd "${srcdir}/FreeFileSync/Build"
install -t "${bindir}" -Dm755 Bin/FreeFileSync Bin/RealTimeSync
- install -t "${appsharedir}" -Dm644 \
- Misc/ding.wav \
- Misc/gong.wav \
- Misc/harp.wav \
- Resources.zip \
- Misc/styles.gtk_rc
+ install -t "${appsharedir}" -Dm644 Resources.zip
+ install -t "${appsharedir}/Misc" -Dm644 Misc/*
install -t "${appsharedir}/Languages" -Dm644 Languages/*.lng
+ install -t "${pkgdir}/usr/share/pixmaps" -Dm644 Misc/FreeFileSync.png Misc/RealTimeSync.png
cd "${srcdir}"
install -d "${appdocdir}"
gzip < Changelog.txt > "${appdocdir}/CHANGELOG.gz"
- unzip -o FreeFileSync/Build/Resources.zip FreeFileSync.png RealTimeSync.png
- install -Dm644 -t "${pkgdir}/usr/share/pixmaps" FreeFileSync.png RealTimeSync.png
install -Dm644 -t "${pkgdir}/usr/share/applications" FreeFileSync.desktop RealTimeSync.desktop
}
diff --git a/RealTimeSync.desktop b/RealTimeSync.desktop
index 74e605be5eb5..dfd533ffd88a 100644
--- a/RealTimeSync.desktop
+++ b/RealTimeSync.desktop
@@ -1,16 +1,11 @@
[Desktop Entry]
-Name=RealtimeSync
+Type=Application
+Name=RealTimeSync
GenericName=Automated Synchronization
-Comment=Real time synchronization
-Exec=RealTimeSync
-NoDisplay=false
-Terminal=0
-TerminalOptions=
+GenericName[de_DE]=Automatisierte Synchronisation
+Exec=RealTimeSync %f
Icon=/usr/share/pixmaps/RealTimeSync.png
-Categories=GTK;Application;Utility;
+NoDisplay=false
+Terminal=false
+Categories=Utility;FileTools;
StartupNotify=true
-Type=Application
-X-KDE-SubstituteUID=false
-X-KDE-Username=
-
-Name[it_IT.utf8]=RealTimeSync