summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJochum Döring2019-01-16 22:36:07 +0100
committerJochum Döring2019-01-16 22:36:07 +0100
commit5941cf3bf886670a8f2cac35e0fc2115ca6c377e (patch)
tree5d12fc94b3cbb189f80ffa4e94fe720e3edd51d8
parentcecb9e811f0b3d8798b240899acee679d9d47566 (diff)
downloadaur-5941cf3bf886670a8f2cac35e0fc2115ca6c377e.tar.gz
update to 10.8
-rwxr-xr-x.SRCINFO12
-rw-r--r--PKGBUILD29
-rw-r--r--revert_resources_path.patch16
-rw-r--r--revert_xdg_config_path.patch15
4 files changed, 58 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 883ac07ab06f..162120a1769d 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = freefilesync
pkgdesc = Backup software to synchronize files and folders
- pkgver = 10.5
- pkgrel = 2
+ pkgver = 10.8
+ pkgrel = 1
url = http://www.freefilesync.org/
arch = i686
arch = x86_64
@@ -10,12 +10,16 @@ pkgbase = freefilesync
depends = wxgtk
depends = webkit2gtk
depends = boost-libs
- source = FreeFileSync_10.5_Source.zip::https://www.freefilesync.org/download_redirect.php?file=FreeFileSync_10.5_Source.zip
+ source = FreeFileSync_10.8_Source.zip::https://www.freefilesync.org/download_redirect.php?file=FreeFileSync_10.8_Source.zip
+ source = revert_resources_path.patch
+ source = revert_xdg_config_path.patch
source = FreeFileSync.desktop
source = ffsicon.png
source = RealTimeSync.desktop
source = rtsicon.png
- sha256sums = 5c6f96d85dac1c6cd0ee511e7f7062b71ec271f0aa70c779af76498948391740
+ sha256sums = ac33e69d1e2be65fdea60e056d43eef7db26c34ee4e0491f90db487f33674388
+ sha256sums = 052ef5bf5eb11730499f4b81cd7e70f990fff3cfcc2f7059b84981e7ededc361
+ sha256sums = fef8aa099a27c277b76f1229651ed2324355528482c8f115e09c39269bbf4bdd
sha256sums = b381bb9dbda25c3c08a67f18072a2761abe34339ddf3318e1758eb7c349f1a3b
sha256sums = 31df3fa1f1310de14bbd379f891d4f8ed2df5b0d68913eb52c88b3be682933fb
sha256sums = 1502efdbf1638856a18ab9916e0431bf6a53471792cb2daa380345bac33f67c4
diff --git a/PKGBUILD b/PKGBUILD
index f6cd5068e6f9..d59655d45479 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Maintainer: jooch <jooch AT gmx DOT com>
pkgname=freefilesync
-pkgver=10.5
-pkgrel=2
+pkgver=10.8
+pkgrel=1
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
url="http://www.freefilesync.org/"
@@ -15,25 +15,33 @@ depends=(wxgtk webkit2gtk boost-libs)
makedepends=(boost)
source=(
"FreeFileSync_${pkgver}_Source.zip::https://www.freefilesync.org/download_redirect.php?file=FreeFileSync_${pkgver}_Source.zip" #ffs
+ revert_resources_path.patch
+ revert_xdg_config_path.patch
FreeFileSync.desktop
ffsicon.png
RealTimeSync.desktop
rtsicon.png
)
-sha256sums=(
- '5c6f96d85dac1c6cd0ee511e7f7062b71ec271f0aa70c779af76498948391740' #ffs source
- 'b381bb9dbda25c3c08a67f18072a2761abe34339ddf3318e1758eb7c349f1a3b' #FreeFileSync.desktop
- '31df3fa1f1310de14bbd379f891d4f8ed2df5b0d68913eb52c88b3be682933fb' #ffsicon.png
- '1502efdbf1638856a18ab9916e0431bf6a53471792cb2daa380345bac33f67c4' #RealTimeSync.desktop
- 'f28042587dbe99cf5d6bef2c1be4b026488e418e4ba8332b3016d246b7053a4e' #rtsicon.png
- )
+sha256sums=('ac33e69d1e2be65fdea60e056d43eef7db26c34ee4e0491f90db487f33674388' #ffs source
+ '052ef5bf5eb11730499f4b81cd7e70f990fff3cfcc2f7059b84981e7ededc361' #revert_resources_path.patch
+ 'fef8aa099a27c277b76f1229651ed2324355528482c8f115e09c39269bbf4bdd' #revert_xdg_config_path.patch
+ 'b381bb9dbda25c3c08a67f18072a2761abe34339ddf3318e1758eb7c349f1a3b' #FreeFileSync.desktop
+ '31df3fa1f1310de14bbd379f891d4f8ed2df5b0d68913eb52c88b3be682933fb' #ffsicon.png
+ '1502efdbf1638856a18ab9916e0431bf6a53471792cb2daa380345bac33f67c4' #RealTimeSync.desktop
+ 'f28042587dbe99cf5d6bef2c1be4b026488e418e4ba8332b3016d246b7053a4e' #rtsicon.png
+ )
-DLAGENTS=('https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -A Mozilla -o %o %u')
+DLAGENTS=('https::/usr/bin/curl -fLC - --retry 5 --retry-delay 3 -A Mozilla -o %o')
prepare() {
# wxgtk < 3.1.0
sed -i 's/m_listBoxHistory->GetTopItem()/0/g' FreeFileSync/Source/ui/main_dlg.cpp
+ # Revert to classic config path
+ patch --binary -p1 -i revert_xdg_config_path.patch
+
+# Revert change to resources path of portable version
+ patch --binary -p1 -i revert_resources_path.patch
# gcc 6.3.1
sed -i 's!static_assert!//static_assert!' zen/scope_guard.h
@@ -70,6 +78,7 @@ build() {
echo "compiler g++ $VER $MAC"
### FFS
+ mkdir -p "${srcdir}/FreeFileSync/Build/Bin"
cd ${srcdir}/FreeFileSync/Source
make
diff --git a/revert_resources_path.patch b/revert_resources_path.patch
new file mode 100644
index 000000000000..4a3975ef1698
--- /dev/null
+++ b/revert_resources_path.patch
@@ -0,0 +1,16 @@
+diff -ur a/FreeFileSync/Source/base/ffs_paths.cpp b/FreeFileSync/Source/base/ffs_paths.cpp
+--- a/FreeFileSync/Source/base/ffs_paths.cpp 2019-01-02 23:57:37.768501228 +0100
++++ b/FreeFileSync/Source/base/ffs_paths.cpp 2019-01-03 00:02:28.632322663 +0100
+@@ -65,10 +65,10 @@
+ wxTheApp->SetAppName(L"FreeFileSync");
+ ZEN_ON_SCOPE_EXIT(wxTheApp->SetAppName(appName));
+
+- //if (isPortableVersion())
+- return appendSeparator(getExeFolderParentPath());
+- //else //use OS' standard paths
+- // return appendSeparator(utfTo<Zstring>(wxStandardPathsBase::Get().GetResourcesDir()));
++ if (isPortableVersion())
++ return appendSeparator(getExeFolderParentPath());
++ else // use OS' standard paths
++ return appendSeparator(utfTo<Zstring>(wxStandardPathsBase::Get().GetResourcesDir()));
+ }
diff --git a/revert_xdg_config_path.patch b/revert_xdg_config_path.patch
new file mode 100644
index 000000000000..8be48f790d67
--- /dev/null
+++ b/revert_xdg_config_path.patch
@@ -0,0 +1,15 @@
+diff -r -u2 a/FreeFileSync/Source/base/ffs_paths.cpp b/FreeFileSync/Source/base/ffs_paths.cpp
+--- a/FreeFileSync/Source/base/ffs_paths.cpp 2018-12-12 15:02:09.000000000 +0100
++++ b/FreeFileSync/Source/base/ffs_paths.cpp 2019-01-03 00:56:19.364918282 +0100
+@@ -83,9 +83,7 @@
+ if (isPortableVersion())
+ cfgFolderPath = getExeFolderParentPath();
+- else //OS standard path (XDG layout): ~/.config/FreeFileSync
++ else //OS standard path (classic layout): ~/.FreeFileSync
+ {
+- //wxBug: wxStandardPaths::GetUserDataDir() does not honor FileLayout_XDG flag
+- wxStandardPaths::Get().SetFileLayout(wxStandardPaths::FileLayout_XDG);
+- cfgFolderPath = appendSeparator(utfTo<Zstring>(wxStandardPaths::Get().GetUserConfigDir())) + "FreeFileSync";
++ cfgFolderPath = utfTo<Zstring>(wxStandardPaths::Get().GetUserDataDir());
+ }
+