summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJochum Döring2020-12-20 04:58:44 +0100
committerJochum Döring2020-12-20 04:58:44 +0100
commitceecaf817568d4120e295a7c3ae036478b33c66c (patch)
tree092834df45643094f7dfe61250ceb23daed7341d
parent52f1872e81c639238fdbf9ebfb41c43720c8dde5 (diff)
downloadaur-ceecaf817568d4120e295a7c3ae036478b33c66c.tar.gz
fix for curl wrapper
-rwxr-xr-x.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--curl_fix.patch29
3 files changed, 39 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96efed6144a9..93c65ae147dc 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = freefilesync
pkgdesc = Backup software to synchronize files and folders
pkgver = 11.0
- pkgrel = 1
+ pkgrel = 2
url = https://freefilesync.org
arch = i686
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = freefilesync
depends = curl
depends = lsb-release
source = FreeFileSync_11.0_Source.zip::https://freefilesync.org/download/FreeFileSync_11.0_Source.zip
+ source = curl_fix.patch
source = revert_xdg_config_path.patch
source = revert_bulk_append.patch
source = revert_linkflags.patch
@@ -18,6 +19,7 @@ pkgbase = freefilesync
source = RealTimeSync.desktop
source = dlagent
sha256sums = 361bab0798811764701cfda297c2031b9decb04bb2e434ec8fe80ba8cc01e56a
+ sha256sums = 72687c95350814f5517d0db7f2ca1eeac4cff1dcbe00a9a8365f5dc76172ab2f
sha256sums = 0f9a9a6b2c3c460bbde7425bd62273c925259db1cc9dc18c6013aae99fb15cd8
sha256sums = 17e7db683662809882db6d6b3d855eb4372ca1bd05e15c4c490970a0b4b127c0
sha256sums = 2942c0e74be2b15cdd83e36fa524c3b6c68d4b4da2042f1b0cf7c13d3b806eac
diff --git a/PKGBUILD b/PKGBUILD
index 8fecd78ffce3..35c095102672 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=freefilesync
pkgver=11.0
-pkgrel=1
+pkgrel=2
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
url="https://freefilesync.org"
@@ -16,6 +16,7 @@ depends=(wxgtk curl lsb-release)
makedepends=(unzip)
source=(
"FreeFileSync_${pkgver}_Source.zip::${url}/download/FreeFileSync_${pkgver}_Source.zip" #ffs
+ curl_fix.patch
revert_xdg_config_path.patch
revert_bulk_append.patch
revert_linkflags.patch
@@ -25,6 +26,7 @@ source=(
)
sha256sums=('361bab0798811764701cfda297c2031b9decb04bb2e434ec8fe80ba8cc01e56a'
+ '72687c95350814f5517d0db7f2ca1eeac4cff1dcbe00a9a8365f5dc76172ab2f'
'0f9a9a6b2c3c460bbde7425bd62273c925259db1cc9dc18c6013aae99fb15cd8'
'17e7db683662809882db6d6b3d855eb4372ca1bd05e15c4c490970a0b4b127c0'
'2942c0e74be2b15cdd83e36fa524c3b6c68d4b4da2042f1b0cf7c13d3b806eac'
@@ -42,10 +44,13 @@ prepare() {
# Avoid uses of wxItemContainer::Append(const std::vector<wxString>& items)
patch -p1 -i revert_bulk_append.patch
- # edit lines to remove functions that require wxgtk 3.1.x
+ # edit lines to remove functions that require wxgtk 3.1.x
sed -e 's:m_textCtrlOfflineActivationKey->ForceUpper:// &:g' -i 'FreeFileSync/Source/ui/small_dlgs.cpp'
sed -e 's:const double scrollSpeed =:& 6; //:g' -i 'wx+/grid.cpp'
+# fix for curl wrapper
+ patch -p1 -i curl_fix.patch
+
# add LINKFLAGS that were removed but that we still need in our case
patch -p1 -i revert_linkflags.patch
diff --git a/curl_fix.patch b/curl_fix.patch
new file mode 100644
index 000000000000..4b1ee1b0f955
--- /dev/null
+++ b/curl_fix.patch
@@ -0,0 +1,29 @@
+diff -r -u a/libcurl/curl_wrap.h b/libcurl/curl_wrap.h
+--- a/libcurl/curl_wrap.h 2020-07-22 13:22:19.000000000 +0200
++++ b/libcurl/curl_wrap.h 2020-12-05 14:38:38.000000000 +0100
+@@ -138,8 +138,9 @@
+ ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_HTTP3);
+ ZEN_CHECK_CASE_FOR_CONSTANT(CURL_LAST);
+ ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_QUIC_CONNECT_ERROR);
++ ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_PROXY);
+ }
+- static_assert(CURL_LAST == CURLE_QUIC_CONNECT_ERROR + 1);
++ static_assert(CURL_LAST == CURLE_PROXY + 1);
+
+ return replaceCpy<std::wstring>(L"Curl status %x", L"%x", numberTo<std::wstring>(static_cast<int>(sc)));
+ }
+@@ -148,12 +149,10 @@
+ void applyCurlOptions(CURL* easyHandle, const std::vector<CurlOption>& options) //throw SysError
+ {
+ for (const CurlOption& opt : options)
+- {
+- const CURLcode rc = ::curl_easy_setopt(easyHandle, opt.option, opt.value);
+- if (rc != CURLE_OK)
++ if (const CURLcode rc = ::curl_easy_setopt(easyHandle, opt.option, opt.value);
++ rc != CURLE_OK)
+ throw SysError(formatSystemError("curl_easy_setopt(" + numberTo<std::string>(static_cast<int>(opt.option)) + ")",
+ formatCurlStatusCode(rc), utfTo<std::wstring>(::curl_easy_strerror(rc))));
+- }
+ }
+ }
+ }