summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Ramos2015-06-17 14:11:24 -0500
committerAlfredo Ramos2015-06-17 14:11:24 -0500
commite2b36b4578d5f8545870631a7e8760d3ce4814ab (patch)
tree52dd08004fa45e88ee2c06be21f2332f6ab64143
parent4b6515c3dd6e647c880bc23855c0685b6ed66eb0 (diff)
downloadaur-e2b36b4578d5f8545870631a7e8760d3ce4814ab.tar.gz
Use Arch\'s jsoncpp lib. Latest Freeminer commit.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fac46222aa2..4b9ef629767e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = freeminer-git
pkgdesc = An open source sandbox game inspired by Minecraft. Development version.
- pkgver = 0.4.12.6.r874.gf1085d3
- pkgrel = 2
+ pkgver = 0.4.12.6.r976.g9715672
+ pkgrel = 1
url = http://freeminer.org/
install = freeminer-git.install
arch = i686
@@ -20,9 +20,10 @@ pkgbase = freeminer-git
depends = irrlicht
depends = openal
depends = enet
+ depends = jsoncpp
depends = libvorbis
depends = hicolor-icon-theme
- provides = freeminer=0.4.12.6.r874.gf1085d3
+ provides = freeminer=0.4.12.6.r976.g9715672
conflicts = freeminer
source = git+https://github.com/freeminer/freeminer.git
source = freeminer-git.install
diff --git a/PKGBUILD b/PKGBUILD
index ca3634a31a41..800c07e14c81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname=freeminer
pkgname=${_pkgname}-git
-pkgver=0.4.12.6.r874.gf1085d3
-pkgrel=2
+pkgver=0.4.12.6.r976.g9715672
+pkgrel=1
pkgdesc='An open source sandbox game inspired by Minecraft. Development version.'
arch=('i686' 'x86_64')
url='http://freeminer.org/'
license=('GPL3' 'CCPL:cc-by-sa-3.0')
-depends=('leveldb' 'curl' 'hiredis' 'sqlite' 'luajit' 'xdg-utils' 'irrlicht' 'openal' 'enet' 'libvorbis' 'hicolor-icon-theme')
+depends=('leveldb' 'curl' 'hiredis' 'sqlite' 'luajit' 'xdg-utils' 'irrlicht' 'openal' 'enet' 'jsoncpp' 'libvorbis' 'hicolor-icon-theme')
makedepends=('cmake' 'git' 'msgpack-c')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
@@ -45,11 +45,12 @@ prepare() {
# Use Arch's enet lib
patch ./src/main.cpp ../enet_shared_lib.patch
- # Remove src/msgpack-c and src/enet submodule
- git submodule deinit src/{msgpack-c,enet}
- git rm --cached src/{msgpack-c,enet}
+ # Remove src/msgpack-c src/enet and src/jsoncpp submodules
+ git submodule deinit src/{msgpack-c,enet,jsoncpp}
+ git rm --cached src/{msgpack-c,enet,jsoncpp}
git config -f .gitmodules --remove-section submodule.src/msgpack-c
git config -f .gitmodules --remove-section submodule.src/enet
+ git config -f .gitmodules --remove-section submodule.src/jsoncpp
git add .gitmodules
# Cloning with submodules
@@ -72,7 +73,8 @@ build() {
cmake ../${_pkgname} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DRUN_IN_PLACE=0 \
- -DENABLE_SYSTEM_MSGPACK=1
+ -DENABLE_SYSTEM_MSGPACK=1 \
+ -DENABLE_SYSTEM_JSONCPP=1
make -j${njobs}
}