summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-07-20 16:09:06 -0400
committerskydrome2015-07-20 16:09:06 -0400
commit9f8b4544fbc99c8930b2209aa0a88ad765f71542 (patch)
tree1b71b918b0205a3963fd75782b3375401b9a64c0
parenta9e2199f94969bbb88790231d8c9a1e169a2e6c4 (diff)
downloadaur-9f8b4544fbc99c8930b2209aa0a88ad765f71542.tar.gz
modified: freenet.install
-rw-r--r--PKGBUILD4
-rw-r--r--freenet.install14
2 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da96fc876a57..e5fe08fed871 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
#
_fred=#tag=build01469 # build 1469: 2015-07-19
+#_fred=#tag=testing-build-1469-pre2
#_fred=#branch=next # git HEAD
-epoch=1
# comment out to run unit tests
BUILDENV+=('!check')
@@ -16,7 +16,7 @@ _plugins=('WebOfTrust' 'JSTUN' 'UPnP' 'KeyUtils')
pkgname=freenet
pkgver=0.7.5.1469
pkgrel=1
-
+epoch=1
_pkgver=0.7.5
pkgdesc="An encrypted network without censorship"
url="https://downloads.freenetproject.org"
diff --git a/freenet.install b/freenet.install
index 91ab82eb3c5d..5c7c7995da44 100644
--- a/freenet.install
+++ b/freenet.install
@@ -8,17 +8,27 @@ post_install() {
echo "ok" || echo "fail"
}
chown -R freenet:freenet /opt/freenet /run/freenet
- echo "Please visit http://127.0.0.1:8888/ to configure your node"
+ echo
+ echo "Freenet will be slow at first startup while it discovers the network."
+ echo "You may see Data Not Found or Route Not Found errors, this is normal."
+ echo "For best performance Freenet should be run 24/7 as much as possible."
+ echo "Your node's configuration WebUI will be located at http://127.0.0.1:8888/ "
+ echo " https://freenetproject.org/faq.html"
+ echo
}
post_upgrade() {
chown -R freenet:freenet /opt/freenet /run/freenet
-}
+ echo
+ echo " Freenet WebUI http://127.0.0.1:8888/ "
+ echo " Changelog https://github.com/freenet/fred/releases/tag/build01469"
+ echo
pre_remove() {
getent passwd freenet &>/dev/null && {
echo -n ">>> Removing freenet system user... "
userdel freenet
echo "ok"
+ echo
}
}