summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2023-08-05 19:27:13 +0200
committerMichael Laß2023-08-05 19:27:13 +0200
commiteb287b1368359a2275edec4ce8a903513816960d (patch)
treefb031129f2c1d42c6ae0fbe93aa631d03078e8c4
parentb8bc5b2f2f7c717549f505d6d984fb1e71731fcf (diff)
downloadaur-eb287b1368359a2275edec4ce8a903513816960d.tar.gz
Update to 1.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Quick-Dirty-patch-to-allow-finding-quazip-qt5-on-Arc.patch22
-rw-r--r--PKGBUILD12
3 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f31a761dcef..6a9a86a3c0a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fritzing
pkgdesc = PCB layout prototyping application
- pkgver = 0.9.10
- pkgrel = 2
+ pkgver = 1.0.0
+ pkgrel = 1
url = http://fritzing.org
install = fritzing.install
arch = aarch64
@@ -15,11 +15,11 @@ pkgbase = fritzing
depends = qt5-svg
depends = quazip-qt5
depends = ngspice
- source = git+https://github.com/fritzing/fritzing-app.git#commit=29c2cede3a0475ed770db1ee502fdebf6bf3a23d
- source = git+https://github.com/fritzing/fritzing-parts.git#commit=4713511c894cb2894eae505b9307c6555afcc32c
+ source = git+https://github.com/fritzing/fritzing-app.git#commit=fe6d2f9c8b58d981a0e119ca251da54dc5959c24
+ source = git+https://github.com/fritzing/fritzing-parts.git#commit=9597553a1adc09019b4a42fe7929196abff18133
source = 0001-Quick-Dirty-patch-to-allow-finding-quazip-qt5-on-Arc.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 65e0818e959f07209928907ddeb76c3e73229fdc0a049c433c842621d59e6e32
+ sha256sums = 6e4200a5d53f8241052c0f61c7a49e71ae4a36051fd29f3e750b1a39ec9c149d
pkgname = fritzing
diff --git a/0001-Quick-Dirty-patch-to-allow-finding-quazip-qt5-on-Arc.patch b/0001-Quick-Dirty-patch-to-allow-finding-quazip-qt5-on-Arc.patch
index 910fca1fd915..26d5b57dfa18 100644
--- a/0001-Quick-Dirty-patch-to-allow-finding-quazip-qt5-on-Arc.patch
+++ b/0001-Quick-Dirty-patch-to-allow-finding-quazip-qt5-on-Arc.patch
@@ -1,22 +1,22 @@
-From 3a75861c4215633bdcc322f2b3d9aa26a05c0663 Mon Sep 17 00:00:00 2001
+From 5e2c8a39e746b9661e2042146e0a39364ff1919a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Michael=20La=C3=9F?= <bevan@bi-co.net>
Date: Thu, 26 Jan 2023 19:18:56 +0100
Subject: [PATCH] Quick & Dirty patch to allow finding quazip-qt5 on Arch Linux
---
- pri/quazipdetect.pri | 16 +++-------------
- 1 file changed, 3 insertions(+), 13 deletions(-)
+ pri/quazipdetect.pri | 18 ++++--------------
+ 1 file changed, 4 insertions(+), 14 deletions(-)
diff --git a/pri/quazipdetect.pri b/pri/quazipdetect.pri
-index d08322cd..532c1459 100644
+index 9f480ec6..c503af88 100644
--- a/pri/quazipdetect.pri
+++ b/pri/quazipdetect.pri
@@ -5,20 +5,10 @@ message("Using fritzing quazip detect script.")
SOURCES += \
src/zlibdummy.c \
--exists($$absolute_path($$PWD/../../quazip_qt5)) {
-- QUAZIPPATH = $$absolute_path($$PWD/../../quazip_qt5)
+-exists($$absolute_path($$PWD/../../quazip_qt$$QT_MAJOR_VERSION)) {
+- QUAZIPPATH = $$absolute_path($$PWD/../../quazip_qt$$QT_MAJOR_VERSION)
- message("found quazip in $${QUAZIPPATH}")
- } else {
- error("quazip could not be found.")
@@ -27,20 +27,22 @@ index d08322cd..532c1459 100644
unix:!macx {
message("including quazip library on linux")
- INCLUDEPATH += $$absolute_path($${QUAZIPPATH}/include/quazip)
-- LIBS += -L$$absolute_path($${QUAZIPPATH}/lib) -lquazip1-qt5
+- LIBS += -L$$absolute_path($${QUAZIPPATH}/lib) -lquazip1-qt$$QT_MAJOR_VERSION
- QMAKE_RPATHDIR += $$absolute_path($${QUAZIPPATH}/lib)
+ INCLUDEPATH += /usr/include/QuaZip-Qt5-1.4/quazip/
+ LIBS += -lquazip1-qt5
}
macx {
-@@ -56,4 +46,4 @@ win32 {
+@@ -55,5 +45,5 @@ win32 {
+ error("quazip library not found in $$QUAZIPLIB")
}
- LIBS += -L$$QUAZIPLIB -lquazip1-qt5
+- LIBS += -L$$QUAZIPLIB -lquazip1-qt$$QT_MAJOR_VERSION
-}
\ No newline at end of file
++ LIBS += -L$$QUAZIPLIB -lquazip1-qt5
+}
--
-2.39.1
+2.41.0
diff --git a/PKGBUILD b/PKGBUILD
index a23858080ea1..93377246a9d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@ pkgname=fritzing
# We drop the "b" at the end of the version number. It probably means beta
# while there is also "d" for development versions. This would not be correctly
# parsed by `pkgver` anyway (d > b), so let's leave out the b suffix entirely.
-pkgver=0.9.10
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
# Tag version can be obtained from github release page. Sometimes this is the
# version number itself, sometimes some CD-magicnumber thing. There can be
@@ -19,8 +19,8 @@ pkgrel=2
# guess what corresponds to the latest official release.
#_tagver=0.9.8
-# This is probably closest to what has been released as 0.9.10.
-_gitrev=29c2cede3a0475ed770db1ee502fdebf6bf3a23d
+# This is probably closest to what has been released as 1.0.0.
+_gitrev=fe6d2f9c8b58d981a0e119ca251da54dc5959c24
# Parts come from a different respository and are not versioned anymore since
# 2016. Sometimes we can get the revision by downloading the release build,
@@ -28,7 +28,7 @@ _gitrev=29c2cede3a0475ed770db1ee502fdebf6bf3a23d
# release build seems to be hidden behind a paywall. Then we need to guess
# based on the master branch of the fritzing-parts repository and the date when
# the release archive was created.
-_partsrev=4713511c894cb2894eae505b9307c6555afcc32c
+_partsrev=9597553a1adc09019b4a42fe7929196abff18133
pkgdesc='PCB layout prototyping application'
arch=('aarch64' 'i686' 'x86_64')
@@ -42,7 +42,7 @@ source=("git+https://github.com/fritzing/fritzing-app.git#commit=${_gitrev}"
0001-Quick-Dirty-patch-to-allow-finding-quazip-qt5-on-Arc.patch)
sha256sums=('SKIP'
'SKIP'
- '65e0818e959f07209928907ddeb76c3e73229fdc0a049c433c842621d59e6e32')
+ '6e4200a5d53f8241052c0f61c7a49e71ae4a36051fd29f3e750b1a39ec9c149d')
prepare() {
cd "${srcdir}"/fritzing-app