summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmirul Fitri2022-05-25 13:45:03 +0800
committerAmirul Fitri2022-05-25 13:45:03 +0800
commit3353bcacc997ee9fa10e6163d09a2d97473ca876 (patch)
tree53951976333490c8aa6c2efbc317a45400891f7d
parent9f06498057af9f8e055d58360f40942c5655f9eb (diff)
downloadaur-frozen.tar.gz
cleanup
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df2195f479b9..55628e76c195 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = frozen
- pkgdesc = Header-only library that provides 0 cost initialization for immutable containers, fixed-size containers, and various algorithms.
+ pkgdesc = A header-only, constexpr alternative to gperf for C++14 users
pkgver = 1.1.1
pkgrel = 1
url = https://github.com/serge-sans-paille/frozen
diff --git a/PKGBUILD b/PKGBUILD
index 7553db32f207..d4b1f46b7f1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=f75fffcc077e5cda0bf3c87121dca103855d2be5
pkgname=frozen
pkgver=1.1.1
pkgrel=1
-pkgdesc="Header-only library that provides 0 cost initialization for immutable containers, fixed-size containers, and various algorithms."
+pkgdesc="A header-only, constexpr alternative to gperf for C++14 users"
arch=('any')
url="https://github.com/serge-sans-paille/frozen"
license=('Apache')
@@ -18,9 +18,12 @@ sha256sums=('SKIP')
prepare() {
cd "${pkgname}"
- cmake -E make_directory build
+ cmake -E make_directory .build
cmake -B.build \
+ -DCMAKE_SKIP_INSTALL_RPATH=YES \
+ -DCMAKE_SKIP_RPATH=YES \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF
}