summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2018-06-12 11:03:19 +0700
committerKonstantin Shalygin2018-06-12 11:03:19 +0700
commitcbbac2b50c8df6cb133fee1d9474c66ef09bfea4 (patch)
treec2b79e53f92e36f98b71a64de9c727611ee57094
parentc5066c14c875686d31c7c6cbf403e55e9dc5080a (diff)
downloadaur-cbbac2b50c8df6cb133fee1d9474c66ef09bfea4.tar.gz
Bump to 5.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
-rw-r--r--frr_5.0_systemd_arch.patch (renamed from frr_4.0_systemd_arch.patch)114
3 files changed, 92 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3b2fba96d2b..8da33caceee0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 26 08:54:04 UTC 2018
+# Tue Jun 12 04:02:48 UTC 2018
pkgbase = frr
pkgdesc = FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, NHRP and EIGRP.
- pkgver = 4.0
- pkgrel = 3
+ pkgver = 5.0
+ pkgrel = 1
url = https://frrouting.org/
arch = any
license = GPL2
@@ -15,6 +15,7 @@ pkgbase = frr
makedepends = c-ares
makedepends = perl-xml-libxml
makedepends = rtrlib
+ makedepends = python-sphinx
depends = libcap
depends = libnl
depends = readline
@@ -28,14 +29,14 @@ pkgbase = frr
conflicts = quagga
conflicts = babeld
conflicts = quagga_cumulus
- source = https://github.com/FRRouting/frr/archive/frr-4.0.tar.gz
+ source = https://github.com/FRRouting/frr/archive/frr-5.0.tar.gz
source = frr.sysusers
source = frr.tmpfiles
- source = frr_4.0_systemd_arch.patch
- sha256sums = a9932ef116106d56b0e17aa569aa56a458acdd50e0d07c042fd5cc725bf742cc
+ source = frr_5.0_systemd_arch.patch
+ sha256sums = 96f8cf9a2d34b7720724491027cc6c1e15b82b8e5bf71fdae0a9e3e1619f4c74
sha256sums = 9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e
sha256sums = 6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89
- sha256sums = 0f8b7a06412dd1f2a04615910a520a244cb35c30ff0f78138e2177b813ff8aad
+ sha256sums = 7cb48afa57c9d9d29adbc2b000aaeb1736aebf7cc88e545e7b41ef1242171620
pkgname = frr
diff --git a/PKGBUILD b/PKGBUILD
index a20d8ea7af83..d1f06cd137c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,30 @@
# Contributor: Shalygin Konstantin <k0ste@k0ste.ru>
pkgname='frr'
-pkgver='4.0'
-pkgrel='3'
+pkgver='5.0'
+pkgrel='1'
pkgdesc='FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, NHRP and EIGRP.'
arch=('any')
url="https://frrouting.org/"
license=('GPL2')
depends=('libcap' 'libnl' 'readline' 'ncurses' 'perl' 'json-c' 'net-snmp' 'rtrlib')
-makedepends=('patch' 'gcc' 'net-snmp' 'json-c' 'bison' 'c-ares' 'perl-xml-libxml' 'rtrlib')
+makedepends=('patch' 'gcc' 'net-snmp' 'json-c' 'bison' 'c-ares' 'perl-xml-libxml' 'rtrlib' 'python-sphinx')
conflicts=('quagga' 'babeld' 'quagga_cumulus')
provides=('quagga' 'quagga_cumulus')
source=("https://github.com/FRRouting/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.sysusers"
"${pkgname}.tmpfiles"
- "${pkgname}_4.0_systemd_arch.patch")
-sha256sums=('a9932ef116106d56b0e17aa569aa56a458acdd50e0d07c042fd5cc725bf742cc'
+ "${pkgname}_5.0_systemd_arch.patch")
+sha256sums=('96f8cf9a2d34b7720724491027cc6c1e15b82b8e5bf71fdae0a9e3e1619f4c74'
'9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e'
'6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89'
- '0f8b7a06412dd1f2a04615910a520a244cb35c30ff0f78138e2177b813ff8aad')
+ '7cb48afa57c9d9d29adbc2b000aaeb1736aebf7cc88e545e7b41ef1242171620')
prepare() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
# https://github.com/FRRouting/frr/issues/1422
- patch -p1 -i "${srcdir}/${pkgname}_4.0_systemd_arch.patch"
+ patch -p1 -i "${srcdir}/${pkgname}_5.0_systemd_arch.patch"
autoreconf -fvi
./configure \
@@ -67,7 +67,7 @@ package() {
sed -ri 's|/var/run/frr|/run/frr|g' "${pkgname}.logrotate"
install -Dm0644 "${pkgname}.logrotate" "${pkgdir}/etc/logrotate.d/${pkgname}"
- for d in zebra ripd ripngd bgpd ospfd ospfd-instance@ ospf6d isisd pimd ldpd nhrpd; do
+ for d in babeld bgpd eigrpd isisd ldpd nhrpd ospf6d ospfd ospfd-instance@ pbrd pimd ripd ripngd zebra; do
install -Dm0644 ${d}.service "${pkgdir}/usr/lib/systemd/system/${d}.service"
done
diff --git a/frr_4.0_systemd_arch.patch b/frr_5.0_systemd_arch.patch
index 9a308c0b3ce1..5de8e865393d 100644
--- a/frr_4.0_systemd_arch.patch
+++ b/frr_5.0_systemd_arch.patch
@@ -1,6 +1,6 @@
-diff -Naupr frr-frr-4.0_orig/redhat/babeld.service frr-frr-4.0/redhat/babeld.service
---- frr-frr-4.0_orig/redhat/babeld.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/babeld.service 2018-04-26 15:28:34.256745385 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/babeld.service frr-frr-5.0/redhat/babeld.service
+--- frr-frr-5.0_orig/redhat/babeld.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/babeld.service 2018-06-12 10:29:41.517126062 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=Babel routing daemon
@@ -17,9 +17,9 @@ diff -Naupr frr-frr-4.0_orig/redhat/babeld.service frr-frr-4.0/redhat/babeld.ser
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/bgpd.service frr-frr-4.0/redhat/bgpd.service
---- frr-frr-4.0_orig/redhat/bgpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/bgpd.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/bgpd.service frr-frr-5.0/redhat/bgpd.service
+--- frr-frr-5.0_orig/redhat/bgpd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/bgpd.service 2018-06-12 10:29:41.517126062 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=BGP routing daemon
@@ -36,9 +36,28 @@ diff -Naupr frr-frr-4.0_orig/redhat/bgpd.service frr-frr-4.0/redhat/bgpd.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/isisd.service frr-frr-4.0/redhat/isisd.service
---- frr-frr-4.0_orig/redhat/isisd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/isisd.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr "frr-frr-5.0_orig/redhat/eigrpd.service" "frr-frr-5.0/redhat/eigrpd.service"
+--- "frr-frr-5.0_orig/redhat/eigrpd.service" 1970-01-01 07:00:00.000000000 +0700
++++ "frr-frr-5.0/redhat/eigrpd.service" 2018-06-12 10:33:14.136729580 +0700
+@@ -0,0 +1,15 @@
++[Unit]
++Description=EIGRP routing daemon
++Documentation=man:eigrpd(8) man:zebra(8)
++BindTo=zebra.service
++After=network.target zebra.service
++
++[Service]
++Type=forking
++PIDFile=/run/frr/eigrpd.pid
++ExecStart=/usr/bin/eigrpd -d
++ExecReload=/bin/kill -HUP $MAINPID
++Restart=on-abort
++
++[Install]
++WantedBy=multi-user.target
+diff -Naupr frr-frr-5.0_orig/redhat/isisd.service frr-frr-5.0/redhat/isisd.service
+--- frr-frr-5.0_orig/redhat/isisd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/isisd.service 2018-06-12 10:29:41.517126062 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=IS-IS routing daemon
@@ -55,9 +74,9 @@ diff -Naupr frr-frr-4.0_orig/redhat/isisd.service frr-frr-4.0/redhat/isisd.servi
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/ldpd.service frr-frr-4.0/redhat/ldpd.service
---- frr-frr-4.0_orig/redhat/ldpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/ldpd.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/ldpd.service frr-frr-5.0/redhat/ldpd.service
+--- frr-frr-5.0_orig/redhat/ldpd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/ldpd.service 2018-06-12 10:29:41.520459491 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=LDP engine
@@ -74,9 +93,9 @@ diff -Naupr frr-frr-4.0_orig/redhat/ldpd.service frr-frr-4.0/redhat/ldpd.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/nhrpd.service frr-frr-4.0/redhat/nhrpd.service
---- frr-frr-4.0_orig/redhat/nhrpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/nhrpd.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/nhrpd.service frr-frr-5.0/redhat/nhrpd.service
+--- frr-frr-5.0_orig/redhat/nhrpd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/nhrpd.service 2018-06-12 10:29:41.520459491 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=NHRP daemon
@@ -93,9 +112,9 @@ diff -Naupr frr-frr-4.0_orig/redhat/nhrpd.service frr-frr-4.0/redhat/nhrpd.servi
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/ospf6d.service frr-frr-4.0/redhat/ospf6d.service
---- frr-frr-4.0_orig/redhat/ospf6d.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/ospf6d.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/ospf6d.service frr-frr-5.0/redhat/ospf6d.service
+--- frr-frr-5.0_orig/redhat/ospf6d.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/ospf6d.service 2018-06-12 10:29:41.520459491 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=OSPF routing daemon for IPv6
@@ -112,9 +131,9 @@ diff -Naupr frr-frr-4.0_orig/redhat/ospf6d.service frr-frr-4.0/redhat/ospf6d.ser
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/ospfd-instance@.service frr-frr-4.0/redhat/ospfd-instance@.service
---- frr-frr-4.0_orig/redhat/ospfd-instance@.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/ospfd-instance@.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/ospfd-instance@.service frr-frr-5.0/redhat/ospfd-instance@.service
+--- frr-frr-5.0_orig/redhat/ospfd-instance@.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/ospfd-instance@.service 2018-06-12 10:29:41.520459491 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=OSPF routing daemon instance %i
@@ -131,9 +150,9 @@ diff -Naupr frr-frr-4.0_orig/redhat/ospfd-instance@.service frr-frr-4.0/redhat/o
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/ospfd.service frr-frr-4.0/redhat/ospfd.service
---- frr-frr-4.0_orig/redhat/ospfd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/ospfd.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/ospfd.service frr-frr-5.0/redhat/ospfd.service
+--- frr-frr-5.0_orig/redhat/ospfd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/ospfd.service 2018-06-12 10:29:41.520459491 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=OSPF routing daemon
@@ -150,9 +169,28 @@ diff -Naupr frr-frr-4.0_orig/redhat/ospfd.service frr-frr-4.0/redhat/ospfd.servi
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/pimd.service frr-frr-4.0/redhat/pimd.service
---- frr-frr-4.0_orig/redhat/pimd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/pimd.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/pbrd.service frr-frr-5.0/redhat/pbrd.service
+--- frr-frr-5.0_orig/redhat/pbrd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/pbrd.service 2018-06-12 10:33:26.043757381 +0700
+@@ -0,0 +1,15 @@
++[Unit]
++Description=PBR routing daemon
++Documentation=man:pbrd(8) man:zebra(8)
++BindTo=zebra.service
++After=network.target zebra.service
++
++[Service]
++Type=forking
++PIDFile=/run/frr/pbrd.pid
++ExecStart=/usr/bin/pbrd -d
++ExecReload=/bin/kill -HUP $MAINPID
++Restart=on-abort
++
++[Install]
++WantedBy=multi-user.target
+diff -Naupr frr-frr-5.0_orig/redhat/pimd.service frr-frr-5.0/redhat/pimd.service
+--- frr-frr-5.0_orig/redhat/pimd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/pimd.service 2018-06-12 10:29:41.520459491 +0700
@@ -0,0 +1,14 @@
+[Unit]
+Description=PIM multicast routing engine
@@ -163,14 +201,14 @@ diff -Naupr frr-frr-4.0_orig/redhat/pimd.service frr-frr-4.0/redhat/pimd.service
+[Service]
+Type=forking
+PIDFile=/run/frr/pimd.pid
-+ExecStart=/usr/sbin/pimd -d
++ExecStart=/usr/bin/pimd -d
+Restart=on-abort
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/ripd.service frr-frr-4.0/redhat/ripd.service
---- frr-frr-4.0_orig/redhat/ripd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/ripd.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/ripd.service frr-frr-5.0/redhat/ripd.service
+--- frr-frr-5.0_orig/redhat/ripd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/ripd.service 2018-06-12 10:29:41.520459491 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=RIP routing daemon
@@ -187,9 +225,9 @@ diff -Naupr frr-frr-4.0_orig/redhat/ripd.service frr-frr-4.0/redhat/ripd.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/ripngd.service frr-frr-4.0/redhat/ripngd.service
---- frr-frr-4.0_orig/redhat/ripngd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/ripngd.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/ripngd.service frr-frr-5.0/redhat/ripngd.service
+--- frr-frr-5.0_orig/redhat/ripngd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/ripngd.service 2018-06-12 10:29:41.520459491 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=RIP routing daemon for IPv6
@@ -206,9 +244,9 @@ diff -Naupr frr-frr-4.0_orig/redhat/ripngd.service frr-frr-4.0/redhat/ripngd.ser
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr-frr-4.0_orig/redhat/zebra.service frr-frr-4.0/redhat/zebra.service
---- frr-frr-4.0_orig/redhat/zebra.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-4.0/redhat/zebra.service 2018-04-26 15:27:31.689567082 +0700
+diff -Naupr frr-frr-5.0_orig/redhat/zebra.service frr-frr-5.0/redhat/zebra.service
+--- frr-frr-5.0_orig/redhat/zebra.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-5.0/redhat/zebra.service 2018-06-12 10:29:41.520459491 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=GNU Zebra routing manager
@@ -218,7 +256,7 @@ diff -Naupr frr-frr-4.0_orig/redhat/zebra.service frr-frr-4.0/redhat/zebra.servi
+[Service]
+Type=forking
+PIDFile=/run/frr/zebra.pid
-+ExecStartPre=/sbin/ip route flush proto zebra
++ExecStartPre=/usr/bin/ip route flush proto zebra
+ExecStart=/usr/bin/zebra -d
+ExecReload=/bin/kill -HUP $MAINPID
+Restart=on-abort