summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniël de Kok2018-01-01 12:01:23 +0100
committerDaniël de Kok2018-01-01 12:01:48 +0100
commitc6fd16e0dc992cda4b684332952ece9219da4e41 (patch)
treed1032baaca390f8d610a0a2080e2dc3a645d6d22
downloadaur-fsa6.tar.gz
Add fsa6 r280.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
-rw-r--r--fsa6.desktop9
-rw-r--r--fsa6.pngbin0 -> 13953 bytes
-rw-r--r--fsa6.sh4
5 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb5982c1232d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = fsa6
+ pkgdesc = Finite state automata utilities
+ pkgver = 280
+ pkgrel = 3
+ url = http://odur.let.rug.nl/~vannoord/Fsa/
+ arch = x86_64
+ license = GPL2
+ depends = tcl
+ depends = tk
+ optdepends = python: generation of Python bindings for C automata
+ optdepends = java-environment: Java support
+ source = http://odur.let.rug.nl/~vannoord/Fsa/binaries/fsa6-280-x86_64-linux-glibc2.19.tar.gz
+ source = fsa6.sh
+ source = fsa6.png
+ source = fsa6.desktop
+ sha256sums = 1b140b9d31bc1a504893ad17b59893e89e2140ea943e7642e9b4efe616f46093
+ sha256sums = 50de3778accfbb989258488a34b00149ae1fc00c989ce8870f16fc8eeb0cacf8
+ sha256sums = d0997dcf378b28bd7051c1d1da1fe53acbef59344787c0bbb925456669d56a0b
+ sha256sums = d82b3baa9f634188bbbe4b005ad2d036e54e45c7df9bf7825d41ba1173a8702a
+
+pkgname = fsa6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8cc12c8fa1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Daniël de Kok <me@danieldk.eu>
+pkgname=fsa6
+pkgver=280
+pkgrel=3
+pkgdesc="Finite state automata utilities"
+arch=("x86_64")
+url="http://odur.let.rug.nl/~vannoord/Fsa/"
+license=('GPL2')
+depends=('tcl' 'tk')
+optdepends=('python: generation of Python bindings for C automata'
+ 'java-environment: Java support')
+source=("http://odur.let.rug.nl/~vannoord/Fsa/binaries/fsa6-${pkgver}-x86_64-linux-glibc2.19.tar.gz"
+ fsa6.sh
+ fsa6.png
+ fsa6.desktop)
+sha256sums=('1b140b9d31bc1a504893ad17b59893e89e2140ea943e7642e9b4efe616f46093'
+ '50de3778accfbb989258488a34b00149ae1fc00c989ce8870f16fc8eeb0cacf8'
+ 'd0997dcf378b28bd7051c1d1da1fe53acbef59344787c0bbb925456669d56a0b'
+ 'd82b3baa9f634188bbbe4b005ad2d036e54e45c7df9bf7825d41ba1173a8702a')
+
+package() {
+ install -dm 755 "${pkgdir}"/{usr/lib,usr/bin}
+ cp -R "$srcdir"/fsa6 "${pkgdir}"/usr/lib/fsa6
+
+ # Remove stray .svn directory.
+ rm -rf "${pkgdir}"/usr/lib/fsa6/.svn
+
+ # The current version of the FSA utilities expect TCL/TK 8.4.
+ ln -sf /usr/lib/libtcl8.6.so "${pkgdir}"/usr/lib/fsa6/binary/create/libtcl8.5.so
+ ln -sf /usr/lib/libtk8.6.so "${pkgdir}"/usr/lib/fsa6/binary/create/libtk8.5.so
+
+ install -m 755 "$srcdir"/fsa6.sh "${pkgdir}"/usr/bin/fsa6
+ install -Dm 644 "$srcdir"/fsa6.desktop "$pkgdir"/usr/share/applications/fsa6.desktop
+ install -Dm 644 "$srcdir"/fsa6.png "$pkgdir"/usr/share/pixmaps/fsa6.png
+}
diff --git a/fsa6.desktop b/fsa6.desktop
new file mode 100644
index 000000000000..cb22c5616417
--- /dev/null
+++ b/fsa6.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=FSA Utilities
+Comment=Finite state automata utilities
+Exec=/usr/bin/fsa6 -tk
+Terminal=true
+Categories=Science;Education
+Icon=fsa6
diff --git a/fsa6.png b/fsa6.png
new file mode 100644
index 000000000000..56aefc63b742
--- /dev/null
+++ b/fsa6.png
Binary files differ
diff --git a/fsa6.sh b/fsa6.sh
new file mode 100644
index 000000000000..b7747235f334
--- /dev/null
+++ b/fsa6.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+LD_LIBRARY_PATH="/usr/lib/fsa6/binary/create" \
+exec /usr/lib/fsa6/binary/create/fsa "$@"