summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomZ2020-11-16 15:24:08 +0100
committerTomZ2020-11-16 15:24:08 +0100
commitbc4ef0a8f8b7c31b9682aaba3bbc47b2abc762bf (patch)
tree7911aa37697c5e8f87d8f64cab2cb3e5def11ca9
parentadd81e9a8408bcf6f3da3455f82c0911ff941d98 (diff)
downloadaur-bc4ef0a8f8b7c31b9682aaba3bbc47b2abc762bf.tar.gz
Update to latest
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--fulcrum.conf132
3 files changed, 127 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f74f252bed0..0f9bc0d43fcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fulcrum
pkgdesc = A fast & nimble SPV server for Bitcoin Cash
- pkgver = 1.2.12
+ pkgver = 1.3.1
pkgrel = 1
url = https://gitlab.com/FloweeTheHub/fulcrum
install = fulcrum.install
@@ -12,10 +12,10 @@ pkgbase = fulcrum
optdepends = jemalloc: reduce memory fragmentation
provides = fulcrum
backup = etc/fulcrum.conf
- source = https://gitlab.com/FloweeTheHub/fulcrum/-/archive/v1.2.12/fulcrum-v1.2.12.tar.gz
+ source = https://gitlab.com/FloweeTheHub/fulcrum/-/archive/v1.3.1/fulcrum-v1.3.1.tar.gz
source = fulcrum.conf
- sha256sums = 3fb0f0bd2fc0009fea8cfe4a908be201b07b458dfaf16dd12786a97811131c8a
- sha256sums = 975025a1810178a7ec32dc4bd8cd5767a68d21378ec65baf9708f6d5b3842a1b
+ sha256sums = 5069eda8226658038227c3f96d8fe5244701958adda44db2206b4fa3389e390b
+ sha256sums = 8a559a825d0b7bcd1231669e387183f05794ae919bb1b7ef84a9d74e407ff598
pkgname = fulcrum
diff --git a/PKGBUILD b/PKGBUILD
index 237b532ab5c9..f11d81d37c99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=fulcrum
pkgdesc='A fast & nimble SPV server for Bitcoin Cash'
-pkgver=1.2.12
+pkgver=1.3.1
pkgrel=1
url='https://gitlab.com/FloweeTheHub/fulcrum'
arch=('x86_64')
@@ -20,8 +20,8 @@ source=(
"https://gitlab.com/FloweeTheHub/fulcrum/-/archive/v$pkgver/fulcrum-v$pkgver.tar.gz"
"fulcrum.conf"
)
-sha256sums=('3fb0f0bd2fc0009fea8cfe4a908be201b07b458dfaf16dd12786a97811131c8a'
- '975025a1810178a7ec32dc4bd8cd5767a68d21378ec65baf9708f6d5b3842a1b'
+sha256sums=('5069eda8226658038227c3f96d8fe5244701958adda44db2206b4fa3389e390b'
+ '8a559a825d0b7bcd1231669e387183f05794ae919bb1b7ef84a9d74e407ff598'
)
prepare() {
diff --git a/fulcrum.conf b/fulcrum.conf
index 6d7211c1231e..c1e22a50d4d1 100644
--- a/fulcrum.conf
+++ b/fulcrum.conf
@@ -161,17 +161,43 @@ rpcpassword = hunter1
# SSL certificate - 'cert' - DEFAULT: None (required for SSL)
#
# Specifes the SSL certificate to use for all SSL ports. The certificate must be
-# in PEM format. (Self-signed certs are ok).
+# in PEM format. If using self-signed certs, the .pem file should contain a
+# single certificate. If using CA-signed certs, the .pem file should contain the
+# full certificate chain (e.g. fullchain.pem).
#
-#cert = /path/to/server.crt
+#cert = /path/to/server-cert.pem
# SSL private key - 'key' - DEFAULT: None (required for SSL)
#
# Specifies the SSL private key to use for encryption. At the present time only
-# RSA keys are supported, and the file must be in PEM format.
+# RSA keys are fully supported. EC, DH, and DSA keys are supported, but their
+# support is experimental. The file must be in PEM format.
#
-#key = /path/to/server.key
+#key = /path/to/server-key.pem
+
+
+# WSS-specific certificate - 'wss-cert' - DEFAULT: None (recommended for WSS)
+#
+# Similar to `cert`, but will only be applied to `wss` ports. This parameter
+# should be a CA-signed fullchain.pem file. This option is intended to allow WSS
+# ports to use a CA-signed certificate (required by web browsers), whereas
+# legacy Electrum Cash ports may want to continue to use self-signed
+# certificates. If this option is specified, `wss-key` must also be specified.
+# If this option is missing, then WSS ports will just fall-back to using the
+# certificate specified by `cert`.
+#
+#wss-cert = /path/to/my-ca-signed-wss-fullchain.pem
+
+
+# WSS-specific private key - 'wss-key' - DEFAULT: None (recommended for WSS)
+#
+# Similar parameter to `key`, but will only be applied to `wss` ports. Specify a
+# private key PEM file to use for WSS. This key must go with the certificate
+# specified in `wss-cert` above. If this option is specified, `wss-cert` must
+# also be specified.
+#
+#wss-key = /path/to/my-ca-signed-wss-privkey.pem
# Admin RPC bind - 'admin' - DEFAULT: None
@@ -535,7 +561,33 @@ rpcpassword = hunter1
#bitcoind_throttle = 50 20 5
-# Keep RocksDB Log Files - 'db_keep_log_file_num' - DEAFULT: 5
+# BitcoinD RPC Timeout - 'bitcoind_timeout' - DEFAULT: 20.0
+#
+# The number of seconds to wait for unanswered bitcoind requests before we
+# consider them as having timed-out. If the bitcoind we are connected to is in
+# IBD, is on BCH ScaleNet, can be under high load, or is not on the same local
+# machine, you may wish to set this to a higher value than the default. This
+# value should be at least high enough to allow for time to prepare and download
+# large blocks from bitcoind (this is particularly critical if bitcoind is not
+# on the same local machine and the connection to it is not particularly fast).
+# If you see the error message "bitcoind request timed out" in the log, you may
+# wish to set this value higher than the default.
+#
+#bitcoind_timeout = 20.0
+
+
+# Bitcoin daemon RPC uses TLS (HTTPS) - 'bitcoind-tls' - DEFAULT: false
+#
+# If true, connect to the remote bitcoind via HTTPS rather than the usual HTTP.
+# Historically, bitcoind supported only JSON-RPC over HTTP; however, some
+# implementations such as bchd support HTTPS. If you are using Fulcrum with
+# bchd, you either need to start bchd with the `notls` option, or you need to
+# specify this option to Fulcrum.
+#
+#bitcoind-tls = false
+
+
+# Keep RocksDB Log Files - 'db_keep_log_file_num' - DEFAULT: 5
#
# The maximum number of database log files to keep around on disk, per database.
# Specify a value in the range 5, 20000.
@@ -543,7 +595,7 @@ rpcpassword = hunter1
# db_keep_log_file_num = 5
-# Max RocksDB Open Files - 'db_max_open_files' - DEAFULT: -1 (unlimited)
+# Max RocksDB Open Files - 'db_max_open_files' - DEFAULT: 100
#
# The maximum number of database .sst files (table files) to keep open, per
# database (there are 6 databases altogether used in Fulcrum). This limit can be
@@ -552,15 +604,50 @@ rpcpassword = hunter1
# 500 to 1000 files total for all 6 databases. (As the database grows, new files
# are added.)
#
-# The default setting of "unlimited" keeps all database files open, so that
-# their indexes remain cached and in memory. This may impact memory consumption
-# but it is the fastest possible setting.
+# Specify a setting of -1 for "unlimited", that is, to keep all database files
+# open, so that their indexes remain cached and in memory. This may impact
+# memory consumption but it is the fastest possible setting.
#
# See: https://github.com/facebook/rocksdb/wiki/Memory-usage-in-RocksDB#indexes-and-filter-blocks
#
# Specify -1 for unlimited, or a value in the range 20, 2147483648.
#
-# db_max_open_files = -1
+# db_max_open_files = 100
+
+
+# Max RocksDB Memory in MiB - 'db_mem' - DEFAULT: 768.0
+#
+# Specifies roughly the maximum amount of memory to give to rocksdb. Larger
+# values offer better performance, at the expense of memory consumption. Note
+# that rocksb's memory consumption may sometimes exceed this value during high
+# load; this setting is merely advisory.
+#
+# Specify a floating-point or integer value in MiB (1 MiB = 1048576 bytes) in
+# the range 50 to 2^64. It is not advised to specify large values in excess of
+# 50% of total system RAM. The default is a good settings, however even 256
+# works well on an SSD. If using an HDD for the datadir, you may want to set
+# this value higher than the default.
+#
+# db_mem = 768.0
+
+
+# RocksDB use "fsync" - 'db_use_fsync' - DEFAULT: false
+#
+# This boolean value, if true, tells the rocksdb library to use fsync() calls as
+# opposed to fdatasync(). fsync() is slower but works around some potential
+# issues in older Linux kernels and the ext4 filesystem.
+#
+# From the rocksdb documentation:
+#
+# " By default, writes to stable storage use fdatasync (on platforms where this
+# function is available). If this option is true, fsync is used instead.
+#
+# fsync and fdatasync are equally safe for our purposes and fdatasync is
+# faster, so it is rarely necessary to set this option. It is provided as a
+# workaround for kernel/filesystem bugs, such as one that affected datasync
+# with ext4 in kernel versions prior to 3.7. " - rocksdb/options.h
+#
+# db_use_fsync = false
# Maximum transmission backlog size - 'max_buffer' - DEFAULT: 4000000
@@ -582,8 +669,8 @@ rpcpassword = hunter1
# set this variable quite low and if clients can read data as it is generated,
# they may receive arbitrarily large histories from your server.
#
-# You may not set this number below 64000 (64 KiB) or in excess of 100000000
-# (100 MiB).
+# You may not set this number below 64000 (64 KB) or in excess of 100000000
+# (100 MB).
#
# Note that as of Fulcrum 1.0.4, you may dynamically adjust this value for all
# connected clients using the 'maxbuffer' FulcrumAdmin command, and it will be
@@ -691,6 +778,17 @@ rpcpassword = hunter1
#peering_enforce_unique_ip = true
+# Use the fast simdjson JSON parser - 'simdjson' - DEFAULT: true
+#
+# If specified, enable or disable the new simdjson backend for JSON parsing.
+# Simdjson is over 2x faster than the original parser, but since this parser was
+# recently added, some users may wish to use the old parser. You may do so by
+# spacifying `false` here. This option corresponds to the CLI argument
+# `--no-simdjson` which has the negated meaning of this option.
+#
+#simdjson = true
+
+
# Exclusion from per-IP limits - 'subnets_to_exclude_from_per_ip_limits'
# - DEFAULT: 127.0.0.1/32, ::1/128
#
@@ -706,6 +804,15 @@ rpcpassword = hunter1
#subnets_to_exclude_from_per_ip_limits = 127.0.0.1/32, ::1/128
+# Disallow deprecated TLS versions - 'tls-disallow-deprecated' - DEFAULT: false
+#
+# If true, restricts the TLS protocol used by the server to non-deprecated v1.2
+# or newer, disallowing connections from clients requesting TLS v1.1 or earlier.
+# This option applies to all SSL and WSS ports server-wide.
+#
+#tls-disallow-deprecated = false
+
+
# Log timestamp format - 'ts-format' - DEFAULT: localtime
#
# Specify the log timestamp format, one of: none, uptime, localtime, utc. If
@@ -715,6 +822,7 @@ rpcpassword = hunter1
#ts-format = localtime
#
+
# Work queue size - 'workqueue' - DEFAULT: 10000
#
# The maximum size of the work queue. Requests from clients that require further