summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPer Osbäck2019-07-14 08:35:00 +0200
committerPer Osbäck2019-07-14 08:35:00 +0200
commita9e182f7fcddb7d28b394957490c311d10936d27 (patch)
tree9214b225f77927ba0949110a3466844356f3b41c
downloadaur-fuse-nfs-git.tar.gz
add fuse-nfs
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08ae7952a87e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = fuse-nfs-git
+ pkgdesc = This is a fuse module that implements the NFS protocol.
+ pkgver = r71.91c69c5
+ pkgrel = 1
+ url = https://github.com/sahlberg/fuse-nfs
+ arch = i686
+ arch = x86_64
+ arch = armv5
+ arch = armv5h
+ arch = armv6
+ arch = armv6h
+ arch = armv7
+ arch = armv7h
+ license = GPL
+ makedepends = git
+ depends = fuse2
+ depends = libnfs
+ source = fuse-nfs-git::git+https://github.com/sahlberg/fuse-nfs.git
+ md5sums = SKIP
+
+pkgname = fuse-nfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5c4f4493eb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Per Osbeck <per@osbeck.com>
+pkgname=fuse-nfs-git
+_pkgname=fuse-nfs
+pkgver=r71.91c69c5
+pkgrel=1
+pkgdesc="This is a fuse module that implements the NFS protocol."
+arch=('i686' 'x86_64' 'armv5' 'armv5h' 'armv6' 'armv6h' 'armv7' 'armv7h')
+url="https://github.com/sahlberg/fuse-nfs"
+license=('GPL')
+makedepends=('git')
+depends=('fuse2' 'libnfs')
+source=("$pkgname::git+https://github.com/sahlberg/$_pkgname.git")
+md5sums=(SKIP)
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+prepare() {
+ cd "$srcdir/$pkgname"
+ ./setup.sh
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}