summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwaelens Jonathan2015-05-10 08:58:23 +0200
committerSwaelens Jonathan2015-05-10 08:58:23 +0200
commit67ebab4d9c095cc962e4aa268b112d198b39754f (patch)
treed7d0f445bf8460a54f86d03d1f2f2c8590356105
downloadaur-67ebab4d9c095cc962e4aa268b112d198b39754f.tar.gz
Initial import
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD101
-rw-r--r--fixes-apache-path.patch13
-rw-r--r--fixes-headers.patch23
-rw-r--r--fixes-password.patch11
-rw-r--r--fixes-path.patch17
-rw-r--r--fixes-pear-lib.patch11
-rw-r--r--fusiondirectory.install23
8 files changed, 245 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d007cf938ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = fusiondirectory
+ pkgdesc = FusionDirectory is a combination of system-administrator and end-user web interface, designed to handle LDAP based setups.
+ pkgver = 1.0.8.8
+ pkgrel = 1
+ url = http://fusiondirectory.org/
+ install = fusiondirectory.install
+ arch = any
+ license = LGPL
+ depends = apache
+ depends = smarty3
+ depends = smarty3-i18n
+ depends = prototype
+ depends = scriptaculous
+ depends = schema2ldif
+ depends = javascript-common
+ depends = perl-path-class
+ depends = perl-ldap
+ depends = perl-mime-base64
+ depends = perl-crypt-passwdmd5
+ depends = perl-term-readkey
+ depends = perl-crypt-cbc
+ depends = perl-file-copy-recursive
+ depends = perl-xml-twig
+ depends = perl-archive-extract
+ depends = perl-extutils-makemaker
+ depends = php-imagick
+ depends = php-ldap
+ depends = php-pear
+ depends = php-gd
+ depends = php-imap
+ depends = php-apache
+ source = http://repos.fusiondirectory.org/sources/1.0/fusiondirectory/fusiondirectory-1.0.8.8.tar.gz
+ source = fixes-path.patch
+ source = fixes-apache-path.patch
+ source = fixes-pear-lib.patch
+ source = fixes-headers.patch
+ source = fixes-password.patch
+ md5sums = e169b4ca7ac809a6b939ed06d81c0f2a
+ md5sums = 5f92d3e4378d0ea7fda7fa9c8b81d29e
+ md5sums = d2e3d7dedf5c436c6d7484dc049f3f7f
+ md5sums = 0a78917932d864cbaefa0139f90c6ab0
+ md5sums = 21ff95126a4e956a85219242c609bb3c
+ md5sums = 2afdfadf6e441099d7644577640c0cb5
+
+pkgname = fusiondirectory
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55fac622b15e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,101 @@
+# Maintainer: K1412 <jonathan@opensides.be>
+pkgname=fusiondirectory
+pkgver=1.0.8.8
+pkgrel=1
+pkgdesc="FusionDirectory is a combination of system-administrator and end-user web interface, designed to handle LDAP based setups."
+arch=('any')
+url="http://fusiondirectory.org/"
+license=('LGPL')
+depends=('apache' 'smarty3' 'smarty3-i18n' 'prototype' 'scriptaculous' 'schema2ldif' 'javascript-common'
+'perl-path-class' 'perl-ldap' 'perl-mime-base64' 'perl-crypt-passwdmd5' 'perl-term-readkey'
+'perl-crypt-cbc' 'perl-file-copy-recursive' 'perl-xml-twig' 'perl-archive-extract' 'perl-extutils-makemaker'
+'php-imagick' 'php-ldap' 'php-pear' 'php-gd' 'php-imap' 'php-apache')
+install=${pkgname}.install
+
+source=("http://repos.fusiondirectory.org/sources/1.0/fusiondirectory/fusiondirectory-${pkgver}.tar.gz"
+ 'fixes-path.patch'
+ 'fixes-apache-path.patch'
+ 'fixes-pear-lib.patch'
+ 'fixes-headers.patch'
+ 'fixes-password.patch')
+
+md5sums=('e169b4ca7ac809a6b939ed06d81c0f2a'
+ '5f92d3e4378d0ea7fda7fa9c8b81d29e'
+ 'd2e3d7dedf5c436c6d7484dc049f3f7f'
+ '0a78917932d864cbaefa0139f90c6ab0'
+ '21ff95126a4e956a85219242c609bb3c'
+ '2afdfadf6e441099d7644577640c0cb5')
+
+prepare() {
+ # In srcdir
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # Apply patchs
+ patch -p1 -i ../fixes-path.patch
+ patch -p1 -i ../fixes-apache-path.patch
+ patch -p1 -i ../fixes-pear-lib.patch
+ patch -p1 -i ../fixes-headers.patch
+ patch -p1 -i ../fixes-password.patch
+
+ # Right for executables
+ chmod 750 ./contrib/bin/*
+
+ # Create the man files
+ gzip ./contrib/man/fusiondirectory.conf.5
+ gzip ./contrib/man/fusiondirectory-setup.1
+ gzip ./contrib/man/fusiondirectory-insert-schema.1
+}
+
+package() {
+ # In srcdir
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # Create multiple directories
+ install -d -m 0770 $pkgdir/var/spool/$pkgname/
+ install -d -m 0770 $pkgdir/var/cache/$pkgname/tmp/
+ install -d -m 0770 $pkgdir/var/cache/$pkgname/locale/
+ install -d -m 0770 $pkgdir/var/cache/$pkgname/include/
+ install -d -m 0770 $pkgdir/var/cache/$pkgname/template/
+
+ # Copy man files
+ install -d -m 0755 $pkgdir/usr/share/man/man1/
+ install -d -m 0755 $pkgdir/usr/share/man/man5/
+
+ cp ./contrib/man/fusiondirectory.conf.5.gz $pkgdir/usr/share/man/man5/
+ cp ./contrib/man/fusiondirectory-setup.1.gz $pkgdir/usr/share/man/man1/
+ cp ./contrib/man/fusiondirectory-insert-schema.1.gz $pkgdir/usr/share/man/man1/
+
+ # Copy docs
+ install -d -m 0770 $pkgdir/usr/share/doc/$pkgname/
+ cp ./AUTHORS ./Changelog ./COPYING $pkgdir/usr/share/doc/$pkgname/
+
+ # Move fusiondirectory.conf in template
+ cp ./contrib/fusiondirectory.conf $pkgdir/var/cache/$pkgname/template/
+
+ mkdir -p $pkgdir/usr/share/doc/$pkgname/
+ cp -a contrib/openldap/slapd.conf $pkgdir/usr/share/doc/$pkgname/
+
+ # Move executables
+ mkdir -p $pkgdir/usr/bin/
+ cp ./contrib/bin/fusiondirectory-setup $pkgdir/usr/bin/
+
+ # Move smarty functions and create php lib directory if it exist
+ install -d -m 0755 $pkgdir/usr/share/php/smarty3/plugins/
+
+ cp ./contrib/smarty/plugins/function.msgPool.php $pkgdir/usr/share/php/smarty3/plugins/function.msgPool.php
+ cp ./contrib/smarty/plugins/function.filePath.php $pkgdir/usr/share/php/smarty3/plugins/function.filePath.php
+ cp ./contrib/smarty/plugins/block.render.php $pkgdir/usr/share/php/smarty3/plugins/block.render.php
+
+ # Copy apache configuration
+ install -d -m 0755 $pkgdir/etc/httpd/conf/extra/
+ cp ./contrib/apache/fusiondirectory-apache.conf $pkgdir/etc/httpd/conf/extra/httpd-${pkgname}.conf
+
+ # FusionDirectory install
+ install -d -m 0755 $pkgdir/usr/share/webapps/${pkgname}/
+ DIRS="ihtml plugins html include locale setup"
+ for i in $DIRS ; do
+ cp -ua $i $pkgdir/usr/share/webapps/${pkgname}/
+ done
+
+ rm ${pkgdir}/usr/share/webapps/fusiondirectory/include/class_databaseManagement.inc
+}
diff --git a/fixes-apache-path.patch b/fixes-apache-path.patch
new file mode 100644
index 000000000000..2ae00612a36d
--- /dev/null
+++ b/fixes-apache-path.patch
@@ -0,0 +1,13 @@
+--- a/contrib/apache/fusiondirectory-apache.conf 2015-06-04 14:47:07.837860500 +0200
++++ b/contrib/apache/fusiondirectory-apache.conf 2015-06-04 14:48:38.402860800 +0200
+@@ -1,8 +1,9 @@
+ # Include FusionDirectory to your web service
+-Alias /fusiondirectory /var/www/fusiondirectory/html
++Alias /fusiondirectory /usr/share/webapps/fusiondirectory/html
+
+ <IfModule mod_php5.c>
+ <Location /fusiondirectory>
++ Require all granted
+ php_admin_flag engine on
+ php_admin_flag register_globals off
+ php_admin_flag allow_call_time_pass_reference off
diff --git a/fixes-headers.patch b/fixes-headers.patch
new file mode 100644
index 000000000000..14598bed17d6
--- /dev/null
+++ b/fixes-headers.patch
@@ -0,0 +1,23 @@
+--- a/ihtml/themes/default/headers.tpl 2014-09-24 18:41:56.000000000 +0200
++++ b/ihtml/themes/default/headers.tpl 2014-08-25 21:40:09.109999069 +0200
+@@ -15,14 +15,14 @@
+
+ <link rel="shortcut icon" href="favicon.ico"/>
+
+- <script src="include/prototype.js" type="text/javascript"></script>
++ <script src="/javascript/prototype/prototype.js" type="text/javascript"></script>
+ <script src="include/fusiondirectory.js" type="text/javascript"></script>
+ {if $usePrototype == 'true'}
+- <script src="include/scriptaculous.js" type="text/javascript"></script>
+- <script src="include/builder.js" type="text/javascript"></script>
+- <script src="include/effects.js" type="text/javascript"></script>
+- <script src="include/dragdrop.js" type="text/javascript"></script>
+- <script src="include/controls.js" type="text/javascript"></script>
++ <script src="/javascript/scriptaculous/scriptaculous.js" type="text/javascript"></script>
++ <script src="/javascript/scriptaculous/builder.js" type="text/javascript"></script>
++ <script src="/javascript/scriptaculous/effects.js" type="text/javascript"></script>
++ <script src="/javascript/scriptaculous/dragdrop.js" type="text/javascript"></script>
++ <script src="/javascript/scriptaculous/controls.js" type="text/javascript"></script>
+ <script src="include/pulldown.js" type="text/javascript"></script>
+ <script src="include/datepicker.js" type="text/javascript"></script>
+ {/if}
diff --git a/fixes-password.patch b/fixes-password.patch
new file mode 100644
index 000000000000..85c8501dac2e
--- /dev/null
+++ b/fixes-password.patch
@@ -0,0 +1,11 @@
+--- a/ihtml/themes/default/password.tpl 2014-09-24 18:41:56.000000000 +0200
++++ b/ihtml/themes/default/password.tpl 2014-08-25 21:49:28.936671788 +0200
+@@ -12,7 +12,7 @@
+ <style type="text/css">@import url('themes/default/password-style.css');</style>
+ <link rel="shortcut icon" href="favicon.ico">
+
+- <script src="include/prototype.js" type="text/javascript"></script>
++ <script src="/javascript/prototype/prototype.js" type="text/javascript"></script>
+ <script src="include/fusiondirectory.js" type="text/javascript"></script>
+ <script src="include/pwdStrength.js" type="text/javascript"></script>
+ </head>
diff --git a/fixes-path.patch b/fixes-path.patch
new file mode 100644
index 000000000000..fa47f6f44e25
--- /dev/null
+++ b/fixes-path.patch
@@ -0,0 +1,17 @@
+--- a/contrib/bin/fusiondirectory-setup 2015-02-25 09:18:20.000000000 +0100
++++ b/contrib/bin/fusiondirectory-setup 2015-02-25 14:41:44.572099789 +0100
+@@ -34,12 +34,12 @@
+
+ # fd's directory and class.cache file's path declaration
+ my %vars = (
+- fd_home => "/var/www/fusiondirectory",
++ fd_home => "/usr/share/webapps/fusiondirectory",
+ fd_cache => "/var/cache/fusiondirectory",
+ fd_config_dir => "/etc/fusiondirectory",
+ fd_smarty_dir => "/usr/share/php/smarty3",
+ fd_spool_dir => "/var/spool/fusiondirectory",
+- ldap_conf => "/etc/ldap/ldap.conf",
++ ldap_conf => "/etc/openldap/ldap.conf",
+ config_file => "fusiondirectory.conf",
+ secrets_file => "fusiondirectory.secrets",
+ locale_dir => "locale",
diff --git a/fixes-pear-lib.patch b/fixes-pear-lib.patch
new file mode 100644
index 000000000000..1e8d88d5e9ce
--- /dev/null
+++ b/fixes-pear-lib.patch
@@ -0,0 +1,11 @@
+--- a/include/variables_common.inc 2014-09-24 18:41:56.000000000 +0200
++++ b/include/variables_common.inc 2014-08-25 22:54:44.390088656 +0200
+@@ -48,7 +48,7 @@
+ /*!
+ * \brief php pear path
+ */
+-define ("PEAR_DIR", "/usr/share/php"); /*! Define PEAR directory */
++define ("PEAR_DIR", "/usr/share/pear"); /*! Define PEAR directory */
+
+ /*!
+ * \brief fpdf library path
diff --git a/fusiondirectory.install b/fusiondirectory.install
new file mode 100644
index 000000000000..f695efe3aedd
--- /dev/null
+++ b/fusiondirectory.install
@@ -0,0 +1,23 @@
+post_install() {
+ fusiondirectory-setup --update-cache --update-locales
+
+ echo '---------------------------------------------------------------------------'
+ echo 'Add this line in your /etc/httpd/conf/httpd.conf'
+ echo 'Include conf/extra/httpd-fusiondirectory.conf'
+ echo '---------------------------------------------------------------------------'
+
+ fusiondirectory-setup --yes --check-directories
+}
+
+post_remove() {
+ echo '---------------------------------------------------------------------------'
+ echo 'Removing of /var/cache/fusiondirectory/'
+ rm -Rf /var/cache/fusiondirectory/
+ echo '---------------------------------------------------------------------------'
+ echo ''
+ echo '---------------------------------------------------------------------------'
+ echo 'Remove this line in your /etc/httpd/conf/httpd.conf'
+ echo 'Include conf/extra/httpd-fusiondirectory.conf'
+ echo '---------------------------------------------------------------------------'
+}
+