summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2021-09-18 16:50:27 +0200
committerAlphaJack2021-09-18 16:50:27 +0200
commita83bd2473200f95d19f65bda9d39643dcbef90a1 (patch)
treedc439354b1d29f0c103b27a6e0442ae9392a2c94
parent4bc62a72074986f40806f6e778f4e86d71fa78c2 (diff)
downloadaur-a83bd2473200f95d19f65bda9d39643dcbef90a1.tar.gz
Reverted to php7, checked dependencies and permission
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
-rw-r--r--fusiondirectory.install1
-rw-r--r--fusiondirectory.php.ini17
4 files changed, 18 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddcad7e1d696..e3c12d1c5d3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,17 +11,16 @@ pkgbase = fusiondirectory
depends = perl-archive-extract
depends = perl-bytes-random-secure
depends = perl-crypt-cbc
+ depends = perl-crypt-rijndael
depends = perl-digest-sha
depends = perl-file-copy-recursive
depends = perl-ldap
depends = perl-path-class
depends = perl-term-readkey
depends = perl-xml-twig
- depends = php>=7.3
- depends = php-cas
- depends = php-gd
- depends = php-imagick
- depends = php-imap
+ depends = php7>=7.3
+ depends = php7-imagick
+ depends = php7-imap
depends = php-pear
depends = schema2ldif
depends = smarty3
@@ -29,6 +28,7 @@ pkgbase = fusiondirectory
optdepends = fusiondirectory-plugins: core plugins
optdepends = apache: webserver
optdepends = nginx: webserver
+ optdepends = php-cas: cas authentication
options = !strip
source = https://github.com/fusiondirectory/fusiondirectory/archive/952afba6f3c0adf945937cb2fc21c40fa1d21d36.tar.gz
source = http://script.aculo.us/dist/scriptaculous-js-1.9.0.zip
@@ -36,7 +36,7 @@ pkgbase = fusiondirectory
source = fusiondirectory.tmpfiles
sha256sums = 4f27b6e1cbb5e78aeaacddfe27ed62155d97897e615a59cd15f08c499c706c09
sha256sums = 1fa39bd110d3326a14f920601803813f088d08ecb2cc645aa7075884d998f6f6
- sha256sums = a17aebba00b9380fdae13011f3ba0350ec861acaf94eedb6d68c0a04ddb0888c
+ sha256sums = f39473f669a0f7469004ce8eb71d637c7f2777ea9b91739c6014c1aa4a4b7c32
sha256sums = 1732399f263301f212599fd862780422eca5375be1da63acd26506587a348025
pkgname = fusiondirectory
diff --git a/PKGBUILD b/PKGBUILD
index 77a13832c02e..9acb853350a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,39 +14,24 @@ depends=("gettext"
"perl-archive-extract"
"perl-bytes-random-secure"
"perl-crypt-cbc"
- #"perl-crypt-rijndael"
+ "perl-crypt-rijndael"
"perl-digest-sha"
"perl-file-copy-recursive"
- #"perl-extutils-makemaker"
"perl-ldap"
- #"perl-mime-base64"
"perl-path-class"
"perl-term-readkey"
"perl-xml-twig"
- "php>=7.3"
- "php-cas"
- #"php-filter"
- #"php-fpdf"
- "php-gd"
- "php-imagick"
- "php-imap"
- #"php-json"
- #"php-mbstring"
- #"php-openssl"
+ "php7>=7.3"
+ "php7-imagick"
+ "php7-imap"
"php-pear"
- #"php-session"
- #"php-simplexml"
- #"php-xml"
"schema2ldif"
"smarty3"
"smarty3-gettext")
optdepends=("fusiondirectory-plugins: core plugins"
"apache: webserver"
"nginx: webserver"
- #"php-gettext: internationalized interface support"
- #"php-mhash: ssha encryption support"
- #"php-sha1: ssha encryption support"
- #"php-zlib: snapshot support"
+ "php-cas: cas authentication"
)
source=(#"https://repos.fusiondirectory.org/sources/$pkgname/$pkgname-$pkgver.tar.gz"
"https://github.com/fusiondirectory/fusiondirectory/archive/$_commit.tar.gz"
@@ -55,7 +40,7 @@ source=(#"https://repos.fusiondirectory.org/sources/$pkgname/$pkgname-$pkgver.ta
"$pkgname.tmpfiles")
sha256sums=('4f27b6e1cbb5e78aeaacddfe27ed62155d97897e615a59cd15f08c499c706c09'
'1fa39bd110d3326a14f920601803813f088d08ecb2cc645aa7075884d998f6f6'
- 'a17aebba00b9380fdae13011f3ba0350ec861acaf94eedb6d68c0a04ddb0888c'
+ 'f39473f669a0f7469004ce8eb71d637c7f2777ea9b91739c6014c1aa4a4b7c32'
'1732399f263301f212599fd862780422eca5375be1da63acd26506587a348025')
install="$pkgname.install"
options=("!strip")
@@ -90,10 +75,12 @@ package(){
# executables
find "contrib/bin/" -type f -exec chmod +x {} \;
mv "contrib/bin/" "$pkgdir/usr/"
+ # ldap schemas
+ cp "contrib/openldap/"* "$pkgdir/etc/openldap/schema/$pkgname/"
# configuration file template
install -D -m 640 "contrib/$pkgname.conf" "$pkgdir/var/cache/$pkgname/template/"
# php extensions
- install -D -m 644 "../$pkgname.php.ini" "$pkgdir/etc/php/conf.d/$pkgname.ini"
+ install -D -m 644 "../$pkgname.php.ini" "$pkgdir/etc/php7/conf.d/$pkgname.ini"
# smarty3 plugins
cp "contrib/smarty/plugins/"* "$pkgdir/usr/share/php/smarty3/plugins/"
rm -r "contrib/smarty"
diff --git a/fusiondirectory.install b/fusiondirectory.install
index 862dbd553ddc..3243e3b3dc90 100644
--- a/fusiondirectory.install
+++ b/fusiondirectory.install
@@ -2,7 +2,6 @@ post_install(){
# commands that must be run as root on the installation device
fusiondirectory-setup --update-cache --update-locales
fusiondirectory-setup --yes --check-directories
- chown -R http: /var/cache/fusiondirectory
}
post_upgrade(){
diff --git a/fusiondirectory.php.ini b/fusiondirectory.php.ini
index 298789d36230..a621f1110723 100644
--- a/fusiondirectory.php.ini
+++ b/fusiondirectory.php.ini
@@ -1,22 +1,11 @@
; mandatory
-extension = cas
extension = curl
-;extension = filter
-;extension = fpdf
-extension = gd
+extension = gettext
extension = iconv
extension = imagick
extension = imap
-;extension = json
-;extension = mbstring
extension = ldap
-;extension = openssl
-;extension = session
-;extension = simplexml
-;extension = xml
+extension = session
; optional
-;extension = gettext
-;extension = mhash
-;extension = sha1
-;extension = zlib
+extension = cas