summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Hanselman2016-05-12 22:13:05 -0400
committerKevin Hanselman2016-05-12 22:13:05 -0400
commit455c8ad47338459d57689463609bae2ab2f3a565 (patch)
tree4a4c8eeac779f4a814f6ac10e2df421221a99eff
downloadaur-455c8ad47338459d57689463609bae2ab2f3a565.tar.gz
Initial commit. Hello, AUR!
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fdcd1800779
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fwup-git
+ pkgdesc = Configurable embedded Linux firmware update creator and runner
+ pkgver = v0.6.1.r3.4da4733
+ pkgrel = 1
+ url = https://github.com/fhunleth/fwup
+ arch = any
+ license = Apache v2.0
+ makedepends = git
+ depends = libsodium
+ depends = libarchive
+ depends = confuse
+ depends = bspwm-git
+ provides = fwup
+ conflicts = fwup
+ source = git+https://github.com/fhunleth/fwup
+ md5sums = SKIP
+
+pkgname = fwup-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ddbbc5fd26c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Kevin Hanselman <kevin-hanselman@gmail.com>
+pkgname=fwup-git
+pkgver=v0.6.1.r3.4da4733
+pkgrel=1
+pkgdesc="Configurable embedded Linux firmware update creator and runner"
+arch=('any')
+url="https://github.com/fhunleth/fwup"
+license=('Apache v2.0')
+groups=()
+depends=('libsodium' 'libarchive' 'confuse' 'bspwm-git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/fhunleth/fwup')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}