summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMirco Tischler2016-10-30 19:14:02 +0100
committerMirco Tischler2016-10-30 19:14:02 +0100
commit5d7990db4f1b7b340be43b48eff37490af7f0ab5 (patch)
treee4adde11db926c1329103715de0b38499df1670d
parent920bb1d34bc07b922e2af6cfa352af0f959e2a8f (diff)
downloadaur-5d7990db4f1b7b340be43b48eff37490af7f0ab5.tar.gz
fwupdate: update to version 8
Added dependencies libsmbios and bash.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9de5771fe5a..8dc20c9f7f4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Jul 7 07:08:40 UTC 2016
+# Sun Oct 30 18:13:51 UTC 2016
pkgbase = fwupdate
pkgdesc = Tools for using the ESRT and UpdateCapsule() to apply firmware updates
- pkgver = 0.5
- pkgrel = 2
+ pkgver = 8
+ pkgrel = 1
url = https://github.com/rhinstaller/fwupdate
arch = i686
arch = x86_64
@@ -11,12 +11,10 @@ pkgbase = fwupdate
makedepends = pesign
makedepends = gnu-efi-libs
depends = efivar
- source = https://github.com/rhinstaller/fwupdate/releases/download/0.5/fwupdate-0.5.tar.bz2
- source = 0001-libfwup-better-bounds-checking-with-efivar-0.24-APIs.patch
- source = 0001-Always-set-a-mode-with-efi_set_variable.patch
- sha256sums = 633cd81e5120857ca4ab94067a59e56a031bb3764584ce1fcfe4fdb9c71031d5
- sha256sums = 76311cc35e262c8128c914d38f6fe2b3ea6083b090b13729f93033d7e3e65abd
- sha256sums = 2845e3f1fb5db180e2b602ff0f359166d2fcfe80eaba0b95c4ce67abf5527c3e
+ depends = libsmbios
+ depends = bash
+ source = https://github.com/rhinstaller/fwupdate/releases/download/8/fwupdate-8.tar.bz2
+ sha256sums = c8120f6ff0378d0f070373b6d46bfcaee18deeaf5a50c65d596c6df866980883
pkgname = fwupdate
diff --git a/PKGBUILD b/PKGBUILD
index 580fd11453a4..078ef961cbe4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,27 @@
# Maintainer: Mirco Tischler <mt-ml at gmx dot de>
pkgname=fwupdate
-pkgver=0.5
-pkgrel=2
+pkgver=8
+pkgrel=1
pkgdesc='Tools for using the ESRT and UpdateCapsule() to apply firmware updates'
arch=('i686' 'x86_64')
url='https://github.com/rhinstaller/fwupdate'
license=('GPL2')
-depends=('efivar')
+depends=('efivar' 'libsmbios' 'bash')
makedepends=('pesign' 'gnu-efi-libs')
-source=("${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
- "0001-libfwup-better-bounds-checking-with-efivar-0.24-APIs.patch"
- "0001-Always-set-a-mode-with-efi_set_variable.patch")
-sha256sums=('633cd81e5120857ca4ab94067a59e56a031bb3764584ce1fcfe4fdb9c71031d5'
- '76311cc35e262c8128c914d38f6fe2b3ea6083b090b13729f93033d7e3e65abd'
- '2845e3f1fb5db180e2b602ff0f359166d2fcfe80eaba0b95c4ce67abf5527c3e')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < "${srcdir}/${source[1]}"
- patch -p1 < "${srcdir}/${source[2]}"
-}
+source=("${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('c8120f6ff0378d0f070373b6d46bfcaee18deeaf5a50c65d596c6df866980883')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make GNUEFIDIR=/usr/lib
+ make EFIDIR=/usr/lib GNUEFIDIR=/usr/lib
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make LIBDIR=/usr/lib DESTDIR="${pkgdir}" libexecdir=/usr/lib/ install
+ make LIBDIR=/usr/lib EFIDIR=/usr/lib DESTDIR="${pkgdir}" libexecdir=/usr/lib/ install
#don't install into /boot. copy files to /usr/lib/fwupdate for manual installation
install -d ${pkgdir}/usr/lib/fwupdate