summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-19 14:40:14 +0200
committerMaxime Gauduin2017-05-19 14:40:14 +0200
commit586a9a311039d3e67586ec11128b9b485741d7ac (patch)
tree7ebc0279532151620d093f6e53bb9205319d94d7
downloadaur-586a9a311039d3e67586ec11128b9b485741d7ac.tar.gz
Add gala-git
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD44
2 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..810cecd486ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+# Generated by mksrcinfo v8
+# Fri May 19 12:40:14 UTC 2017
+pkgbase = gala-git
+ pkgdesc = The Pantheon Window Manager
+ pkgver = r1018.66b5d4a
+ pkgrel = 1
+ url = https://github.com/elementary/gala
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = git
+ makedepends = gnome-common
+ makedepends = granite-git
+ makedepends = intltool
+ makedepends = vala
+ depends = atk
+ depends = bamf
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gnome-desktop
+ depends = gtk3
+ depends = json-glib
+ depends = libdrm
+ depends = libgee
+ depends = libgl
+ depends = libx11
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxrandr
+ depends = libxtst
+ depends = mesa
+ depends = mutter
+ depends = pango
+ depends = plank
+ depends = wayland
+ depends = libgranite.so
+ provides = gala
+ provides = libgala.so
+ conflicts = gala
+ replaces = gala-bzr
+ source = git+https://github.com/elementary/gala.git
+ sha256sums = SKIP
+
+pkgname = gala-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31564b01c9b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=gala-git
+pkgver=r1018.66b5d4a
+pkgrel=1
+pkgdesc='The Pantheon Window Manager'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/gala'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('atk' 'bamf' 'cairo' 'gdk-pixbuf2' 'glib2' 'glibc' 'gnome-desktop'
+ 'gtk3' 'json-glib' 'libdrm' 'libgee' 'libgl' 'libx11' 'libxcomposite'
+ 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxrandr' 'libxtst'
+ 'mesa' 'mutter' 'pango' 'plank' 'wayland'
+ 'libgranite.so')
+makedepends=('git' 'gnome-common' 'granite-git' 'intltool' 'vala')
+provides=('gala' 'libgala.so')
+conflicts=('gala')
+replaces=('gala-bzr')
+source=('git+https://github.com/elementary/gala.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gala
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd gala
+
+ ./autogen.sh \
+ --prefix='/usr' \
+ --disable-schemas-compile
+ make
+}
+
+package() {
+ cd gala
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: