summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenom2015-06-15 22:32:24 +0200
committerXenom2015-06-15 22:32:24 +0200
commit5e5f0a29b6087d41d50450daa66083b36514d0c7 (patch)
tree4502f93c292a826ef3c5d1870a627675785d88c6
downloadaur-gambatte-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c3349d65da4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gambatte-git
+ pkgdesc = An accuracy-focused Game Boy Color emulator
+ pkgver = f3c548d
+ pkgrel = 1
+ url = https://github.com/sinamas/gambatte
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = scons
+ depends = gcc-libs
+ depends = sdl
+ depends = zlib
+ optdepends = gambatte-qt: Qt4 frontend
+ provides = gambatte
+ conflicts = gambatte
+ source = git://github.com/sinamas/gambatte.git
+ md5sums = SKIP
+
+pkgname = gambatte-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce7d1391048b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Cedric Mathieu <me.xenom[at]gmail.com>
+
+pkgname=gambatte-git
+_gitname="gambatte"
+pkgver=f3c548d
+pkgrel=1
+pkgdesc="An accuracy-focused Game Boy Color emulator"
+arch=('i686' 'x86_64')
+url="https://github.com/sinamas/gambatte"
+license=('GPL')
+depends=('gcc-libs' 'sdl' 'zlib')
+optdepends=('gambatte-qt: Qt4 frontend')
+makedepends=('git' 'scons')
+provides=('gambatte')
+conflicts=('gambatte')
+source=('git://github.com/sinamas/gambatte.git')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$_gitname"
+ git describe --always | sed 's|-|.|g'
+}
+
+
+
+build() {
+ cd "$_gitname"
+
+ for i in libgambatte gambatte_sdl; do
+ cd $i
+ scons CXXFLAGS="${CXXFLAGS}" || return 1
+ cd ..
+ done
+}
+
+package() {
+
+ cd "$_gitname"
+
+ install -Dm755 gambatte_sdl/gambatte_sdl "$pkgdir"/usr/bin/gambatte
+ install -Dm644 libgambatte/libgambatte.a "$pkgdir"/usr/lib/libgambatte.a
+}
+
+# vim:set ts=2 sw=2 et: