summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMinze Zwerver2018-04-16 15:45:11 +0200
committerMinze Zwerver2018-04-16 15:45:11 +0200
commit4a1c058a2b41ed3913d01e15224c2cef8d252cf1 (patch)
tree9d31712b96eeaeb373504cb535445ee2a64b333f
parent00ce2879a9fcafaddf8c759589ed94f148077f2b (diff)
downloadaur-4a1c058a2b41ed3913d01e15224c2cef8d252cf1.tar.gz
moved service file and renamed sourcepackage.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6582db022fcd..dbb545c819b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gamemode
pkgdesc = A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS.
pkgver = 1.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/FeralInteractive/gamemode.git
arch = x86_64
license = BSD 3-Clause License (Revised)
@@ -12,7 +12,7 @@ pkgbase = gamemode
depends = polkit
optdepends = systemd
provides = gamemode
- source = https://github.com/FeralInteractive/gamemode/archive/1.0.tar.gz
+ source = gamemode-1.0.tar.gz::https://github.com/FeralInteractive/gamemode/archive/1.0.tar.gz
sha256sums = bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d
pkgname = gamemode
diff --git a/PKGBUILD b/PKGBUILD
index 431675137585..7ac8d29ff545 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ysblokje <ysblokje at gmail dot com>
pkgname=('gamemode')
pkgver=1.0
-pkgrel=4
+pkgrel=5
pkgdesc="A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS."
arch=('x86_64')
url="https://github.com/FeralInteractive/gamemode.git"
@@ -10,7 +10,7 @@ optdepends=('systemd')
depends=('polkit')
makedepends=('meson' 'ninja' 'pkg-config' 'git')
provides=('gamemode')
-source=("https://github.com/FeralInteractive/gamemode/archive/$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/FeralInteractive/gamemode/archive/$pkgver.tar.gz")
sha256sums=('bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d')
build() {
@@ -20,6 +20,8 @@ build() {
package() {
DESTDIR=$pkgdir ninja -C build install
+ mv ${pkgdir}/etc/systemd ${pkgdir}/usr/lib/systemd
+ rm -rf ${pkgdir}/etc
install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" ${pkgname}-${pkgver}/LICENSE.txt
}