summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorysblokje2020-09-22 08:58:28 +0200
committerysblokje2020-09-22 09:03:45 +0200
commit68bdde5945e2f9c8e061b5c66f12d6bff106d9f4 (patch)
tree8c458e360b37ffb0b134892c0970005dc25d58af
parent732ea20f2df9f68ecde65977839b305f3487ccbb (diff)
parent07f88cdf6a56e0e25bde495f36f6a2f9617e093b (diff)
downloadaur-68bdde5945e2f9c8e061b5c66f12d6bff106d9f4.tar.gz
Merge branch 'master' of ssh://aur.archlinux.org/gamemode into master
Modified the dependencies after using multilib-build to check the package contents. added modeline to the end.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD78
2 files changed, 48 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe5ac4075a80..c1792bdbeab3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,26 @@
pkgbase = gamemode
pkgdesc = A daemon/lib combo that allows games to request a set of optimisations be temporarily applied to the host OS
pkgver = 1.6
- pkgrel = 4
+ pkgrel = 7
url = https://github.com/FeralInteractive/gamemode
arch = x86_64
license = BSD
checkdepends = appstream
makedepends = meson
+ makedepends = lib32-systemd
+ makedepends = lib32-dbus
+ depends = libinih
source = https://github.com/FeralInteractive/gamemode/releases/download/1.6/gamemode-1.6.tar.xz
sha256sums = ede17eb042c1c87f7b35bfe96a00560afaea086f685d25bb3964d794b0af9c80
pkgname = gamemode
install = gamemode.install
- depends = polkit
+ depends = libinih
+ depends = dbus
optdepends = systemd
+ optdepends = polkit
pkgname = lib32-gamemode
depends = gamemode
- depends = lib32-glibc
depends = lib32-dbus
diff --git a/PKGBUILD b/PKGBUILD
index f952e9c6260d..74a4c9e9c207 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,60 +3,64 @@
pkgname=('gamemode' 'lib32-gamemode')
pkgbase='gamemode'
pkgver=1.6
-pkgrel=4
+pkgrel=7
pkgdesc="A daemon/lib combo that allows games to request a set of optimisations be temporarily applied to the host OS"
arch=('x86_64')
url="https://github.com/FeralInteractive/gamemode"
license=('BSD')
-makedepends=('meson')
+makedepends=('meson' 'lib32-systemd' 'lib32-dbus')
+depends=('libinih')
checkdepends=('appstream')
-source=("$url/releases/download/$pkgver/$pkgbase-$pkgver.tar.xz")
+source=("$url/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
sha256sums=('ede17eb042c1c87f7b35bfe96a00560afaea086f685d25bb3964d794b0af9c80')
build() {
- meson "${pkgbase}-${pkgver}" build64 \
- --prefix /usr \
- --libexecdir lib/gamemode \
- -Dwith-pam-group=gamemode \
- -Dwith-systemd-user-unit-dir=/usr/lib/systemd/user
- meson compile -C build64
-
- export CFLAGS=-m32
- export CXXFLAGS=-m32
- export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
-
- meson "${pkgbase}-${pkgver}" build32 \
- --prefix /usr \
- -Dwith-sd-bus-provider=no-daemon \
- -Dwith-examples=false \
- -Dwith-util=false \
- --libdir lib32
- meson compile -C build32
+ meson "${pkgbase}-${pkgver}" build64 \
+ --prefix /usr \
+ --libexecdir lib/gamemode \
+ -Dwith-pam-group=gamemode \
+ -Dwith-systemd-user-unit-dir=/usr/lib/systemd/user
+ meson compile -C build64
+
+ export CFLAGS=-m32
+ export CXXFLAGS=-m32
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ meson "${pkgbase}-${pkgver}" build32 \
+ --prefix /usr \
+ -Dwith-sd-bus-provider=no-daemon \
+ -Dwith-examples=false \
+ -Dwith-util=false \
+ --libdir lib32
+ meson compile -C build32
}
check() {
- meson test -C build64
- meson test -C build32
+ meson test -C build64
+ meson test -C build32
}
package_gamemode() {
- depends=('polkit')
- optdepends=('systemd')
- install="${pkgname}.install"
-
- DESTDIR="${pkgdir}" meson install -C build64
- install -Dm644 "${srcdir}/${pkgbase}-${pkgver}/LICENSE.txt" -t \
- "${pkgdir}/usr/share/licenses/${pkgname}/"
- install -m644 -Dt "${pkgdir}/usr/share/doc/${pkgname}/example" \
- "${pkgname}-${pkgver}/example/gamemode.ini"
+ depends=('libinih' 'dbus')
+ optdepends=('systemd' 'polkit')
+ install="${pkgname}.install"
+
+ DESTDIR="${pkgdir}" meson install -C build64
+
+ install -Dm644 "${srcdir}/${pkgbase}-${pkgver}/LICENSE.txt" -t \
+ "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dm644 "${srcdir}/${pkgbase}-${pkgver}/example/gamemode.ini" -t \
+ "${pkgdir}/usr/share/doc/${pkgname}/example"
}
package_lib32-gamemode() {
- depends=('gamemode' 'lib32-glibc' 'lib32-dbus')
+ depends=('gamemode' 'lib32-dbus')
+
+ DESTDIR="${pkgdir}" meson install -C build32
- DESTDIR="${pkgdir}" meson install -C build32
- rm -rf "${pkgdir}/usr/include"
- install -Dm644 "${srcdir}/${pkgbase}-${pkgver}/LICENSE.txt" -t \
- "${pkgdir}/usr/share/licenses/${pkgname}/"
+ rm -rf "${pkgdir}/usr/include"
+ install -Dm644 "${srcdir}/${pkgbase}-${pkgver}/LICENSE.txt" -t \
+ "${pkgdir}/usr/share/licenses/${pkgname}/"
}
+# vim: set ts=4 sw=4 tw=0 et :