summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Price2024-02-25 18:51:55 -0800
committerChristopher Price2024-02-25 18:51:55 -0800
commit1b4a2b2d97b46cdfce6368b935942f70d60645b9 (patch)
tree95c6ccf7a82baf92fd6c7d58d46b87b79d987971
parentbce1b4aadefb86ba0ac7ea502bc5fa2c8a436050 (diff)
downloadaur-1b4a2b2d97b46cdfce6368b935942f70d60645b9.tar.gz
Updated to latest pre release v0.4.5
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 957bcd69004d..d245b3d5d946 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = gapi-ocaml
pkgdesc = A simple OCaml client for Google Services.
- pkgver = 0.4.3
- pkgrel = 2
+ pkgver = 0.4.5
+ pkgrel = 1
url = https://astrada.github.io/gapi-ocaml/
arch = x86_64
license = MIT
makedepends = dune
makedepends = ocaml-ounit
- depends = ocaml>=4.02.3
+ depends = ocaml>=4.08.0
depends = ocaml-findlib>=1.2.7
- depends = ocamlnet>=4.1.4
depends = ocaml-curl>=0.5.3
depends = ocaml-cryptokit>=1.3.14
depends = ocaml-yojson>=1.6.0
+ depends = cppo>=1.1.0
+ depends = camlp-streams
options = !strip
options = staticlibs
- source = gapi-ocaml-0.4.3.tar.gz::https://github.com/astrada/gapi-ocaml/archive/v0.4.3.tar.gz
- sha256sums = d8d551fae40494e0042bf25335e04fee57df38f490a0e4e8f6ec189fbfdada0d
+ source = gapi-ocaml-0.4.5.tar.gz::https://github.com/astrada/gapi-ocaml/archive/v0.4.5.tar.gz
+ sha256sums = 13f859ccd38be6d18d2c7e010ad67b3e5a0254ed607f6508e11f3669b5776d66
pkgname = gapi-ocaml
diff --git a/PKGBUILD b/PKGBUILD
index 1add9f22a4b5..dadbcd028b09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Christopher Price <pricechrispy at gmail dot com>
# Contributor: nerflad (nerflad@gmail.com)
pkgname=gapi-ocaml
-pkgver=0.4.3
-pkgrel=2
+pkgver=0.4.5
+pkgrel=1
pkgdesc='A simple OCaml client for Google Services.'
arch=('x86_64')
url='https://astrada.github.io/gapi-ocaml/'
license=('MIT')
depends=(
-'ocaml>=4.02.3'
+'ocaml>=4.08.0'
'ocaml-findlib>=1.2.7'
-'ocamlnet>=4.1.4'
'ocaml-curl>=0.5.3'
'ocaml-cryptokit>=1.3.14'
'ocaml-yojson>=1.6.0'
+'cppo>=1.1.0'
+'camlp-streams'
)
makedepends=(
'dune'
@@ -21,7 +22,7 @@ makedepends=(
)
options=('!strip' 'staticlibs')
source=("$pkgname-$pkgver.tar.gz::https://github.com/astrada/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('d8d551fae40494e0042bf25335e04fee57df38f490a0e4e8f6ec189fbfdada0d')
+sha256sums=('13f859ccd38be6d18d2c7e010ad67b3e5a0254ed607f6508e11f3669b5776d66')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"