summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2016-12-21 20:49:21 +0100
committerSebastian Wolf2016-12-21 20:49:21 +0100
commite09a6b16530f01c9ac7559527d4a21121badd320 (patch)
treeb8341a781e5f62ee0fa44455245cefdffe21c930
parentb9c13661a8c0d08bac30c1ff6135ce0b74c26225 (diff)
downloadaur-gc-shrink.tar.gz
Fix PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7afde61c673f..d9603838cbda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Dec 21 19:48:23 UTC 2016
pkgbase = gc-shrink
pkgdesc = Small command line program that removes garbage from gamecube images to created smaller images.
pkgver = 0.2
- pkgrel = 2
- url = http://www.gotwalls.com/
+ pkgrel = 3
+ url = http://www.gotwalls.com
arch = i686
arch = x86_64
license = unknown
source = http://www.gotwalls.com/files/gc-shrink-0.2.zip
- md5sums = fa9cfbf8a465ddd35dd1d1e09c616f24
+ sha256sums = 547e092e306f99c52685a517af992c562b8de766cd02186caecfb7f1b2620cab
pkgname = gc-shrink
diff --git a/PKGBUILD b/PKGBUILD
index a44f76ec4e31..1fd42fefee80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Contributor: Sebastian Wolf <fatmike303 at googlemail dot com>
pkgname=gc-shrink
pkgver=0.2
-pkgrel=2
-pkgdesc="Small command line program that removes garbage from gamecube images to created smaller images."
-arch=("i686" "x86_64")
-url=("http://www.gotwalls.com/")
+pkgrel=3
+pkgdesc='Small command line program that removes garbage from gamecube images to created smaller images.'
+arch=('i686' 'x86_64')
+url=http://www.gotwalls.com
license=('unknown')
depends=()
-source=("http://www.gotwalls.com/files/$pkgname-$pkgver.zip")
-md5sums=("fa9cfbf8a465ddd35dd1d1e09c616f24")
+source=(http://www.gotwalls.com/files/${pkgname}-${pkgver}.zip)
+sha256sums=(547e092e306f99c52685a517af992c562b8de766cd02186caecfb7f1b2620cab)
build() {
- cd $srcdir/$pkgname-$pkgver/src
- gcc -o ${pkgname} ${pkgname}.c -DUNIX
+ cd ${pkgname}-${pkgver}/src
+ gcc -o ${pkgname} ${pkgname}.c -DUNIX
}
package() {
- install -Dm755 $srcdir/$pkgname-$pkgver/src/${pkgname} $pkgdir/usr/bin/${pkgname}
+ install -Dm755 ${pkgname}-${pkgver}/src/${pkgname} ${pkgdir}/usr/bin/${pkgname}
}