summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuan Guo2018-08-11 15:25:07 +0800
committerQuan Guo2018-08-11 15:25:07 +0800
commitae7c4d6d3f17b1620834240a798c2c10c6129780 (patch)
treea215f83e54a062cd243ac0b4228c261ac464c1db
parent7d1a2c6f64a11118f847b364b4063d53dfc1bb81 (diff)
downloadaur-gcalcli-git.tar.gz
Move to python3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3631ea9e2a8c..c4ec49c14325 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Tue Jun 28 19:05:03 UTC 2016
+# Sat Aug 11 07:24:52 UTC 2018
pkgbase = gcalcli-git
- pkgdesc = Google Calendar Command Line Interface, modfied to work with the package: python2-oauth2client from [community] repository.
- pkgver = 3.3.2.r261.g4a55b6f
+ pkgdesc = Google Calendar Command Line Interface, modfied to work with the package: python-oauth2client from [community] repository.
+ pkgver = 3.4.0.r311.g27aa937
pkgrel = 1
url = https://github.com/insanum/gcalcli
arch = any
license = MIT
- depends = python2-google-api-python-client
- depends = python2-dateutil
- depends = python2-gflags
- depends = python2-oauth2client
- optdepends = python2-vobject: for ics/vcal importing
- optdepends = python2-parsedatetime: for fuzzy dates/times like "now", "today", "eod tomorrow", etc.
+ depends = python-google-api-python-client
+ depends = python-dateutil
+ depends = python-gflags
+ depends = python-oauth2client
+ optdepends = python-vobject: for ics/vcal importing
+ optdepends = python-parsedatetime: for fuzzy dates/times like "now", "today", "eod tomorrow", etc.
conflicts = gcalcli
source = git+https://github.com/insanum/gcalcli
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 77090b6ed7e5..7657402ee59f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,20 @@
# Contributor: insanum
# Contributor: Thomas Zervogiannis
-#modified to work with python2-oauth2client from [community] repository
+#modified to work with python-oauth2client from [community] repository
pkgname=gcalcli-git
-pkgver=3.3.2.r261.g4a55b6f
+pkgver=3.4.0.r311.g27aa937
pkgrel=1
pkgdesc='Google Calendar Command Line Interface, modfied to work with
-the package: python2-oauth2client from [community] repository.'
+the package: python-oauth2client from [community] repository.'
arch=('any')
url=https://github.com/insanum/gcalcli
license=('MIT')
-depends=('python2-google-api-python-client' 'python2-dateutil' 'python2-gflags'
-'python2-oauth2client')
-optdepends=('python2-vobject: for ics/vcal importing'
- 'python2-parsedatetime: for fuzzy dates/times like "now", "today",
+depends=('python-google-api-python-client' 'python-dateutil' 'python-gflags'
+'python-oauth2client')
+optdepends=('python-vobject: for ics/vcal importing'
+ 'python-parsedatetime: for fuzzy dates/times like "now", "today",
"eod tomorrow", etc.')
source=('git+https://github.com/insanum/gcalcli')
md5sums=('SKIP')
@@ -30,14 +30,10 @@ pkgver() {
echo "$(git describe --abbrev=0 --tags | cut -f 2 -d '-' | sed 's/v//').r$(git rev-list --count HEAD).$(git log -1 --format='g%h')"
}
-prepare() {
- cd $_gitname
- sed -i -e 's/import\ run/import\ run_flow/' gcalcli
-}
-
package() {
cd $_gitname
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
# vim:set ts=2 sw=2 et:
+