summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2016-02-26 14:54:09 +0800
committerFantix King2016-02-26 14:57:55 +0800
commit2a3103929e0c84112c886ce7df6ed28efd74576f (patch)
tree13fcda34dc01bc27698f246eb2a90abde32fc97d
parenta3dfaa78616dd98a4df6acb46d25c0467af3152f (diff)
downloadaur-gcc-multilib-x32.tar.gz
5.3.0-5.1
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD14
2 files changed, 34 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53e81c145b7..dfe5c3f554d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Feb 15 10:54:34 UTC 2016
+# Fri Feb 26 06:57:47 UTC 2016
pkgbase = gcc-multilib-x32
pkgdesc = The GNU Compiler Collection for multilib with x32 ABI support
pkgver = 5.3.0
- pkgrel = 4.1
+ pkgrel = 5.1
url = http://gcc.gnu.org
arch = x86_64
license = GPL
@@ -12,12 +12,12 @@ pkgbase = gcc-multilib-x32
license = custom
checkdepends = dejagnu
checkdepends = inetutils
- makedepends = binutils>=2.25
+ makedepends = binutils>=2.26
makedepends = libmpc
makedepends = gcc-ada-multilib
makedepends = doxygen
- makedepends = lib32-glibc>=2.22
- makedepends = libx32-glibc>=2.22
+ makedepends = lib32-glibc>=2.23
+ makedepends = libx32-glibc>=2.23
options = !emptydirs
source = ftp://gcc.gnu.org/pub/gcc/snapshots/5-20160209/gcc-5-20160209.tar.bz2
source = http://isl.gforge.inria.fr/isl-0.15.tar.bz2
@@ -30,11 +30,11 @@ pkgname = gcc-multilib-x32
pkgdesc = The GNU Compiler Collection - C and C++ frontends for multilib with x32 ABI support
install = gcc.install
groups = x32-devel
- depends = gcc-libs-multilib-x32=5.3.0-4.1
- depends = binutils>=2.25
+ depends = gcc-libs-multilib-x32=5.3.0-5.1
+ depends = binutils>=2.26
depends = libmpc
- provides = gcc=5.3.0-4
- provides = gcc-multilib=5.3.0-4
+ provides = gcc=5.3.0-5
+ provides = gcc-multilib=5.3.0-5
conflicts = gcc
conflicts = gcc-x32-seed
conflicts = gcc-multilib
@@ -43,43 +43,43 @@ pkgname = gcc-multilib-x32
pkgname = gcc-libs-multilib-x32
pkgdesc = Runtime libraries shipped by GCC for multilib with x32 ABI support
install = gcc-libs.install
- depends = glibc>=2.22
- depends = lib32-gcc-libs=5.3.0-4
- depends = libx32-gcc-libs=5.3.0-4.1
- provides = gcc-libs=5.3.0-4
- provides = gcc-libs-multilib=5.3.0-4
+ depends = glibc>=2.23
+ depends = lib32-gcc-libs=5.3.0-5
+ depends = libx32-gcc-libs=5.3.0-5.1
+ provides = gcc-libs=5.3.0-5
+ provides = gcc-libs-multilib=5.3.0-5
conflicts = gcc-libs
options = !emptydirs
options = !strip
pkgname = libx32-gcc-libs
pkgdesc = Runtime libraries shipped by GCC (x32 ABI)
- depends = libx32-glibc>=2.22
+ depends = libx32-glibc>=2.23
options = !emptydirs
options = !strip
pkgname = gcc-fortran-multilib-x32
pkgdesc = Fortran front-end for GCC for multilib with x32 ABI support
install = gcc-fortran.install
- depends = gcc-multilib-x32=5.3.0-4.1
- provides = gcc-fortran=5.3.0-4
- provides = gcc-fortran-multilib=5.3.0-4
+ depends = gcc-multilib-x32=5.3.0-5.1
+ provides = gcc-fortran=5.3.0-5
+ provides = gcc-fortran-multilib=5.3.0-5
conflicts = gcc-fortran
options = !emptydirs
pkgname = gcc-objc-multilib-x32
pkgdesc = Objective-C front-end for GCC for multilib with x32 ABI support
- depends = gcc-multilib-x32=5.3.0-4.1
- provides = gcc-objc=5.3.0-4
- provides = gcc-objc-multilib=5.3.0-4
+ depends = gcc-multilib-x32=5.3.0-5.1
+ provides = gcc-objc=5.3.0-5
+ provides = gcc-objc-multilib=5.3.0-5
conflicts = gcc-objc
pkgname = gcc-ada-multilib-x32
pkgdesc = Ada front-end for GCC (GNAT) for multilib with x32 ABI support
install = gcc-ada.install
- depends = gcc-multilib-x32=5.3.0-4.1
- provides = gcc-ada=5.3.0-4
- provides = gcc-ada-multilib=5.3.0-4
+ depends = gcc-multilib-x32=5.3.0-5.1
+ provides = gcc-ada=5.3.0-5
+ provides = gcc-ada-multilib=5.3.0-5
conflicts = gcc-ada
options = staticlibs
options = !emptydirs
@@ -87,9 +87,9 @@ pkgname = gcc-ada-multilib-x32
pkgname = gcc-go-multilib-x32
pkgdesc = Go front-end for GCC for multilib with x32 ABI support
install = gcc-go.install
- depends = gcc-multilib-x32=5.3.0-4.1
- provides = gcc-go=5.3.0-4
- provides = gcc-go-multilib=5.3.0-4
+ depends = gcc-multilib-x32=5.3.0-5.1
+ provides = gcc-go=5.3.0-5
+ provides = gcc-go-multilib=5.3.0-5
conflicts = go
conflicts = gcc-go
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index 8482f787423..1fb23dd0d7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 161514 2016-02-14 03:40:35Z allan $
+# $Id: PKGBUILD 163137 2016-02-22 12:25:27Z allan $
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
# x32 Maintainer: Fantix King <fantix.king@gmail.com>
@@ -10,14 +10,14 @@ pkgname=('gcc-multilib-x32' 'gcc-libs-multilib-x32' 'libx32-gcc-libs' 'gcc-fortr
pkgver=5.3.0
_pkgver=5
_islver=0.15
-pkgrel=4.1
+pkgrel=5.1
_snapshot=5-20160209
pkgdesc="The GNU Compiler Collection for multilib with x32 ABI support"
arch=('x86_64')
license=('GPL' 'LGPL' 'FDL' 'custom')
url="http://gcc.gnu.org"
-makedepends=('binutils>=2.25' 'libmpc' 'gcc-ada-multilib' 'doxygen'
- 'lib32-glibc>=2.22' 'libx32-glibc>=2.22')
+makedepends=('binutils>=2.26' 'libmpc' 'gcc-ada-multilib' 'doxygen'
+ 'lib32-glibc>=2.23' 'libx32-glibc>=2.23')
checkdepends=('dejagnu' 'inetutils')
options=('!emptydirs')
source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
@@ -111,7 +111,7 @@ check() {
package_libx32-gcc-libs()
{
pkgdesc="Runtime libraries shipped by GCC (x32 ABI)"
- depends=('libx32-glibc>=2.22')
+ depends=('libx32-glibc>=2.23')
options=('!emptydirs' '!strip')
cd ${srcdir}/gcc-build
@@ -148,7 +148,7 @@ package_libx32-gcc-libs()
package_gcc-libs-multilib-x32()
{
pkgdesc="Runtime libraries shipped by GCC for multilib with x32 ABI support"
- depends=('glibc>=2.22' "lib32-gcc-libs=$pkgver-${pkgrel%.*}" "libx32-gcc-libs=$pkgver-$pkgrel")
+ depends=('glibc>=2.23' "lib32-gcc-libs=$pkgver-${pkgrel%.*}" "libx32-gcc-libs=$pkgver-$pkgrel")
provides=("gcc-libs=$pkgver-${pkgrel%.*}" "gcc-libs-multilib=$pkgver-${pkgrel%.*}")
conflicts=('gcc-libs')
options=('!emptydirs' '!strip')
@@ -199,7 +199,7 @@ package_gcc-libs-multilib-x32()
package_gcc-multilib-x32()
{
pkgdesc="The GNU Compiler Collection - C and C++ frontends for multilib with x32 ABI support"
- depends=("gcc-libs-multilib-x32=$pkgver-$pkgrel" 'binutils>=2.25' 'libmpc')
+ depends=("gcc-libs-multilib-x32=$pkgver-$pkgrel" 'binutils>=2.26' 'libmpc')
groups=('x32-devel')
options=('staticlibs')
provides=("gcc=$pkgver-${pkgrel%.*}" "gcc-multilib=$pkgver-${pkgrel%.*}")