summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralrii2018-03-30 00:45:11 -0400
committeralrii2018-03-30 00:45:11 -0400
commit23252d032acb16ebc73d890ebb801c7cef4f2949 (patch)
tree1754093e38df3ab8b0c92c4d9d10c8e1379d4e01
parent954645aaceea4412bc4545ceff48da39838250d4 (diff)
downloadaur-gce-compute-image-packages.tar.gz
Add dependency [python-distro]
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bc7f244f469..9c2041b9d7d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = gce-compute-image-packages
pkgdesc = Linux Guest Environment for Google Compute Engine
- pkgver = 0.0.0
+ pkgver = 20180227
pkgrel = 1
url = https://github.com/GoogleCloudPlatform/compute-image-packages
arch = x86_64
license = Apache
+ makedepends = git
depends = python-boto
depends = python-setuptools
- depends = git
- source = gce-compute-image-packages::git://github.com/GoogleCloudPlatform/compute-image-packages.git
+ depends = python-distro
+ source = gce-compute-image-packages-20180227::git://github.com/GoogleCloudPlatform/compute-image-packages.git
sha512sums = SKIP
pkgname = gce-compute-image-packages
diff --git a/PKGBUILD b/PKGBUILD
index 1c085267f1f7..936ef01a2539 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
# Maintainer: Kohei Suzuki <eagletmt@gmail.com>
pkgname=gce-compute-image-packages
-pkgver=0.0.0
+pkgver=20180227
pkgrel=1
pkgdesc='Linux Guest Environment for Google Compute Engine'
arch=('x86_64')
url='https://github.com/GoogleCloudPlatform/compute-image-packages'
license=('Apache')
-depends=('python-boto' 'python-setuptools' 'git')
-source=("$pkgname"::'git://github.com/GoogleCloudPlatform/compute-image-packages.git')
+depends=('python-boto' 'python-setuptools' 'python-distro')
+makedepends=('git')
+source=("$pkgname-$pkgver"::'git://github.com/GoogleCloudPlatform/compute-image-packages.git')
# Because the sources are not static, skip Git checksum:
sha512sums=('SKIP')
package() {
- cd "gce-compute-image-packages"
+ cd "$pkgname-$pkgver"
python setup.py install --root="$pkgdir"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"