summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Snowhill2024-02-06 12:52:59 -0800
committerChristopher Snowhill2024-02-06 12:52:59 -0800
commit3ea93d3e820bad80397981b90822a407703b566c (patch)
treed15961006149e88999720bebbb71f3955452135e
parentbc290a393a7e50ec6de71bb0910afc81c8c58625 (diff)
downloadaur-gdown.tar.gz
v5.1.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6afd41dceb5..f8005f0be933 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = gdown
pkgdesc = Download a large file from Google Drive
- pkgver = 4.7.1
- pkgrel = 2
+ pkgver = 5.1.0
+ pkgrel = 1
url = https://github.com/wkentaro/gdown
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = git
+ makedepends = python-hatch-vcs
+ makedepends = python-hatch-fancy-pypi-readme
depends = python
depends = python-tqdm
depends = python-filelock
@@ -14,7 +18,7 @@ pkgbase = gdown
depends = python-six
depends = python-beautifulsoup4
depends = python-requests
- source = git+https://github.com/wkentaro/gdown.git#tag=v4.7.1
+ source = git+https://github.com/wkentaro/gdown.git#tag=v5.1.0
sha512sums = SKIP
pkgname = gdown
diff --git a/PKGBUILD b/PKGBUILD
index 9e6436c7de3e..3ea37998094a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Sven-Hendrik Haase <svenstaro@gmail.com>
pkgname=gdown
-pkgver=4.7.1
-pkgrel=2
+pkgver=5.1.0
+pkgrel=1
pkgdesc="Download a large file from Google Drive"
arch=('any')
url="https://github.com/wkentaro/gdown"
license=('MIT')
depends=('python' 'python-tqdm' 'python-filelock' 'python-pysocks' 'python-six' 'python-beautifulsoup4' 'python-requests')
-makedepends=('python-setuptools' 'git')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'git' 'python-hatch-vcs' 'python-hatch-fancy-pypi-readme')
source=(git+https://github.com/wkentaro/gdown.git#tag=v${pkgver})
sha512sums=('SKIP')
@@ -22,13 +22,14 @@ prepare() {
build() {
cd "${pkgname}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${pkgname}"
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
install -Dm755 README.md "${pkgdir}/usr/share/doc/${pkgname}"/README.md
}