summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastian Löher2017-05-09 13:37:42 +0200
committerBastian Löher2017-05-09 15:21:06 +0200
commit9164a817a6cfa14a1ac399c6813d724f8ecc47c8 (patch)
tree860577192592aa0b69ac93cf27e78c6503033368
downloadaur-geant3.tar.gz
Commit for AUR
-rw-r--r--.SRCINFO34
-rw-r--r--Geant3_CMake.patch26
-rw-r--r--PKGBUILD81
-rw-r--r--gcalor.F.gzbin0 -> 127515 bytes
-rw-r--r--gdalet.F.gzbin0 -> 1354 bytes
-rw-r--r--gdalitzcbm.F.gzbin0 -> 492 bytes
-rw-r--r--gdecay.F.gzbin0 -> 2157 bytes
-rw-r--r--geant3_geane.patch42
-rw-r--r--geant3_root6.patch10
-rw-r--r--geant3_structs.patch20
10 files changed, 213 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1571a7dd2a78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = geant3
+ pkgdesc = Monte Carlo GEometry ANd Tracking Version 3
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://root.cern.ch/download-vmc
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ depends = root
+ options = emptydirs
+ options = strip
+ options = staticlibs
+ options = libtool
+ source = geant3::git+http://root.cern.ch/git/geant3.git#tag=v2-1
+ source = gcalor.F.gz
+ source = gdalet.F.gz
+ source = gdalitzcbm.F.gz
+ source = gdecay.F.gz
+ source = geant3_geane.patch
+ source = geant3_root6.patch
+ source = geant3_structs.patch
+ source = Geant3_CMake.patch
+ md5sums = SKIP
+ md5sums = 1d424f336f14f7b956b4ff88b6609ad6
+ md5sums = 780850d26765e43733e1f1451bd24d16
+ md5sums = 79441f41a967cb484e1470777067caa7
+ md5sums = d22549981df7d18a015f9913602eeb72
+ md5sums = f0df4447afd26fba12213732f1a3784f
+ md5sums = 856d3a197ddf34d1d9e1a3b64fdb3bf1
+ md5sums = a88e74f73ebc85c51256fba99d7551cd
+ md5sums = c7dec3af4c0b3cd1d1522f99be432525
+
+pkgname = geant3
+
diff --git a/Geant3_CMake.patch b/Geant3_CMake.patch
new file mode 100644
index 000000000000..04a42ef7d20e
--- /dev/null
+++ b/Geant3_CMake.patch
@@ -0,0 +1,26 @@
+--- cmake/Geant3BuildLibrary.cmake 2015-01-21 09:02:50.000000000 +0100
++++ cmake/Geant3BuildLibrary.cmake 2015-01-21 09:10:08.000000000 +0100
+@@ -52,7 +52,7 @@
+ set(directories
+ added gbase gcons geocad ggeom gheisha ghits ghrout ghutils giface giopa
+ gkine gparal gphys gscan gstrag gtrak matx55 miface miguti neutron peanut
+- fiface cgpack fluka block comad erdecks erpremc minicern gdraw)
++ fiface cgpack fluka block comad erdecks erpremc minicern gdraw gcalor)
+
+ # Fortran sources
+ set(fortran_sources gcinit.F)
+--- cmake/Geant3BuildProject.cmake
++++ cmake/Geant3BuildProject.cmake
+@@ -40,6 +40,12 @@ install(DIRECTORY
+ COMPONENT Development
+ )
+
++# Install the data directory which is needed at runtime
++install(DIRECTORY
++ ${PROJECT_SOURCE_DIR}/data
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/geant3
++)
++
+ #
+ # Install the Geant3Config, Geant3ConfigVersion
+ #
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8eb5092e2f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: Bastian Löher <b.loeher@gsi.de>
+# Note: This repository contains code fragments and patches from the fairroot
+# fairsoft group (https://github.com/FairRootGroup/FairSoft)
+pkgname=geant3
+pkgver_mid=2
+pkgver_low=1
+pkgver=${pkgver_mid}.${pkgver_low}
+gittag=v${pkgver_mid}-${pkgver_low}
+pkgrel=1
+pkgdesc="Monte Carlo GEometry ANd Tracking Version 3"
+arch=('x86_64')
+url="https://root.cern.ch/download-vmc"
+license=('GPL')
+groups=()
+makedepends=('gcc-fortran')
+depends=('root')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=('emptydirs' 'strip' 'staticlibs' 'libtool')
+install=
+changelog=
+source=("${pkgname}::git+http://root.cern.ch/git/${pkgname}.git#tag=${gittag}"
+ 'gcalor.F.gz'
+ 'gdalet.F.gz'
+ 'gdalitzcbm.F.gz'
+ 'gdecay.F.gz'
+ 'geant3_geane.patch'
+ 'geant3_root6.patch'
+ 'geant3_structs.patch'
+ 'Geant3_CMake.patch'
+)
+noextract=()
+md5sums=('SKIP'
+ '1d424f336f14f7b956b4ff88b6609ad6'
+ '780850d26765e43733e1f1451bd24d16'
+ '79441f41a967cb484e1470777067caa7'
+ 'd22549981df7d18a015f9913602eeb72'
+ 'f0df4447afd26fba12213732f1a3784f'
+ '856d3a197ddf34d1d9e1a3b64fdb3bf1'
+ 'a88e74f73ebc85c51256fba99d7551cd'
+ 'c7dec3af4c0b3cd1d1522f99be432525')
+
+# Do not compress the package for installation
+# PKGEXT='.pkg.tar'
+# Compress using lightweight gzip
+PKGEXT='.pkg.tar.gz'
+
+prepare() {
+ cd "${pkgname}"
+ cp ../gdecay.F gphys
+ cp ../gdalet.F gphys
+ cp ../gdalitzcbm.F gphys
+ mkdir -p gcalor
+ cp ../gcalor.F gcalor
+ rm added/dummies_gcalor.c
+ patch -p0 -i ../geant3_geane.patch
+ patch -p0 -i ../Geant3_CMake.patch
+ patch -p0 -i ../geant3_structs.patch
+ patch -p0 -i ../geant3_root6.patch
+}
+
+build() {
+ cd "${pkgname}"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
+ -DCMAKE_CXX_FLAGS_RELWITHDEBINFO="--std=c++14 -O2 -g -DNDEBUG" \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DROOT_DIR=/usr \
+ ..
+
+ make
+}
+
+package() {
+ cd "${pkgname}/build"
+ mkdir -p /usr/include/
+ make install
+}
diff --git a/gcalor.F.gz b/gcalor.F.gz
new file mode 100644
index 000000000000..40579b03f83f
--- /dev/null
+++ b/gcalor.F.gz
Binary files differ
diff --git a/gdalet.F.gz b/gdalet.F.gz
new file mode 100644
index 000000000000..7a9732822b72
--- /dev/null
+++ b/gdalet.F.gz
Binary files differ
diff --git a/gdalitzcbm.F.gz b/gdalitzcbm.F.gz
new file mode 100644
index 000000000000..b0603aa32119
--- /dev/null
+++ b/gdalitzcbm.F.gz
Binary files differ
diff --git a/gdecay.F.gz b/gdecay.F.gz
new file mode 100644
index 000000000000..9b1aaa60a319
--- /dev/null
+++ b/gdecay.F.gz
Binary files differ
diff --git a/geant3_geane.patch b/geant3_geane.patch
new file mode 100644
index 000000000000..fa6934ddb594
--- /dev/null
+++ b/geant3_geane.patch
@@ -0,0 +1,42 @@
+--- erdecks/eustep.F_old 2012-05-29 14:55:38.490000649 +0200
++++ erdecks/eustep.F 2012-05-29 15:02:38.744000650 +0200
+@@ -167,6 +167,8 @@
+ CALL UCOPY(P3,P2,3)
+ CALL UCOPY(VECT,P3,3)
+ ICONT = 0
++ ISTOP = 1
++ ICLOSE = 0
+ ENDIF
+ ENDIF
+
+@@ -204,6 +206,8 @@
+ CALL UCOPY(P3,P2,3)
+ CALL UCOPY(VECT,P3,3)
+ ICONT = 0
++ ISTOP = 1
++ ICLOSE = 0
+ ENDIF
+ ENDIF
+ ENDIF
+--- TGeant3/TGeant3gu.cxx_old 2012-05-29 14:55:39.038000648 +0200
++++ TGeant3/TGeant3gu.cxx 2012-05-29 14:59:00.198000645 +0200
+@@ -696,7 +696,9 @@
+ for(Int_t i=0; i<3; i++)geant3->Gcmore()->p2[i] = geant3->Gcmore()->p3[i]; //call ucopy(p3,p2,3)
+ for(Int_t i=0; i<3; i++)geant3->Gcmore()->p3[i] = geant3->Gctrak()->vect[i]; //call ucopy(vect,p3,3)
+ icont = 0;
+- }
++ geant3->StopTrack();
++ geant3->Gcmore()->iclose = 0;
++ }
+ }
+ }else if(cflag==2) {
+ // printf("geant3->Gconst()->big = %F" ,geant3->Gconst());
+@@ -745,6 +747,8 @@
+ for(Int_t i=0; i<3; i++)geant3->Gcmore()->p2[i] = geant3->Gcmore()->p3[i]; //call ucopy(p3,p2,3)
+ for(Int_t i=0; i<3; i++)geant3->Gcmore()->p3[i] = geant3->Gctrak()->vect[i]; //call ucopy(vect,p3,3)
+ icont = 0;
++ geant3->StopTrack();
++ geant3->Gcmore()->iclose = 0;
+ }
+ }
+ }
diff --git a/geant3_root6.patch b/geant3_root6.patch
new file mode 100644
index 000000000000..dc559a26040f
--- /dev/null
+++ b/geant3_root6.patch
@@ -0,0 +1,10 @@
+--- cmake/Geant3BuildLibrary.cmake
++++ cmake/Geant3BuildLibrary.cmake
+@@ -26,6 +26,7 @@ include_directories(
+ ${PROJECT_SOURCE_DIR}
+ ${PROJECT_SOURCE_DIR}/minicern
+ ${PROJECT_SOURCE_DIR}/TGeant3
++ ${CMAKE_INSTALL_PREFIX}/include/TGeant3
+ ${CMAKE_CURRENT_BINARY_DIR})
+
+ #-------------------------------------------------------------------------------
diff --git a/geant3_structs.patch b/geant3_structs.patch
new file mode 100644
index 000000000000..f58206463b78
--- /dev/null
+++ b/geant3_structs.patch
@@ -0,0 +1,20 @@
+--- TGeant3/geant3LinkDef.h
++++ TGeant3/geant3LinkDef.h
+@@ -13,9 +13,6 @@
+ #pragma link C++ class TGeant3f77+;
+ #pragma link C++ class TG3Application+;
+
+-/*
+-// Unused class rule
+-// (generate warning with Root6 cling)
+ #pragma link C++ class Quest_t+;
+ #pragma link C++ class Gconst_t+;
+ #pragma link C++ class Gconsx_t+;
+@@ -48,7 +45,6 @@
+ #pragma link C++ class Eropts_t+;
+ #pragma link C++ class Eroptc_t+;
+ #pragma link C++ class Erwork_t+;
+-*/
+
+ #pragma link C++ class G3Material+;
+ #pragma link C++ class G3Medium-;