summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2022-01-30 16:03:57 -0500
committerTed Alff2022-01-30 16:03:57 -0500
commitdb5319b94e7ac7750c8cd6cc910246458f02f5d3 (patch)
tree2b0da79a40bff7bb16babf0a4d92a6600dab61a9
downloadaur-geany-nord-theme.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b959dac1f8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = geany-nord-theme
+ pkgdesc = Nord color theme for Geany.
+ pkgver = r15+96f85bd
+ pkgrel = 1
+ url = https://github.com/Betelgeuse1/NordThemeGeany
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = geany
+ source = geany-nord-theme::git+https://github.com/Betelgeuse1/NordThemeGeany#commit=96f85bd25ce3be58df186bb44f27ddc9d4387e8c
+ sha1sums = SKIP
+
+pkgname = geany-nord-theme
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..685211446733
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+pkgname=geany-nord-theme
+pkgver=r15+96f85bd
+pkgrel=1
+pkgdesc='Nord color theme for Geany.'
+arch=('any')
+url='https://github.com/Betelgeuse1/NordThemeGeany'
+license=('GPL')
+depends=('geany')
+makedepends=('git')
+_commit='96f85bd25ce3be58df186bb44f27ddc9d4387e8c'
+source=("${pkgname}::git+https://github.com/Betelgeuse1/NordThemeGeany#commit=${_commit}")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/${pkgname}
+ printf "r%s+%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm644 ${pkgname}/styling/nord.conf "${pkgdir}"/usr/share/geany/colorschemes/nord.conf
+}