summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-05-01 11:47:53 +0000
committerAntonio Rojas2019-05-01 11:47:53 +0000
commit00cd4ba226b8cd2d2eb8537d618c090b8433ca2b (patch)
tree66a9396328945048adf6c3fe5d797092fb732f37
downloadaur-gebabbel.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
-rw-r--r--gebabbel-0.4.patch7
-rw-r--r--gebabbel.changelog3
-rw-r--r--gebabbel.desktop7
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36de25640f8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gebabbel
+ pkgdesc = GUI for gpsbabel
+ pkgver = 0.4
+ pkgrel = 9
+ url = http://gebabbel.sourceforge.net/
+ changelog = gebabbel.changelog
+ arch = x86_64
+ license = GPL2
+ depends = qt4
+ depends = gpsbabel
+ source = https://sources.archlinux.org/other/gebabbel/Gebabbel-0.4-Src.tar.gz
+ source = http://gebabbel.sourceforge.net/GebabbelLogo.png
+ source = gebabbel.desktop
+ source = gebabbel-0.4.patch
+ sha512sums = 96750cf1d3e627b8071d1693c7b31a2fb056f533c6e9de09e4de3550d7a923388c6b8f9634695d19708fd509ec9da537a0b1d477554d7249204754b55dd684f2
+ sha512sums = e26cb843f7c92eb603ff950803fb99f93b1ca297af55d14ef7b3ec699f0ae44c85738126d00abb3bcfbf5f6e4d5dcf2c3e4f54a1821efbe7e6ff42b88c1c2e71
+ sha512sums = 425aa6c586968f4b20f528e623686e87ea76b6d81324277a1e964138d7327de75a2e2fa237168bd5c8fa082443decf4e50a241df264ccd9eeb78ed5831f6615a
+ sha512sums = 71da26a82ea8f94b1e274ffb57b8629956c1fae19d9d6056d22060aa64e3249530c4f8c132ad5a00f595ac3598ce360557059fcfa1fe4bcb4af68c07fce6e170
+
+pkgname = gebabbel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20901d5eacbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: pfm <nl081130@yahoo.de>
+
+pkgname=gebabbel
+pkgver=0.4
+pkgrel=9
+pkgdesc="GUI for gpsbabel"
+arch=('x86_64')
+url="http://gebabbel.sourceforge.net/"
+license=('GPL2')
+depends=('qt4' 'gpsbabel')
+changelog=$pkgname.changelog
+source=(https://sources.archlinux.org/other/$pkgname/Gebabbel-$pkgver-Src.tar.gz
+ http://$pkgname.sourceforge.net/GebabbelLogo.png
+ $pkgname.desktop
+ $pkgname-$pkgver.patch)
+sha512sums=('96750cf1d3e627b8071d1693c7b31a2fb056f533c6e9de09e4de3550d7a923388c6b8f9634695d19708fd509ec9da537a0b1d477554d7249204754b55dd684f2'
+ 'e26cb843f7c92eb603ff950803fb99f93b1ca297af55d14ef7b3ec699f0ae44c85738126d00abb3bcfbf5f6e4d5dcf2c3e4f54a1821efbe7e6ff42b88c1c2e71'
+ '425aa6c586968f4b20f528e623686e87ea76b6d81324277a1e964138d7327de75a2e2fa237168bd5c8fa082443decf4e50a241df264ccd9eeb78ed5831f6615a'
+ '71da26a82ea8f94b1e274ffb57b8629956c1fae19d9d6056d22060aa64e3249530c4f8c132ad5a00f595ac3598ce360557059fcfa1fe4bcb4af68c07fce6e170')
+
+build() {
+ cd ${srcdir}/Gebabbel-$pkgver
+
+ patch -Np0 -i ${srcdir}/$pkgname-$pkgver.patch
+
+ qmake-qt4
+ make
+}
+
+package() {
+ cd ${srcdir}/Gebabbel-$pkgver
+
+ install -D -m755 ${srcdir}/Gebabbel-$pkgver/bin/$pkgname \
+ ${pkgdir}/usr/bin/$pkgname
+ install -D -m644 ${srcdir}/GebabbelLogo.png \
+ ${pkgdir}/usr/share/pixmaps/$pkgname.png
+ install -D -m644 ${srcdir}/$pkgname.desktop \
+ ${pkgdir}/usr/share/applications/$pkgname.desktop
+
+ #localization
+ install -d ${pkgdir}/usr/share/$pkgname/locale
+ install -t ${pkgdir}/usr/share/$pkgname/locale/ \
+ ${srcdir}/Gebabbel-$pkgver/binincludes/translations/*.qm
+}
diff --git a/gebabbel-0.4.patch b/gebabbel-0.4.patch
new file mode 100644
index 000000000000..e604e5a5cd46
--- /dev/null
+++ b/gebabbel-0.4.patch
@@ -0,0 +1,7 @@
+--- src/MyMainWindow.cpp 2007-09-18 22:26:49.000000000 +0200
++++ src/MyMainWindow.cpp 2011-01-30 13:23:02.000000000 +0100
+@@ -221,3 +221,3 @@
+ MainToolBar = addToolBar( tr( "Main Toolbar" ) );
+- MainToolBar->setIconSize( QSize::QSize( 16, 16 ) );
++ MainToolBar->setIconSize( QSize( 16, 16 ) );
+ MainToolBar->setAllowedAreas( Qt::TopToolBarArea );
diff --git a/gebabbel.changelog b/gebabbel.changelog
new file mode 100644
index 000000000000..a4d1f2369232
--- /dev/null
+++ b/gebabbel.changelog
@@ -0,0 +1,3 @@
+2011-02-03 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+ * gebabbel 0.4-4
+ * moved to [community] with 37 AUR votes
diff --git a/gebabbel.desktop b/gebabbel.desktop
new file mode 100644
index 000000000000..027b52a83ba2
--- /dev/null
+++ b/gebabbel.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Gebabbel
+Exec=gebabbel
+Icon=gebabbel
+Type=Application
+Comment=GUI for gpsbabel
+Categories=Utility;Education; \ No newline at end of file