summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Korpel2015-06-08 23:12:24 +0200
committerMarcel Korpel2015-06-08 23:12:24 +0200
commit6c70dc8b2f22840683e3a4ad87c2cb9fa86edb51 (patch)
treef87c736eb5bb76d420148185cc815414c698eded
downloadaur-6c70dc8b2f22840683e3a4ad87c2cb9fa86edb51.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--gemistdownloader.sh2
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba100fc5f7dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gemistdownloader
+ pkgdesc = Download programmes from Dutch broadcasting companies
+ pkgver = 2.8.1.14_beta
+ pkgrel = 1
+ url = http://helpdeskweb.nl/gemistdownloader/mono
+ arch = any
+ license = CCPL:by-nc-nd
+ depends = mono
+ depends = ffmpeg
+ depends = sh
+ source = http://www.helpdeskweb.nl/mono_GemistDownloader_28114_beta.zip
+ source = gemistdownloader.sh
+ sha256sums = 9f5c784212d8a34475763e0641a9c72769a14027c65ae3009a22214e32d2a797
+ sha256sums = 08fa204eec19b630837409c66bfe087a21bcebffa57f14919f1b88435f70da3a
+
+pkgname = gemistdownloader
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed00367a2396
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Marcel Korpel <marcel[dot]korpel[at]gmail>
+
+_truepkgname=GemistDownloader
+pkgver=2.8.1.14_beta
+pkgname=${_truepkgname,,}
+_pkgver=${pkgver//.}
+pkgrel=1
+pkgdesc='Download programmes from Dutch broadcasting companies'
+arch=('any')
+url="http://helpdeskweb.nl/gemistdownloader/mono"
+license=('CCPL:by-nc-nd')
+depends=('mono' 'ffmpeg' 'sh')
+source=(http://www.helpdeskweb.nl/mono_${_truepkgname}_${_pkgver}.zip
+ ${pkgname}.sh)
+sha256sums=('9f5c784212d8a34475763e0641a9c72769a14027c65ae3009a22214e32d2a797'
+ '08fa204eec19b630837409c66bfe087a21bcebffa57f14919f1b88435f70da3a')
+
+package() {
+ cd "$srcdir"
+
+ install -Dm644 ${_truepkgname}.exe "${pkgdir}/usr/share/${pkgname}/${_truepkgname}.exe"
+ install -D ${pkgname}.sh "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/gemistdownloader.sh b/gemistdownloader.sh
new file mode 100644
index 000000000000..658fd76a60ca
--- /dev/null
+++ b/gemistdownloader.sh
@@ -0,0 +1,2 @@
+#/bin/sh
+exec mono /usr/share/gemistdownloader/GemistDownloader.exe "$@"