summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyrIng2015-10-03 16:35:16 +0200
committerCyrIng2015-10-03 16:35:16 +0200
commit1354e9b32cba0460ec5cf9effbeb811512296a3d (patch)
tree7fdf7c55c719ab3e44bd02674c5d09fa714ca39b
downloadaur-geogebra-installer.tar.gz
Initial commit: geogebra-installer
-rw-r--r--.SRCINFO28
-rw-r--r--ChangeLog42
-rw-r--r--PKGBUILD41
-rw-r--r--geogebra7
-rw-r--r--geogebra.install13
5 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7a9ebcc50db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = geogebra-installer
+ pkgdesc = Dynamic mathematics software with interactive graphics, algebra and spreadsheet
+ pkgver = 5.0.156.0
+ pkgrel = 1
+ url = http://www.geogebra.org/
+ install = geogebra.install
+ changelog = ChangeLog
+ arch = any
+ license = GPL3
+ license = CCPL:by-sa
+ license = CCPL:by-nc
+ makedepends = gendesk
+ depends = desktop-file-utils
+ depends = gsl
+ depends = hicolor-icon-theme
+ depends = java-runtime
+ depends = shared-mime-info
+ depends = xdg-utils
+ conflicts = geogebra
+ source = http://download.geogebra.org/installers/5.0/GeoGebra-Linux-Portable-5.0.156.0.tar.bz2
+ source = http://static.geogebra.org/images/geogebra-logo.svg
+ source = geogebra
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = geogebra-installer
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..cb927cca1e86
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,42 @@
+5.0.156.0-1:
+upstream update
+
+5.0.150.0-1:
+upstream update
+
+5.0.149.0-1:
+upstream update
+
+5.0.146.0-1:
+upstream update
+
+5.0.143.0-1:
+upstream update
+
+5.0.129.0-1:
+upstream update
+put icon back
+
+5.0.128.0-1:
+upstream update
+
+5.0.119.0-1:
+upstream update
+
+5.0.112.0-1:
+upstream update
+
+5.0.82.0-1:
+upstream update
+
+5.0.74.0-1:
+upstream update
+
+5.0.57.0-1:
+upstream update
+
+5.0.56.0-1:
+upstream update
+
+5.0.53.0-1:
+upstream update
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e9f3e8f313a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: CyrIng <labs[at]cyring[dot]fr>
+# Contributor: CyrIng <labs[at]cyring[dot]fr>
+pkgname=geogebra-installer
+pkgver=5.0.156.0
+pkgrel=1
+pkgdesc="Dynamic mathematics software with interactive graphics, algebra and spreadsheet"
+arch=('any')
+url='http://www.geogebra.org/'
+license=('GPL3' 'CCPL:by-sa' 'CCPL:by-nc')
+depends=('desktop-file-utils' 'gsl' 'hicolor-icon-theme' 'java-runtime'
+ 'shared-mime-info' 'xdg-utils')
+makedepends=('gendesk')
+conflicts=('geogebra')
+source=("http://download.geogebra.org/installers/5.0/GeoGebra-Linux-Portable-${pkgver}.tar.bz2"
+ "http://static.geogebra.org/images/geogebra-logo.svg"
+ "geogebra")
+install=geogebra.install
+changelog=ChangeLog
+
+prepare() {
+ gendesk -f -n --pkgname "geogebra" --pkgdesc "${pkgdesc}" \
+ --name="GeoGebra" \
+ --categories="Education;Science;Math" \
+ --mimetypes="application/vnd.geogebra.file;application/vnd.geogebra.tool"
+}
+
+package() {
+ cd "GeoGebra-Linux-Portable-${pkgver}"
+
+ install -Dm755 "${srcdir}/geogebra" "${pkgdir}/usr/bin/geogebra"
+ install -dm755 "${pkgdir}/usr/share/geogebra"
+ install "geogebra/"* -t "${pkgdir}/usr/share/geogebra/"
+
+ install -Dm644 "${srcdir}/geogebra.desktop" "${pkgdir}/usr/share/applications/geogebra.desktop"
+ install -Dm644 "${srcdir}/geogebra-logo.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/geogebra.svg"
+}
+
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
diff --git a/geogebra b/geogebra
new file mode 100644
index 000000000000..46fd3dfb818c
--- /dev/null
+++ b/geogebra
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+GG_PATH="/usr/share"
+export GG_CONFIG_PATH="$HOME"
+export JAVACMD="/usr/bin/java"
+
+exec "$GG_PATH/geogebra/geogebra" "$@"
diff --git a/geogebra.install b/geogebra.install
new file mode 100644
index 000000000000..f36700583f78
--- /dev/null
+++ b/geogebra.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-mime-database usr/share/mime/ > /dev/null
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}