summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-10-16 22:23:30 +0200
committerChristopher Arndt2023-10-16 22:23:30 +0200
commit647951c75a9cb7ee82458518c24ce19a4637215a (patch)
tree415dc46bc781eb8c61645799026a73c12ef9bbb6
parent633e9e38aa86b63dbc2b20b7afe835a7bf2d840f (diff)
downloadaur-geonkick-git.tar.gz
Fix url, source url, vst3 build, check function and doc file list
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
-rw-r--r--geonkick-vst3sdk-include-stdint.patch12
3 files changed, 11 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 032193b3370a..15714f8a5842 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = geonkick-git
pkgdesc = A free software percussion synthesizer (git version)
- pkgver = 2.10.0.r1199.990cb7ba
+ pkgver = 2.10.2.r34.228bba0
pkgrel = 1
- url = https://gitlab.com/geonkick/geonkick
+ url = https://geonkick.org
arch = x86_64
groups = lv2-plugins
groups = pro-audio
@@ -34,7 +34,7 @@ pkgbase = geonkick-git
conflicts = geonkick-lv2
conflicts = geonkick-standalone
conflicts = geonkick-vst3
- source = geonkick::git+https://gitlab.com/geonkick/geonkick.git
+ source = geonkick::git+https://gitlab.com/Geonkick-Synthesizer/geonkick.git
sha256sums = SKIP
pkgname = geonkick-git
diff --git a/PKGBUILD b/PKGBUILD
index d4a607fb6f5e..f358c21e98a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
_plugin_uri='http://geontime.com/geonkick'
_pkgname=geonkick
pkgname="${_pkgname}-git"
-pkgver=2.10.0.r1199.990cb7ba
+pkgver=2.10.2.r34.228bba0
pkgrel=1
pkgdesc='A free software percussion synthesizer (git version)'
arch=(x86_64)
-url='https://gitlab.com/geonkick/geonkick'
-license=(GPL3)
+url='https://geonkick.org'
+license=(GPL-3.0-or-later)
groups=(lv2-plugins pro-audio vst3-plugins)
depends=(gcc-libs glibc cairo hicolor-icon-theme libx11 libsndfile)
-makedepends=(cmake git jack lv2 rapidjson sord)
+makedepends=(cmake git jack lv2 rapidjson sord vst3sdk)
checkdepends=(lv2lint)
optdepends=(
'jack: for stand-alone application'
@@ -20,7 +20,7 @@ optdepends=(
)
provides=($_pkgname $_pkgname-common $_pkgname-lv2 $_pkgname-standalone $_pkgname-vst3)
conflicts=($_pkgname $_pkgname-common $_pkgname-lv2 $_pkgname-standalone $_pkgname-vst3)
-source=("$_pkgname::git+https://gitlab.com/geonkick/geonkick.git")
+source=("$_pkgname::git+https://gitlab.com/Geonkick-Synthesizer/geonkick.git")
sha256sums=('SKIP')
pkgver() {
@@ -35,15 +35,13 @@ build() {
-S $_pkgname \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DGKICK_VST3=ON \
+ -DVST3_SDK_PATH=/usr/src/vst3sdk \
-W no-dev
cmake --build $_pkgname-build
}
check() {
- cp -av $_pkgname-build/plugin/lv2/*.so $_pkgname/plugin/lv2/$_pkgname.lv2/
- lv2lint -Mpack -I $_pkgname/plugin/lv2/$_pkgname.lv2/ "$_plugin_uri"
- rm $_pkgname/plugin/lv2/$_pkgname.lv2/*.so
+ lv2lint -S nowarn -M pack -I $_pkgname/src/plugin/lv2/$_pkgname.lv2 "$_plugin_uri"
}
@@ -54,7 +52,7 @@ package() {
install -vDm 644 data/$_pkgname.desktop \
-t "$pkgdir"/usr/share/applications
# documentation
- install -vDm 644 README.md NEWS.md \
+ install -vDm 644 AUTHORS README.md CHANGELOG.md \
-t "$pkgdir"/usr/share/doc/$pkgname
install -vDm 644 doc/*.{md,png} \
-t "$pkgdir"/usr/share/doc/$pkgname
diff --git a/geonkick-vst3sdk-include-stdint.patch b/geonkick-vst3sdk-include-stdint.patch
deleted file mode 100644
index 93459cff3fd3..000000000000
--- a/geonkick-vst3sdk-include-stdint.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/3rdparty/vst3_sdk/public.sdk/source/vst/utility/stringconvert.h b/3rdparty/vst3_sdk/public.sdk/source/vst/utility/stringconvert.h
-index ff910aaa..28c3681d 100644
---- a/3rdparty/vst3_sdk/public.sdk/source/vst/utility/stringconvert.h
-+++ b/3rdparty/vst3_sdk/public.sdk/source/vst/utility/stringconvert.h
-@@ -37,6 +37,7 @@
- #pragma once
-
- #include "pluginterfaces/vst/vsttypes.h"
-+#include <cstdint>
- #include <string>
-
- //------------------------------------------------------------------------