summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarendra Bharathi C V2024-04-09 14:22:42 -0400
committerNarendra Bharathi C V2024-04-09 14:22:42 -0400
commit36797702b300d7098e9eb84545b782d26f9e768b (patch)
tree760db1e03ec2b389bd2b6107a05f5d68ad2a42df
parentbe4ae9ccead20932684dbec1e440c744250171a1 (diff)
downloadaur-gerbil-scheme-git.tar.gz
Unset CFLAGS and CXXFLAGS
The default CFLAGS provided with Archlinux uses -O2 which overrides -O1 preferred by upstream. -O2 causes build to fail. This change unsets CFLAGS from Archlinux to use tuned flags from upstream.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b09c912c548b..e1739d13f027 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gerbil-scheme-git
pkgdesc = Gerbil is an opinionated dialect of Scheme designed for Systems Programming, with a state of the art macro and module system on top of the Gambit runtime.
- pkgver = v0.18.1_75_gdf339651
+ pkgver = v0.18.1_87_g1ccf1302
pkgrel = 1
url = https://cons.io
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 67a276d8828e..4f0323e6d6c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: cvnb <narendrabharathi@gmail.com>
pkgname=gerbil-scheme-git
_pkgname=gerbil
-pkgver=v0.18.1_75_gdf339651
+pkgver=v0.18.1_87_g1ccf1302
pkgrel=1
pkgdesc="Gerbil is an opinionated dialect of Scheme designed for Systems Programming, with a state of the art macro and module system on top of the Gambit runtime."
arch=(x86_64 i686 aarch64)
@@ -24,6 +24,7 @@ pkgver() {
build() {
cd "$_pkgname"
+ unset CFLAGS CXXFLAGS
./configure --prefix=/opt/gerbil
make
}