summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2021-07-06 23:47:06 +0200
committerAdrien Prost-Boucle2021-07-06 23:47:06 +0200
commit4336f55edfb6f594694fca6d58e2a1307fe4b253 (patch)
treef7028865b4139ada26b7e588049d032489a7fe68
parent67cdbb16f332868c217e0ffc8a007e7001aedcf4 (diff)
downloadaur-4336f55edfb6f594694fca6d58e2a1307fe4b253.tar.gz
Fix compilation error due to default makepkg default options
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2afc5428a498..b02fd3c1259a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Apr 26 20:47:32 UTC 2021
+# Tue Jul 6 21:45:50 UTC 2021
pkgbase = ghdl-gcc-git
pkgdesc = VHDL simulator - GCC back-end
- pkgver = 2.0.0dev.r6204.gfcd93aa12
+ pkgver = 2.0.0dev.r6467.g1285cbfce
pkgrel = 1
url = https://github.com/ghdl/ghdl
install = ghdl.install
@@ -16,8 +16,8 @@ pkgbase = ghdl-gcc-git
license = GPL2
makedepends = git
depends = gcc-ada
- provides = ghdl=2.0.0dev.r6204.gfcd93aa12
- provides = ghdl-git=2.0.0dev.r6204.gfcd93aa12
+ provides = ghdl=2.0.0dev.r6467.g1285cbfce
+ provides = ghdl-git=2.0.0dev.r6467.g1285cbfce
conflicts = ghdl
conflicts = ghdl-llvm-git
conflicts = ghdl-mcode-git
diff --git a/PKGBUILD b/PKGBUILD
index 99fdd6cd8a4e..466da1bb6894 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrien Prost-Boucle <adrien.prost-boucle@laposte.net>
pkgname=ghdl-gcc-git
-pkgver=2.0.0dev.r6204.gfcd93aa12
+pkgver=2.0.0dev.r6467.g1285cbfce
pkgrel=1
arch=('x86_64' 'i686' 'pentium4' 'arm' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='VHDL simulator - GCC back-end'
@@ -94,6 +94,14 @@ build() {
#CFLAGS=${DEBUG_CFLAGS/-pipe/}
#CXXFLAGS=${DEBUG_CXXFLAGS/-pipe/}
+ # 2021-07-06 Fix proposed in AUR comment by runecaster
+ # Using -Werror=format-security causes compilation failures : -Wformat -Werror=format-security
+ CFLAGS=${CFLAGS/-Wformat -Werror=format-security/}
+ CXXFLAGS=${CXXFLAGS/-Wformat -Werror=format-security/}
+
+ msg "Using CFLAGS .... $CFLAGS"
+ msg "Using CXXFLAGS .. $CXXFLAGS"
+
"${srcdir}"/gcc-${_gccver}/configure \
--prefix=/usr \
--libdir=/usr/lib \
@@ -174,4 +182,7 @@ package() {
ln -s "$_gso" "${pkgdir}/usr/lib/libghdl.so"
fi
+ # GTKWave has always installed binary ghwdump, now ghdl does it too
+ # While awaiting for the two projects to agree, you can prevent install of ghwdump here
+ #rm -f "${pkgdir}/usr/bin/ghwdump"
}