summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2021-04-26 22:49:46 +0200
committerAdrien Prost-Boucle2021-04-26 22:49:46 +0200
commit67cdbb16f332868c217e0ffc8a007e7001aedcf4 (patch)
tree1ad95f160a13c62ed26b583cc43628f9cb85c43e
parente0cfbb961e54daadd98c37a1565685dc56971258 (diff)
downloadaur-67cdbb16f332868c217e0ffc8a007e7001aedcf4.tar.gz
Fix license and architectures, update to gcc 10.3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD13
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f5502141175..2afc5428a498 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,33 @@
# Generated by mksrcinfo v8
-# Tue Mar 2 21:20:32 UTC 2021
+# Mon Apr 26 20:47:32 UTC 2021
pkgbase = ghdl-gcc-git
pkgdesc = VHDL simulator - GCC back-end
- pkgver = 2.0.0dev.r6030.ga03aeddd
+ pkgver = 2.0.0dev.r6204.gfcd93aa12
pkgrel = 1
url = https://github.com/ghdl/ghdl
install = ghdl.install
- arch = any
- license = GPLv2
+ arch = x86_64
+ arch = i686
+ arch = pentium4
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL2
makedepends = git
depends = gcc-ada
- provides = ghdl=2.0.0dev.r6030.ga03aeddd
- provides = ghdl-git=2.0.0dev.r6030.ga03aeddd
+ provides = ghdl=2.0.0dev.r6204.gfcd93aa12
+ provides = ghdl-git=2.0.0dev.r6204.gfcd93aa12
conflicts = ghdl
conflicts = ghdl-llvm-git
conflicts = ghdl-mcode-git
options = !emptydirs
options = staticlibs
source = ghdl::git://github.com/ghdl/ghdl.git
- source = ftp://ftp.gnu.org/gnu/gcc/gcc-10.2.0/gcc-10.2.0.tar.xz
+ source = ftp://ftp.gnu.org/gnu/gcc/gcc-10.3.0/gcc-10.3.0.tar.xz
source = http://isl.gforge.inria.fr/isl-0.23.tar.bz2
sha256sums = SKIP
- sha256sums = b8dd4368bb9c7f0b98188317ee0254dd8cc99d1e3a18d0ff146c855fe16c1d8c
+ sha256sums = 64f404c1a650f27fc33da242e1f2df54952e3963a49e06e73f6940f3223ac344
sha256sums = c58922c14ae7d0791a77932f377840890f19bc486b653fa64eba7f1026fb214d
pkgname = ghdl-gcc-git
diff --git a/PKGBUILD b/PKGBUILD
index a2a83322a000..99fdd6cd8a4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,12 @@
# Maintainer: Adrien Prost-Boucle <adrien.prost-boucle@laposte.net>
-# This PKGBUILD file is inspired from the package ghdl
-# https://aur.archlinux.org/packages/ghdl/
pkgname=ghdl-gcc-git
-pkgver=2.0.0dev.r6030.ga03aeddd
+pkgver=2.0.0dev.r6204.gfcd93aa12
pkgrel=1
-arch=('any')
+arch=('x86_64' 'i686' 'pentium4' 'arm' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='VHDL simulator - GCC back-end'
url='https://github.com/ghdl/ghdl'
-license=('GPLv2')
+license=('GPL2')
provides=("ghdl=$pkgver" "ghdl-git=$pkgver")
conflicts=('ghdl' 'ghdl-llvm-git' 'ghdl-mcode-git')
@@ -17,7 +15,7 @@ depends=('gcc-ada')
install=ghdl.install
options=(!emptydirs staticlibs)
-_gccver=10.2.0
+_gccver=10.3.0
_islver=0.23
source=(
@@ -27,7 +25,7 @@ source=(
)
sha256sums=(
'SKIP'
- 'b8dd4368bb9c7f0b98188317ee0254dd8cc99d1e3a18d0ff146c855fe16c1d8c'
+ '64f404c1a650f27fc33da242e1f2df54952e3963a49e06e73f6940f3223ac344'
'c58922c14ae7d0791a77932f377840890f19bc486b653fa64eba7f1026fb214d'
)
@@ -54,7 +52,6 @@ prepare() {
cd "${srcdir}/ghdl"
- # Note : Add --enable-openieee to use free (but not complete) implementation of IEEE VHDL libs
./configure \
--prefix=/usr \
--with-gcc="${srcdir}/gcc" \