summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2020-03-23 23:58:23 +0100
committerAdrien Prost-Boucle2020-03-23 23:58:23 +0100
commit6d5ae96569510c0a627ebbc54b3b0df0bab8042e (patch)
tree988b10120dbf1083b419ba5b84b7722c0b65fdf2
parent2c936cc8e33fcb75483006770ea83e3086227173 (diff)
downloadaur-6d5ae96569510c0a627ebbc54b3b0df0bab8042e.tar.gz
Update versions of gcc and isl
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e4f6ac704d1..f105ee12621a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Dec 2 23:24:11 UTC 2019
+# Mon Mar 23 22:57:00 UTC 2020
pkgbase = ghdl-gcc-git
pkgdesc = VHDL simulator - GCC back-end
- pkgver = 0.37dev.r4250.gd11ad228
+ pkgver = 1.0dev.r4725.g89826463
pkgrel = 1
url = https://github.com/ghdl/ghdl
install = ghdl.install
@@ -10,19 +10,19 @@ pkgbase = ghdl-gcc-git
license = GPLv2
makedepends = gcc-ada
makedepends = git
- provides = ghdl=0.37dev.r4250.gd11ad228
- provides = ghdl-git=0.37dev.r4250.gd11ad228
+ provides = ghdl=1.0dev.r4725.g89826463
+ provides = ghdl-git=1.0dev.r4725.g89826463
conflicts = ghdl
conflicts = ghdl-llvm-git
conflicts = ghdl-mcode-git
options = !emptydirs
options = staticlibs
source = ghdl::git://github.com/ghdl/ghdl.git
- source = ftp://ftp.gnu.org/gnu/gcc/gcc-8.3.0/gcc-8.3.0.tar.xz
- source = http://isl.gforge.inria.fr/isl-0.20.tar.bz2
+ source = ftp://ftp.gnu.org/gnu/gcc/gcc-9.2.0/gcc-9.2.0.tar.xz
+ source = http://isl.gforge.inria.fr/isl-0.22.1.tar.bz2
sha256sums = SKIP
- sha256sums = 64baadfe6cc0f4947a84cb12d7f0dfaf45bb58b7e92461639596c21e02d97d2c
- sha256sums = b587e083eb65a8b394e833dea1744f21af3f0e413a448c17536b5549ae42a4c2
+ sha256sums = ea6ef08f121239da5695f76c9b33637a118dcf63e24164422231917fa61fb206
+ sha256sums = 1a668ef92eb181a7c021e8531a3ca89fd71aa1b3744db56f68365ab0a224c5cd
pkgname = ghdl-gcc-git
diff --git a/PKGBUILD b/PKGBUILD
index 30daabfb8311..1b4f0ed1e69c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# https://aur.archlinux.org/packages/ghdl/
pkgname=ghdl-gcc-git
-pkgver=0.37dev.r4250.gd11ad228
+pkgver=1.0dev.r4725.g89826463
pkgrel=1
arch=('any')
pkgdesc='VHDL simulator - GCC back-end'
@@ -16,8 +16,8 @@ makedepends=('gcc-ada' 'git')
install=ghdl.install
options=(!emptydirs staticlibs)
-_gccver=8.3.0
-_islver=0.20
+_gccver=9.2.0
+_islver=0.22.1
source=(
"ghdl::git://github.com/ghdl/ghdl.git"
@@ -26,8 +26,8 @@ source=(
)
sha256sums=(
'SKIP'
- '64baadfe6cc0f4947a84cb12d7f0dfaf45bb58b7e92461639596c21e02d97d2c'
- 'b587e083eb65a8b394e833dea1744f21af3f0e413a448c17536b5549ae42a4c2'
+ 'ea6ef08f121239da5695f76c9b33637a118dcf63e24164422231917fa61fb206'
+ '1a668ef92eb181a7c021e8531a3ca89fd71aa1b3744db56f68365ab0a224c5cd'
)
pkgver() {
@@ -40,7 +40,7 @@ pkgver() {
#local _gitver=`git log -n 1 --date=short | sed -n -e 's/.*Date:\s*\([0-9-]*\).*/\1/p' | tr -d -`
# Revision number
local _gitrev=`git rev-list --count HEAD`
- # Short hash oatest commit
+ # Short hash of latest commit
local _githash=`git rev-parse --short HEAD`
#echo $_distver.git$_gitver;
@@ -70,9 +70,10 @@ prepare() {
# Do not run fixincludes - FIXME Why?
sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
- # Arch Linux installs libraries in /lib
# FIXME How to fix this for all architectures ?
+ # Arch Linux installs libraries in /lib
sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64
+ # Arch Linux ARM installs aarch64 libraries /lib
sed -i '/lp64=/s/lib64/lib/' gcc/config/aarch64/t-aarch64-linux
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"